프로젝트 (AccessToSQL) 만들기 및 관리Creating and Managing Projects (AccessToSQL)

Access 데이터베이스를 마이그레이션하려면 SQL ServerSQL Server 또는 SQL Azure 있습니다 SSMA 프로젝트를 먼저 만들어야 합니다.To migrate Access databases to SQL ServerSQL Server or SQL Azure, you must first create an SSMA project. 마이그레이션하려는 Access 데이터베이스에 대 한 메타 데이터가 포함 된 파일이 프로젝트 SQL ServerSQL Server 또는 SQL Azure 대상 인스턴스에 대 한 메타 데이터 SQL ServerSQL Server 마이그레이션된 개체 및 데이터를 받을 SQL Azure 또는 SQL ServerSQL Server 연결 정보 및 프로젝트 설정 합니다.The project is a file that contains metadata about the Access databases that you want to migrate to SQL ServerSQL Server or SQL Azure, metadata about the target instance of SQL ServerSQL Server or SQL Azure that will receive the migrated objects and data, SQL ServerSQL Server connection information, and project settings.

기본 프로젝트 설정을 검토합니다.Reviewing Default Project Settings

SSMA는 변환 및 데이터베이스 개체를 동기화 하 고 데이터를 변환 하기 위한 몇 가지 옵션을 포함 합니다.SSMA contains several options for converting and synchronizing database objects and for converting data. 이러한 옵션에 대 한 기본 설정은 많은 사용자에 적합합니다.The default setting for these options is appropriate for many users. 그러나 새 SSMA 프로젝트를 만들기 전에 해야 옵션 검토을 원하는 경우 모든 새 프로젝트에 사용할 기본 설정을 변경 합니다.However, before you create a new SSMA project, you should review the options and, if you want to, change the default settings that will be used for all your new projects.

기본 프로젝트 설정을 검토 하려면To review default project settings

  1. 도구 메뉴에서 기본 프로젝트 설정합니다.On the Tools menu, select Default Project Settings.

  2. 라는 프로젝트 형식을 선택 마이그레이션 대상 버전 설정을 볼 / 변경 하려는 및 클릭에 대 한 드롭다운 일반 탭 합니다.Select the project type in Migration Target Version drop down for which settings are to be viewed/ changed and then click General tab.

  3. 왼쪽된 창에서 클릭 변환합니다.In the left pane, click Conversion.

  4. 오른쪽 창에서 옵션을 검토 합니다.In the right pane, review the options. 이러한 옵션에 대 한 자세한 내용은 참조 하세요. 프로젝트 설정 (변환)합니다.For more information about these options, see Project Settings (Conversion).

  5. 필요에 따라 옵션을 변경 합니다.Change options as necessary.

  6. 에 대 한 이전 단계를 반복 합니다 마이그레이션GUI, 및 형식 매핑 페이지입니다.Repeat the previous steps for the Migration, GUI, and Type Mapping pages.

참고 SQL Azure 마이그레이션 프로젝트를 만드는 동안 선택한 경우에 SQL Azure 설정이 제공 됩니다.Note SQL Azure settings will be available only when you select Migration to SQL Azure while creating a project.

새 프로젝트 만들기Creating New Projects

SSMA는 기본 프로젝트를 로드 하지 않고 시작 합니다.SSMA starts without loading a default project. Access 데이터베이스에서 데이터를 마이그레이션하도록 SQL ServerSQL Server 또는 SQL Azure 프로젝트를 만들어야 합니다.To migrate data from Access databases to SQL ServerSQL Server or SQL Azure, you must create a project.

새 프로젝트를 만들려면To create a new project

  1. 파일 메뉴에서 새 프로젝트를 선택합니다.On the File menu, select New Project.

    새 프로젝트 대화 상자가 나타납니다.The New Project dialog box appears.

  2. 이름 입력란에 프로젝트 이름을In the Name box, enter a name for your project.

  3. 위치 상자에 입력 하거나 프로젝트에 대 한 폴더를 선택 합니다.In the Location box, enter or select a folder for the project

  4. 마이그레이션에 드롭에서 다운, SQL Server 2005 중 하나를 선택 / SQL Server 2008 / SQL Server 2012 / SQL Server 2014 / SQL Server 2016 / Azure SQL DB를 클릭 하 고 확인합니다.In the Migration To drop down, select one of SQL Server 2005/ SQL Server 2008/ SQL Server 2012/ SQL Server 2014/ SQL Server 2016/ Azure SQL DB, and then click OK.

SSMA는 프로젝트 파일을 만듭니다.SSMA creates the project file. 이제 다음 단계를 수행할 수 있습니다 하나 이상의 Access 데이터베이스 추가합니다.You can now perform the next step of adding one or more Access databases.

사용자 지정 프로젝트 설정Customizing Project Settings

또한 모든 새 SSMA 프로젝트에 적용 하는 기본 프로젝트 설정을 정의 하는 것 외에도 각 프로젝트에 대 한 설정을 사용자 지정할 수 있습니다.In addition to defining default project settings, which apply to all new SSMA projects, you can also customize the settings for each project. 자세한 내용은 설정 변환 및 마이그레이션 옵션합니다.For more information, see Setting Conversion and Migration Options.

원본 및 대상 데이터베이스 간의 데이터 형식 매핑 사용자 지정 하는 경우 프로젝트, 데이터베이스 또는 개체 수준에서 매핑을 정의할 수 있습니다.When you customize data type mappings between source and target databases, you can define mappings at the project, database, or object level. 형식 매핑에 대 한 자세한 내용은 참조 하세요. 매핑 소스 및 대상 데이터 형식합니다.For more information about type mapping, see Mapping Source and Target Data Types.

프로젝트를 저장합니다.Saving Projects

프로젝트를 저장 하면 SSMA 프로젝트 설정 및 선택적으로 프로젝트 파일에는 데이터베이스 메타 데이터를 유지 합니다.When you save a project, SSMA persists the project settings, and optionally the database metadata, to the project file.

프로젝트를 저장 하려면To save a project

  • 파일 메뉴에서 프로젝트 저장합니다.On the File menu, select Save Project.

    데이터베이스 프로젝트 내에서 변경 또는 변환 되지 않은 경우 프로젝트에 메타 데이터를 저장 하 SSMA 메시지가 나타납니다.If databases within the project have changed or have not been converted, SSMA will prompt you to save metadata into the project. 메타 데이터를 저장 하면 오프 라인으로 작업 합니다.Saving metadata lets you work offline. 또한 기술 지원 요원을 비롯 한 다른 사용자에 게 전체 프로젝트 파일을 보낼 수 있습니다.It also lets you send a complete project file to other people, including technical support personnel. 메타 데이터를 저장 하 라는 메시지가 나타나면 다음을 수행 합니다.If you are prompted to save metadata, do the following:

    1. 각 데이터베이스의 상태를 보여 주는 메타 데이터 누락, 데이터베이스 이름 옆의 확인란을 선택 합니다.For each database that shows a status of Metadata missing, select the check box next to the database name.

      메타 데이터를 저장 하면 몇 분 정도 걸릴 수 있습니다.Saving metadata might take several minutes. 이 시점에서 메타 데이터를 저장 하지 않을 경우 모든 확인란을 선택 하지 마십시오.If you do not want to save metadata at this point, do not select any check boxes.

    2. 저장을 클릭합니다.Click Save.

      SSMA는 Access 스키마를 구문 분석 하 고 프로젝트 파일에 메타 데이터를 저장 합니다.SSMA will parse the Access schemas and save the metadata to the project file.

열린 프로젝트Opening Projects

프로젝트를 열면에서 연결이 끊어지도록 SQL ServerSQL Server 또는 SQL Azure입니다.When you open a project, it is disconnected from SQL ServerSQL Server or SQL Azure. 이 기능을 사용 하면 오프 라인으로 작업할 수 있습니다.This lets you work offline. 메타 데이터 로드 데이터베이스 개체를 업데이트 하려면 SQL ServerSQL Server 또는 SQL Azure입니다.To update metadata load database objects into SQL ServerSQL Server or SQL Azure. 데이터를 마이그레이션하려면 다시 연결 해야 SQL ServerSQL Server 또는 SQL Azure입니다.To migrate data, you must reconnect to SQL ServerSQL Server or SQL Azure.

프로젝트를 열려면To open a project

  1. 다음 절차 중 하나를 사용 합니다.Use one of the following procedures:

    • 파일 메뉴에서 최근에 사용한 프로젝트, 다음 열려는 프로젝트를 선택 하 고 있습니다.On the File menu, point to Recent Projects, and then select the project you want to open.

    • 파일 메뉴에서 프로젝트 열기.a2ssproj 프로젝트 파일 찾기, 파일을 선택 및 클릭 열기.On the File menu, select Open Project, locate the .a2ssproj project file, select the file, and then click Open.

  2. 에 다시 연결할 SQL ServerSQL Server파일 메뉴에서 SQL Server에 다시 연결.To reconnect to SQL ServerSQL Server, on the File menu, select Reconnect to SQL Server.

  3. SQL Azure 다시 연결 합니다 파일 메뉴에서 SQL Azure 다시 연결 합니다.To reconnect to SQL Azure, on the File menu, select Reconnect to SQL Azure.

다음 단계Next Step

마이그레이션 프로세스에서 다음 단계 하나 이상의 Access 데이터베이스 추가합니다.The next step in the migration process is to add one or more Access databases.

관련 항목See Also

SQL Server에 대 한 액세스 데이터베이스 마이그레이션Migrating Access Databases to SQL Server
Access 데이터베이스 파일 추가 및 제거Adding and Removing Access Database Files