Visual Studio의 바로 가기 키

해당 바로 가기 키를 선택하여 Visual Studio의 다양한 명령과 창에 액세스할 수 있습니다. 이 페이지에는 Visual Studio를 설치할 때 선택한 일반 프로필의 기본 명령 바로 가기가 나와 있습니다. 선택한 프로필과 관계없이 옵션 대화 상자를 열고 환경 노드를 확장한 다음, 키보드 를 선택하여 명령의 바로 가기를 확인할 수 있습니다. 또한 지정한 명령에 다른 바로 가기를 할당하여 바로 가기를 사용자 지정할 수도 있습니다.

일반적인 바로 가기 키 목록과 기타 생산성 정보는 다음을 참조하세요.

Visual Studio의 접근성에 대한 자세한 내용은 접근성 팁과 요령방법: 단독으로 키보드 사용을 참조하세요.

인쇄 가능한 바로 가기 키 참고 자료

클릭하여 Visual Studio용 인쇄 가능한 바로 가기 키 참고 자료를 확인하세요.

인쇄 가능한 바로 가기 키 참고 자료.

이 섹션의 모든 바로 가기 키는 달리 지정하지 않는 한 전역적으로 적용됩니다. ‘전역’ 컨텍스트는 Visual Studio의 모든 도구 창에서 바로 가기를 적용할 수 있음을 의미합니다.

참고

옵션 대화 상자를 열고 환경 노드를 확장한 다음 키보드를 선택하여 모든 명령의 바로 가기를 확인 할 수 있습니다.

명령 바로 가기 키 명령 ID
솔루션 빌드 Ctrl+Shift+B 빌드.솔루션빌드
취소 Ctrl+Break 빌드.취소
Compile Ctrl+F7 빌드.컴파일
솔루션에서 코드 분석 실행 Alt+F11 Build.RunCodeAnalysisonSolution
명령 바로 가기 키[특수 컨텍스트] 명령 ID
함수에서 중단 Ctrl+B 디버그.함수에서중단
모두 중단 Ctrl+Alt+Break 디버그.모두중단
모든 중단점 삭제 Ctrl+Shift+F9 디버그.모든중단점삭제
예외 Ctrl+Alt+E 디버그.예외
간략한 조사식 Ctrl+Alt+Q

또는 Shift+F9
디버그.간략한조사식
다시 시작 Ctrl+Shift+F5 디버그.다시시작
커서까지 실행 Ctrl+F10 디버그.커서까지실행
다음 문 설정 Ctrl+Shift+F10 디버그.다음문설정
시작 F5 디버그.시작
디버그하지 않고 시작 Ctrl+F5 디버그.디버깅하지않고시작
한 단계씩 코드 실행 F11 디버그.한단계씩코드실행
프로시저 나가기 Shift+F11 디버그.프로시저나가기
프로시저 단위 실행 F10 디버그.프로시저단위실행
디버깅 중지 Shift+F5 디버그.디버깅중지
중단점 설정/해제 F9 디버그.중단점설정해제
명령 바로 가기 키[특수 컨텍스트] 명령 ID
구분선 Enter[텍스트 편집기, 보고서 디자이너, Windows Forms 디자이너]

또는 Shift+Enter[텍스트 편집기]
편집.구분선
정의 부분만 보이기 Ctrl+M, Ctrl+O[텍스트 편집기] 편집.정의부분만보이기
선택 영역을 주석으로 처리 Ctrl+K, Ctrl+C[텍스트 편집기] 편집.선택영역을주석으로처리
단어 자동 완성 Alt+오른쪽 화살표 [텍스트 편집기, 워크플로 디자이너]

또는 Ctrl+스페이스바 [텍스트 편집기, 워크플로 디자이너]

또는 Ctrl+K, W[워크플로 디자이너]

또는 Ctrl+K, Ctrl+W[워크플로 디자이너]
편집.단어자동완성
복사 Ctrl+C

또는 Ctrl+Insert
편집.복사
잘라내기 Ctrl+X

또는 Shift+Delete
편집.잘라내기
DELETE Delete[팀 탐색기]

또는 Shift+Delete[시퀀스 다이어그램, UML 동작 다이어그램, 레이어 다이어그램]

또는 Ctrl+Delete[클래스 다이어그램]
편집.삭제
찾기 Ctrl+F 편집.찾기
모든 참조 찾기 Shift+F12 편집.모든참조찾기
파일에서 찾기 Ctrl+Shift+F 편집.파일에서찾기
다음 찾기 F3 편집.다음찾기
다음 선택 찾기 Ctrl+F3 편집.다음찾기선택
문서 서식 Ctrl+K, Ctrl+D[텍스트 편집기] 편집.문서서식
선택 영역 서식 Ctrl+K, Ctrl+F[텍스트 편집기] 편집.선택영역서식
다음으로 이동 Ctrl+G 편집.이동
선언으로 이동 Ctrl+F12 편집.선언으로이동
정의로 이동 F12 편집.정의로이동
찾기 콤보 상자로 이동 Ctrl+D 편집.찾기콤보상자로이동
다음 위치로 이동 F8 편집.다음위치로이동
코드 조각 삽입 Ctrl+K, Ctrl+X 편집.코드조각삽입
삽입 탭 Tab[보고서 디자이너, Windows Forms 디자이너, 텍스트 편집기] 편집.탭삽입
줄 잘라내기 Ctrl+L[텍스트 편집기] 편집.줄잘라내기
한 줄 아래까지 열 확장 선택 Shift+Alt+아래쪽 화살표[텍스트 편집기] 편집.한줄아래까지열확장선택
위쪽 줄 열기 Ctrl+Enter[텍스트 편집기] 편집.위쪽줄열기
멤버 목록 Ctrl+J[텍스트 편집기, 워크플로 디자이너]

또는 Ctrl+K, Ctrl+L[워크플로 디자이너]

또는 Ctrl+K, L[워크플로 디자이너]
편집.멤버목록
다음 탐색 Ctrl+, 편집.탐색
파일 열기 Ctrl+Shift+G Edit.OpenFile
겹쳐쓰기 모드 Insert[텍스트 편집기] 편집.겹쳐쓰기모드
매개 변수 정보 Ctrl+Shift+스페이스바[텍스트 편집기, 워크플로 디자이너]

또는 Ctrl+K, Ctrl+P[워크플로 디자이너]

또는 Ctrl+K, P[워크플로 디자이너]
편집.매개변수정보
붙여넣기 Ctrl+V

또는 Shift+Insert
편집.붙여넣기
정의 피킹 Alt+F12[텍스트 편집기] Edit.PeekDefinition
다시 실행 Ctrl+Y

또는 Shift+Alt+Backspace

또는 Ctrl+Shift+Z
편집.다시실행
바꾸기 Ctrl+H 편집.바꾸기
모두 선택 Ctrl+A 편집.모두선택
현재 단어 선택 Ctrl+W[텍스트 편집기] 편집.현재단어선택
선택 취소 Esc[텍스트 편집기, 보고서 디자이너, 설정 디자이너, Windows Forms 디자이너, 관리되는 리소스 편집기] 편집.선택취소
코드 감싸기 Ctrl+K, Ctrl+S
(Visual Studio 2019 및 이전 버전에서만 사용 가능)
편집.코드감싸기
왼쪽으로 탭 이동 Shift+Tab[텍스트 편집기, 보고서 디자이너, Windows Forms 디자이너] 편집.왼쪽으로탭이동
전체 개요 영역 표시/숨기기 Ctrl+M, Ctrl+L[텍스트 편집기] 편집.전체개요표시숨기기
책갈피 설정/해제 Ctrl+K, Ctrl+K[텍스트 편집기] 편집.책갈피설정해제
완료 모드 설정/해제 Ctrl+Alt+스페이스바[텍스트 편집기] 편집.완료모드설정/해제
개요 확장/축소 Ctrl+M, Ctrl+M[텍스트 편집기] 편집.개요확장축소
선택 영역의 주석 처리 제거 Ctrl+K, Ctrl+U[텍스트 편집기] 편집.선택영역의주석처리제거
실행 취소 Ctrl+Z

또는 Alt+백스페이스
편집.실행취소
끝까지 단어 삭제 Ctrl+Delete[텍스트 편집기] 편집.끝까지단어삭제
시작까지 단어 삭제 Ctrl+백스페이스[텍스트 편집기] 편집.시작까지단어삭제
명령 바로 가기 키[특수 컨텍스트] 명령 ID
종료 Alt+F4 File.Exit
새 파일 Ctrl+N 파일.새파일
새 프로젝트 Ctrl+Shift+N 파일.새프로젝트
새 웹 사이트 Shift+Alt+N 파일.새웹사이트
파일 열기 Ctrl+O 파일.파일열기
프로젝트 열기 Ctrl+Shift+O 파일.프로젝트열기
웹 사이트 열기 Shift+Alt+O 파일.웹사이트열기
이름 바꾸기 F2[팀 탐색기] 파일.이름바꾸기
모두 저장 Ctrl+Shift+S 파일.모두저장
선택한 항목 저장 Ctrl+S 파일.선택한항목저장
브라우저에서 보기 Ctrl+Shift+W 파일.브라우저에서보기
명령 바로 가기 키[특수 컨텍스트] 명령 ID
기존 항목 추가 Shift+Alt+A 프로젝트.기존항목추가
새 항목 추가 Ctrl+Shift+A 프로젝트.새항목추가
명령 바로 가기 키[특수 컨텍스트] 명령 ID
메서드 추출 Ctrl+R, Ctrl+M 리팩터링.메서드추출
명령 바로 가기 키[특수 컨텍스트] 명령 ID
프로세스에 연결 Ctrl+Alt+P Tools.AttachtoProcess
명령 바로 가기 키[특수 컨텍스트] 명령 ID
클래스 뷰 Ctrl+Shift+C 보기.클래스뷰
레이블 편집 F2 보기.레이블편집
오류 목록 Ctrl+\, Ctrl+E

또는 Ctrl+\, E
보기.오류목록
뒤로 탐색 Ctrl+- 보기.뒤로탐색
앞으로 탐색 Ctrl+Shift+- 보기.앞으로탐색
개체 브라우저 Ctrl+Alt+J 보기.개체브라우저
출력 Ctrl+Alt+O 보기.출력
속성 창 F4 보기.속성창
새로 고침 F5[팀 탐색기] View.Refresh
서버 탐색기 Ctrl+Alt+S 보기.서버탐색기
스마트 태그 표시 Ctrl+.

또는 Shift+Alt+F10[HTML 편집기 디자인 뷰]
보기.스마트태그표시
솔루션 탐색기 Ctrl+Alt+L 보기.솔루션탐색기
TFS 팀 탐색기 Ctrl+\, Ctrl+M View.TfsTeamExplorer
도구 상자 Ctrl+Alt+X 보기.도구상자
코드 보기 Enter[클래스 다이어그램]

또는 F7[설정 디자이너]
보기.코드보기
뷰 디자이너 Shift+F7[HTML 편집기 소스 뷰] 보기.디자이너보기
명령 바로 가기 키[특수 컨텍스트] 명령 ID
문서 창 활성화 Esc 창.문서창활성화
문서 창 닫기 Ctrl+F4 창.문서창닫기
다음 문서 창 Ctrl+F6 창.다음문서창
다음 문서 창으로 이동 Ctrl+Tab 창.다음문서창으로이동
다음 분할 창 F6 창.다음분할창

전역 바로 가기

이러한 바로 가기 키는 전역 이므로 Visual Studio 창에 포커스가 있을 때 사용할 수 있습니다.

분석: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
뒤로 탐색 Shift+Alt+3 Analyze.NavigateBackward
앞으로 탐색 Shift+Alt+4 Analyze.NavigateForward

아키텍처: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
새 다이어그램 Ctrl+\, Ctrl+N Architecture.NewDiagram

Azure: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
모바일 서비스 스크립트 작업 다시 시도 Ctrl+Num *, Ctrl+R WindowsAzure.RetryMobileServiceScriptOperation
모바일 서비스 스크립트 오류 세부 정보 표시 Ctrl+Num *, Ctrl+D WindowsAzure.ShowMobileServiceScriptErrorDetails

빌드: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
선택 영역 빌드 Ctrl+B(Visual Studio 2019) 빌드.선택 영역 빌드
솔루션 빌드 Ctrl+Shift+B 빌드.솔루션빌드
취소 Ctrl+Break 빌드.취소
Compile Ctrl+F7 빌드.컴파일
솔루션에서 코드 분석 실행 Alt+F11 Build.RunCodeAnalysisonSolution

클래스 뷰 상황에 맞는 메뉴: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
속성 Alt+Enter ClassViewContextMenus.ClassViewMultiselectProjectreferencesItems.Properties

디버그: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
코드 변경 내용 적용 Alt+F10 디버그.코드변경내용적용
프로세스에 연결 Ctrl+Alt+P 디버그.프로세스에연결
자동 Ctrl+Alt+V, A 디버그.자동
모두 중단 Ctrl+Alt+Break 디버그.모두중단
중단점 Ctrl+Alt+B 디버그.중단점
호출 스택 Ctrl+Alt+C 디버그.호출스택
모든 중단점 삭제 Ctrl+Shift+F9 디버그.모든중단점삭제
Launch Alt+F2 Debug.DiagnosticsHub.Launch
디스어셈블리 Ctrl+Alt+D 디버그.디스어셈블리
DOM 탐색기 Ctrl+Alt+V, D Debug.DOMExplorer
중단점 설정 Ctrl+F9 디버그.중단점설정
예외 Ctrl+Alt+E 디버그.예외
함수 중단점 Ctrl+K, B(Visual Studio 2019)
Ctrl+B(Visual Studio 2017)
Debug.FunctionBreakpoint
이전 호출 또는 IntelliTrace 이벤트로 이동 Ctrl+Shift+F11 Debug.GoToPreviousCallorIntelliTraceEvent
진단 시작 Alt+F5 Debug.Graphics.StartDiagnostics
직접 실행 Ctrl+Alt+I 디버그.직접실행
IntelliTrace 호출 Ctrl+Alt+Y, T Debug.IntelliTraceCalls
IntelliTrace 이벤트 Ctrl+Alt+Y, F Debug.IntelliTraceEvents
JavaScript 콘솔 Ctrl+Alt+V, C Debug.JavaScriptConsole
로컬 Ctrl+Alt+V, L 디버그.지역
프로세스 콤보 Ctrl+5 디버그.위치도구모음.프로세스콤보
스택 프레임 콤보 Ctrl+7 디버그.위치도구모음.스택프레임콤보
스레드 콤보 Ctrl+6 디버그.위치도구모음.스레드콤보
현재 스레드 플래그 지정 상태 표시/숨기기 Ctrl+8 디버그.위치도구모음.현재스레드플래그지정상태표시/숨기기
플래그가 지정된 스레드 표시/숨기기 Ctrl+9 디버그.위치도구모음.플래그가지정된스레드표시/숨기기
메모리 1 Ctrl+Alt+M, 1 디버그.메모리1
메모리 2 Ctrl+Alt+M, 2 디버그.메모리2
메모리 3 Ctrl+Alt+M, 3 디버그.메모리3
메모리 4 Ctrl+Alt+M, 4 디버그.메모리4
모듈 Ctrl+Alt+U 디버그.모듈
병렬 스택 Ctrl+Shift+D, S 디버그.병렬스택
병렬 조사식 1 Ctrl+Shift+D, 1 Debug.ParallelWatch1
병렬 조사식 2 Ctrl+Shift+D, 2 Debug.ParallelWatch2
병렬 조사식 3 Ctrl+Shift+D, 3 Debug.ParallelWatch3
병렬 조사식 4 Ctrl+Shift+D, 4 Debug.ParallelWatch4
프로세스 Ctrl+Alt+Z 디버그.프로세스
간략한 조사식 Shift+F9 또는 Ctrl+Alt+Q 디버그.간략한조사식
프로세스에 다시 연결 Shift+Alt+P Debug.ReattachtoProcess
Windows 앱 새로 고침 Ctrl+Shift+R 디버그.Windows응용프로그램새로고침
레지스터 Ctrl+Alt+G 디버그.레지스터
다시 시작 Ctrl+Shift+F5 디버그.다시시작
커서까지 실행 Ctrl+F10 디버그.커서까지실행
다음 문 설정 Ctrl+Shift+F10 디버그.다음문설정
코드 맵에 호출 스택 표시 Ctrl+Shift+` Debug.ShowCallStackonCodeMap
다음 문 표시 Alt+Num * 디버그.다음문표시
시작 F5 디버그.시작
Windows Phone 애플리케이션 분석 시작 Alt+F1 Debug.StartWindowsPhoneApplicationAnalysis
디버그하지 않고 시작 Ctrl+F5 디버그.디버깅하지않고시작
한 단계씩 코드 실행 F11 디버그.한단계씩코드실행
현재 프로세스 한 단계씩 코드 실행 Ctrl+Alt+F11 디버그.현재프로세스한단계씩코드실행
한 단계씩 코드 실행 Shift+Alt+F11 디버그.한단계씩코드실행
프로시저 나가기 Shift+F11 디버그.프로시저나가기
현재 프로세스 프로시저 나가기 Ctrl+Shift+Alt+F11 디버그.현재프로세스프로시저나가기
프로시저 단위 실행 F10(디버깅할 때: 작업을 통해 단계 수행) 디버그.프로시저단위실행
프로시저 단위 실행 F10(디버깅하지 않을 때: 디버깅을 시작하고 사용자 코드의 첫째 줄에서 중지) 디버그.프로시저단위실행
현재 프로세스 프로시저 단위 실행 Ctrl+Alt+F10 디버그.현재프로세스프로시저단위실행
디버깅 중지 Shift+F5 디버그.디버깅중지
성능 분석 중지 Shift+Alt+F2 Debug.StopPerformanceAnalysis
작업 Ctrl+Shift+D, K Debug.Tasks
스레드 Ctrl+Alt+H Debug.Threads
중단점 설정/해제 F9 디버그.중단점설정해제
디스어셈블리 설정/해제 Ctrl+F11 디버그.디스어셈블리설정해제
조사식 1 Ctrl+Alt+W, 1 디버그.조사식1
조사식 2 Ctrl+Alt+W, 2 디버그.조사식2
조사식 3 Ctrl+Alt+W, 3 디버그.조사식3
조사식 4 Ctrl+Alt+W, 4 디버그.조사식4

디버거 상황에 맞는 메뉴: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
DELETE Alt+F9, D 디버거상황에맞는메뉴.중단점창.삭제
디스어셈블리로 이동 Alt+F9, A 디버거상황에맞는메뉴.중단점창.디스어셈블리로이동
소스 코드로 이동 Alt+F9, S 디버거상황에맞는메뉴.중단점창.소스코드로이동

진단 허브: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
수집 중지 Ctrl+Alt+F2 DiagnosticsHub.StopCollection

편집: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
복사 Ctrl+C

또는

Ctrl+Ins
편집.복사
잘라내기 Ctrl+X

또는

Shift+Delete
편집.잘라내기
클립보드 링 순환 Ctrl+Shift+V

또는

Ctrl+Shift+Ins
편집.클립보드링순환
DELETE 삭제 편집.삭제
중복 Ctrl+D Edit.Duplicate
찾기 Ctrl+F 편집.찾기
모든 참조 찾기 Shift+F12 편집.모든참조찾기
파일에서 찾기 Ctrl+Shift+F 편집.파일에서찾기
다음 찾기 F3 편집.다음찾기
다음 선택 찾기 Ctrl+F3 편집.다음찾기선택
이전 찾기 Shift+F3 편집.이전찾기
이전 선택 찾기 Ctrl+Shift+F3 편집.이전찾기선택
메서드 생성 Ctrl+K, Ctrl+M Edit.GenerateMethod
다음으로 이동 Ctrl+G 편집.이동
전체로 이동 Ctrl+, 또는 Ctrl+T Edit.GoToAll
선언으로 이동 Ctrl+F12 편집.선언으로이동
정의로 이동 F12 편집.정의로이동
멤버로 이동 Ctrl+1, Ctrl+M 또는 Ctrl+1, M 또는 Alt+\ Edit.GoToMember
다음 위치로 이동 F8(오류 목록 또는 출력 창의 다음 오류) 편집.다음위치로이동
이전 위치로 이동 Shift+F8(오류 목록 또는 출력 창의 이전 오류) 편집.이전위치로이동
코드 조각 삽입 Ctrl+K, Ctrl+X 편집.코드조각삽입
컨트롤 아래로 이동 Ctrl+아래쪽 화살표 편집.컨트롤아래로이동
모눈 아래로 컨트롤 이동 아래쪽 화살표 편집.모눈아래로컨트롤이동
컨트롤 왼쪽으로 이동 Ctrl+왼쪽 화살표 편집.컨트롤왼쪽으로이동
모눈 왼쪽으로 컨트롤 이동 왼쪽 화살표 편집.모눈왼쪽으로컨트롤이동
컨트롤 오른쪽으로 이동 Ctrl+오른쪽 화살표 편집.컨트롤오른쪽으로이동
모눈 오른쪽으로 컨트롤 이동 오른쪽 화살표 편집.모눈오른쪽으로컨트롤이동
컨트롤 위로 이동 Ctrl+위쪽 화살표 편집.컨트롤위로이동
모눈 위로 컨트롤 이동 위쪽 화살표 편집.모눈위로컨트롤이동
다음 책갈피 Ctrl+K, Ctrl+N 편집.다음책갈피
폴더의 다음 책갈피 Ctrl+Shift+K, Ctrl+Shift+N 편집.폴더의다음책갈피
파일 열기 Ctrl+Shift+G(커서 아래에 파일 이름이 열림) Edit.OpenFile
붙여넣기 Ctrl+V

또는

Shift+Ins
편집.붙여넣기
이전 책갈피 Ctrl+K, Ctrl+P 편집.이전책갈피
폴더의 이전 책갈피 Ctrl+Shift+K, Ctrl+Shift+P 편집.폴더의이전책갈피
빠른 찾기 기호 Shift+Alt+F12 편집.빠른기호찾기
다시 실행 Ctrl+Y

또는

Ctrl+Shift+Z

또는

Shift+Alt+Backspace
편집.다시실행
원격 참조 새로 고침 Ctrl+Shift+J Edit.RefreshRemoteReferences
바꾸기 Ctrl+H 편집.바꾸기
파일에서 바꾸기 Ctrl+Shift+H 편집.파일에서바꾸기
모두 선택 Ctrl+A 편집.모두선택
다음 컨트롤 선택 Tab 편집.다음컨트롤선택
이전 컨트롤 선택 Shift+Tab 편집.이전컨트롤선택
바둑판식 모눈 표시 Enter 편집.바둑판식모눈표시
아래로 컨트롤 크기 조정 Ctrl+Shift+아래쪽 화살표 편집.아래로컨트롤크기조정
모눈 아래로 컨트롤 크기 조정 Shift+아래쪽 화살표 편집.모눈아래로컨트롤크기조정
왼쪽으로 컨트롤 크기 조정 Ctrl+Shift+왼쪽 화살표 편집.왼쪽으로컨트롤크기조정
모눈 왼쪽으로 컨트롤 크기 조정 Shift+왼쪽 화살표 편집.모눈왼쪽으로컨트롤크기조정
오른쪽으로 컨트롤 크기 조정 Ctrl+Shift+오른쪽 화살표 편집.오른쪽으로컨트롤크기조정
모눈 오른쪽으로 컨트롤 크기 조정 Shift+오른쪽 화살표 편집.모눈오른쪽으로컨트롤크기조정
위로 컨트롤 크기 조정 Ctrl+Shift+위쪽 화살표 편집.위로컨트롤크기조정
모눈 위로 컨트롤 크기 조정 Shift+위쪽 화살표 편집.모눈위로컨트롤크기조정
검색 중지 Alt+F3, S 편집.검색중지
코드 감싸기 Ctrl+K, Ctrl+S
(Visual Studio 2019 및 이전 버전에서만 사용 가능)
편집.코드감싸기
실행 취소 Ctrl+Z

또는

Alt+백스페이스
편집.실행취소

편집기 상황에 맞는 메뉴: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
중단점 조건 Alt+F9, C EditorContextMenus.CodeWindow.Breakpoint.BreakpointConditions
중단점 편집 레이블 Alt+F9, L EditorContextMenus.CodeWindow.Breakpoint.BreakpointEditlabels
임시 중단점 삽입 Shift+Alt+F9, T EditorContextMenus.CodeWindow.Breakpoint.InsertTemporaryBreakpoint
항목 표시 Ctrl+` EditorContextMenus.CodeWindow.CodeMap.ShowItem
Execute Ctrl+Alt+F5 EditorContextMenus.CodeWindow.Execute
뷰로 이동 Ctrl+M, Ctrl+G EditorContextMenus.CodeWindow.GoToView
헤더 코드 파일 전환 Ctrl+K, Ctrl+O(문자 ‘O’) EditorContextMenus.CodeWindow.ToggleHeaderCodeFile
호출 계층 구조 보기 Ctrl+K, Ctrl+T

또는

Ctrl+K, T
EditorContextMenus.CodeWindow.ViewCallHierarchy

파일: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
종료 Alt+F4 File.Exit
새 파일 Ctrl+N 파일.새파일
새 프로젝트 Ctrl+Shift+N 파일.새프로젝트
새 웹 사이트 Shift+Alt+N 파일.새웹사이트
파일 열기 Ctrl+O(문자 ‘O’) 파일.파일열기
프로젝트 열기 Ctrl+Shift+O(문자 ‘O’) 파일.프로젝트열기
웹 사이트 열기 Shift+Alt+O(문자 ‘O’) 파일.웹사이트열기
인쇄 Ctrl+P 파일.인쇄
모두 저장 Ctrl+Shift+S 파일.모두저장
선택한 항목 저장 Ctrl+S 파일.선택한항목저장
브라우저에서 보기 Ctrl+Shift+W 파일.브라우저에서보기

도움말: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
도움말 콘텐츠 추가 및 제거 Ctrl+Alt+F1 Help.AddandRemoveHelpContent
F1 도움말 F1 도움말.F1도움말
도움말 보기 Ctrl+F1 도움말.도움말보기
창 도움말 Shift+F1 도움말.창도움말

부하 테스트: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
카운터 창으로 이동 Ctrl+R, Q LoadTest.JumpToCounterPane

기타 상황에 맞는 메뉴: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
새 다이어그램 추가 삽입 OtherContextMenus.MicrosoftDataEntityDesignContext.AddNewDiagram

프로젝트: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
기존 항목 추가 Shift+Alt+A 프로젝트.기존항목추가
새 항목 추가 Ctrl+Shift+A 프로젝트.새항목추가
클래스 마법사 Ctrl+Shift+A Project.ClassWizard
재정의 Ctrl+Alt+Ins 프로젝트.재정의
변경 내용 미리 보기 Alt+; , Alt+C Project.Previewchanges
선택한 파일 게시 Alt+; , Alt+P Project.Publishselectedfiles
서버에서 선택한 파일 바꾸기 Alt+; , Alt+R Project.Replaceselectedfilesfromserver

프로젝트 및 솔루션 상황에 맞는 메뉴: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
아래로 이동 Alt+아래쪽 화살표 ProjectandSolutionContextMenus.Item.MoveDown
위로 이동 Alt+위쪽 화살표 ProjectandSolutionContextMenus.Item.MoveUp

리퍽터링: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
필드 캡슐화 Ctrl+R, Ctrl+E 리팩터링.필드캡슐화
인터페이스 추출 Ctrl+R, Ctrl+I 리팩터링.인터페이스추출
메서드 추출 Ctrl+R, Ctrl+M 리팩터링.메서드추출
매개 변수 제거 Ctrl+R, Ctrl+V 리팩터링.매개변수제거
이름 바꾸기 Ctrl+R, Ctrl+R 리팩터링.이름바꾸기
매개 변수 다시 정렬 Ctrl+R, Ctrl+O(문자 ‘O’) 리팩터링.매개변수다시정렬

솔루션 탐색기: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
파일 필터 열기 Ctrl+[ , O(문자 ‘O’)

또는

Ctrl+[ , Ctrl+O(문자 ‘O’)
SolutionExplorer.OpenFilesFilter
보류 중인 변경 내용 필터 Ctrl+[ , P

또는

Ctrl+[ , Ctrl+P
SolutionExplorer.PendingChangesFilter
활성 문서와 동기화 Ctrl+[ , S

또는

Ctrl+[ , Ctrl+S
SolutionExplorer.SyncWithActiveDocument

팀: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
Git 분기로 이동 Ctrl+0(영), Ctrl+N

또는

Ctrl+0, N
Team.Git.GoToGitBranches
Git 변경 내용으로 이동 Ctrl+0(영), Ctrl+G

또는

Ctrl+0, G
Team.Git.GoToGitChanges
Git 커밋으로 이동 Ctrl+0(영), Ctrl+O(문자 ‘O’)

또는

Ctrl+0, O
Team.Git.GoToGitCommits
팀 탐색기 검색 Ctrl+' Team.TeamExplorerSearch

Team Foundation 상황에 맞는 메뉴: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
빌드로 이동 Ctrl+0(영), Ctrl+B

또는

Ctrl+0, B
TeamFoundationContextMenus.Commands.GoToBuilds
연결로 이동 Ctrl+0(영), Ctrl+C

또는

Ctrl+0, C
TeamFoundationContextMenus.Commands.GoToConnect
문서로 이동 Ctrl+0(영), Ctrl+D

또는

Ctrl+0, D
TeamFoundationContextMenus.Commands.GoToDocuments
홈으로 이동 Ctrl+0(영), Ctrl+H

또는

Ctrl+0, H
TeamFoundationContextMenus.Commands.GoToHome
내 작업으로 이동 Ctrl+0(영), Ctrl+M

또는

Ctrl+0, M
TeamFoundationContextMenus.Commands.GoToMyWork
보류 중인 변경 내용으로 이동 Ctrl+0(영), Ctrl+P

또는

Ctrl+0, P
TeamFoundationContextMenus.Commands.GoToPendingChanges
보고서로 이동 Ctrl+0(영), Ctrl+R

또는

Ctrl+0, R
TeamFoundationContextMenus.Commands.GoToReports
설정으로 이동 Ctrl+0(영), Ctrl+S

또는

Ctrl+0, S
TeamFoundationContextMenus.Commands.GoToSettings
웹 액세스로 이동 Ctrl+0(영), Ctrl+A

또는

Ctrl+0, A
TeamFoundationContextMenus.Commands.GoToWebAccess
작업 항목으로 이동 Ctrl+0(영), Ctrl+W

또는

Ctrl+0, W
TeamFoundationContextMenus.Commands.GoToWorkItems

테스트: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
코딩된 UI 테스트 빌더 사용 Ctrl+\, Ctrl+C Test.UseCodedUITestBuilder
기존 작업 기록 사용 Ctrl+\, Ctrl+A Test.UseExistingActionRecording

테스트 탐색기: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
모든 테스트 디버그 Ctrl+R, Ctrl+A TestExplorer.DebugAllTests
컨텍스트에서 모든 테스트 디버그 Ctrl+R, Ctrl+T TestExplorer.DebugAllTestsInContext
마지막 실행 디버그 Ctrl+R, D TestExplorer.DebugLastRun
마지막 실행 반복 Ctrl+R, L TestExplorer.RepeatLastRun
모든 테스트 실행 Ctrl+R, A TestExplorer.RunAllTests
컨텍스트에서 모든 테스트 실행 Ctrl+R, T TestExplorer.RunAllTestsInContext
테스트 탐색기 표시 Ctrl+E, T TestExplorer.ShowTestExplorer
탭 열기 Ctrl+E, L LiveUnitTesting.OpenTab
코드 검사 결과 Ctrl+E, C Test.CodeCoverageResults

도구: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
프로세스에 연결 Ctrl+Alt+P Tools.AttachtoProcess
코드 조각 관리자 Ctrl+K, Ctrl+B 도구.코드조각관리자
GC 강제 Ctrl+Shift+Alt+F12, Ctrl+Shift+Alt+F12 Tools.ForceGC

보기: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
모든 창 Shift+Alt+M View.AllWindows
아키텍처 탐색기 Ctrl+\, Ctrl+R View.ArchitectureExplorer
뒤로 Alt+왼쪽 화살표(텍스트 편집기의 View.NavigateBackward와 다른 기능 수행) View.Backward
책갈피 창 Ctrl+K, Ctrl+W 보기.책갈피창
다음 찾아보기 Ctrl+Shift+1 보기.다음찾아보기
이전 찾아보기 Ctrl+Shift+2 보기.이전찾아보기
호출 계층 구조 Ctrl+Alt+K 보기.호출계층구조
클래스 뷰 Ctrl+Shift+C 보기.클래스뷰
클래스 뷰 검색 콤보 상자로 이동 Ctrl+K, Ctrl+V 보기.클래스뷰검색콤보상자로이동
코드 정의 창 Ctrl+\, D

또는

Ctrl+\, Ctrl+D
보기.코드정의창
명령 창 Ctrl+Alt+A 보기.명령창
데이터 원본 Shift+Alt+D 보기.데이터소스
문서 개요 Ctrl+Alt+T 보기.문서개요
레이블 편집 F2 보기.레이블편집
오류 목록 Ctrl+\, E

또는

Ctrl+\, Ctrl+E
보기.오류목록
F# 대화형 Ctrl+Alt+F 보기.F#Interactive
기호 찾기 결과 Ctrl+Alt+F12 보기.기호찾기결과
앞으로 Alt+오른쪽 화살표(텍스트 편집기의 View.NavigateForward와 다른 기능 수행) View.Forward
정방향 찾아보기 컨텍스트 Ctrl+Shift+7 보기.정방향검색컨텍스트
전체 화면 Shift+Alt+Enter 보기.전체화면
뒤로 탐색 Ctrl+- 보기.뒤로탐색
앞으로 탐색 Ctrl+Shift+- 보기.앞으로탐색
다음 오류 Ctrl+Shift+F12 보기.다음오류
알림 Ctrl+W, N

또는

Ctrl+W, Ctrl+N
View.Notifications
개체 브라우저 Ctrl+Alt+J 보기.개체브라우저
개체 브라우저 검색 콤보 상자로 이동 Ctrl+K, Ctrl+R 보기.개체브라우저검색콤보상자로이동
출력 Ctrl+Alt+O(문자 ‘O’) 보기.출력
팝 찾아보기 컨텍스트 Ctrl+Shift+8(C++만 해당) View.PopBrowseContext
속성 창 F4 보기.속성창
속성 페이지 Shift+F4 보기.속성페이지
리소스 뷰 Ctrl+Shift+E 보기.리소스뷰
서버 탐색기 Ctrl+Alt+S 보기.서버탐색기
스마트 태그 표시 Shift+Alt+F10

또는

Ctrl+.
보기.스마트태그표시
솔루션 탐색기 Ctrl+Alt+L 보기.솔루션탐색기
SQL Server 개체 탐색기 Ctrl+\, Ctrl+S View.SQLServerObjectExplorer
작업 목록 Ctrl+\, T

또는

Ctrl+\, Ctrl+T
보기.작업목록
TFS 팀 탐색기 Ctrl+\, Ctrl+M View.TfsTeamExplorer
도구 상자 Ctrl+Alt+X 보기.도구상자
UML 모델 탐색기 Ctrl+\, Ctrl+U View.UMLModelExplorer
코드 보기 F7 보기.코드보기
뷰 디자이너 Shift+F7 보기.디자이너보기
웹 브라우저 Ctrl+Alt+R 보기.웹브라우저
확대 Ctrl+Shift+. View.ZoomIn
축소 Ctrl+Shift+, View.ZoomOut
테스트 탐색기 표시 Ctrl+E, T TestExplorer.ShowTestExplorer

창: 전역 바로 가기 키

명령 바로 가기 키 명령 ID
문서 창 활성화 Esc 창.문서창활성화
선택 항목에 탭 추가 Ctrl+Shift+Alt+스페이스바 Window.AddTabtoSelection
문서 창 닫기 Ctrl+F4 창.문서창닫기
도구 창 닫기 Shift+Esc 창.도구창닫기
탭 열어 두기 Ctrl+Alt+Home Window.KeepTabOpen
탐색 모음으로 이동 Ctrl+F2 창.탐색모음으로이동
다음 문서 창 Ctrl+F6 창.다음문서창
다음 문서 창으로 이동 Ctrl+Tab 창.다음문서창으로이동
다음 창 Alt+F6 창.다음창
다음 분할 창 F6 창.다음분할창
다음 탭 Ctrl+Alt+PgDn

또는

Ctrl+PgDn
창.다음탭
다음 탭 및 선택 항목에 추가 Ctrl+Shift+Alt+PgDn 창.다음탭및선택영역에추가
다음 도구 창으로 이동 Alt+F7 창.다음도구창으로이동
이전 문서 창 Ctrl+Shift+F6 창.이전문서창
이전 문서 창으로 이동 Ctrl+Shift+Tab 창.이전문서창으로이동
이전 창 Shift+Alt+F6 창.이전창
이전 분할 창 Shift+F6 창.이전분할창
이전 탭 Ctrl+Alt+PgUp

또는

Ctrl+PgUp
창.이전탭
이전 탭 및 선택 항목에 추가 Ctrl+Shift+Alt+PgUp 창.이전탭및선택영역에추가
이전 도구 창으로 이동 Shift+Alt+F7 창.이전도구창으로이동
빠른 실행 Ctrl+Q Window.QuickLaunch
빠른 실행 이전 범주 Ctrl+Shift+Q Window.QuickLaunchPreviousCategory
도킹 메뉴 표시 Alt+- Window.ShowDockMenu
Ex MDI 파일 목록 표시 Ctrl+Alt+아래쪽 화살표 창.EzMDI파일목록표시
솔루션 탐색기 검색 Ctrl+; Window.SolutionExplorerSearch
창 검색 Alt+` Window.WindowSearch

컨텍스트별 바로 가기 키

이러한 바로 가기 키는 컨텍스트에 맞게 적용되므로 프로젝트 형식, 프로그래밍 언어 또는 플랫폼과 관련된 Visual Studio의 메뉴 및 항목과 함께 사용할 수 있습니다.

ADO.NET 엔터티 데이터 모델 디자이너: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
아래로 Alt+아래쪽 화살표 OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.Down
아래로 5 Alt+PgDn OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.Down5
맨 아래로 Alt+End OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.ToBottom
맨 위로 Alt+Home OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.ToTop
위로 Alt+위쪽 화살표 OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.Up
위로 1 Alt+PgUp OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.Up5
이름 바꾸기 Ctrl+R, R OtherContextMenus.MicrosoftDataEntityDesignContext.Refactor.Rename
다이어그램에서 제거 Shift+Del OtherContextMenus.MicrosoftDataEntityDesignContext.RemovefromDiagram
엔터티 데이터 모델 브라우저 Ctrl+1 View.EntityDataModelBrowser
엔터티 데이터 모델 매핑 세부 정보 Ctrl+2 View.EntityDataModelMappingDetails

클래스 다이어그램: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
축소 Num - 클래스다이어그램.축소
Expand Num + 클래스다이어그램.확장
DELETE Ctrl+Del 편집.삭제
기본 형식 목록 확장/축소 Shift+Alt+B 편집.기본형식목록확장/축소
롤리팝 탐색 Shift+Alt+L 편집.롤리팝탐색
다이어그램에서 제거 삭제 Edit.RemovefromDiagram
코드 보기 Enter 보기.코드보기

코딩 된 UI 테스트 편집기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
참조를 클립보드에 복사 Ctrl+C OtherContextMenus.UITestEditorContextMenu.CopyReferencetoClipboard
앞에 지연 삽입 Ctrl+Alt+D OtherContextMenus.UITestEditorContextMenu.InsertDelayBefore
모두 찾기 Shift+Alt+L OtherContextMenus.UITestEditorContextMenu.LocateAll
UI 컨트롤 찾기 Ctrl+Shift+L OtherContextMenus.UITestEditorContextMenu.LocatetheUIControl
코드 이동 Ctrl+Alt+C OtherContextMenus.UITestEditorContextMenu.Movecode
새 메서드로 분할 Ctrl+Shift+T OtherContextMenus.UITestEditorContextMenu.Splitintoanewmethod

데이터 세트 편집기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
열 삽입 삽입 기타상황에맞는메뉴.열컨텍스트.열삽입
Ctrl+L 기타상황에맞는메뉴.DB테이블컨텍스트.추가.열

차이점 뷰어: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
공백 문자 잘라내기 무시 Ctrl+\, Ctrl+스페이스바 Diff.IgnoreTrimWhitespace
인라인 뷰 Ctrl+\, Ctrl+1 Diff.InlineView
왼쪽 전용 뷰 Ctrl+\, Ctrl+3 Diff.LeftOnlyView
다음 차이점 F8 Diff.NextDifference
이전 차이점 Shift+F8 Diff.PreviousDifference
오른쪽 전용 뷰 Ctrl+\, Ctrl+4 Diff.RightOnlyView
나란히 보기 뷰 Ctrl+\, Ctrl+2 Diff.SideBySideView
왼쪽과 오른쪽 간 전환 Ctrl+\, Ctrl+Tab Diff.SwitchBetweenLeftAndRight
뷰 동기화 설정/해제 Ctrl+\, Ctrl+아래쪽 화살표 Diff.SynchronizeViewToggle
주석 추가 Ctrl+Shift+K EditorContextMenus.CodeWindow.AddComment
로컬 파일 편집 Ctrl+Shift+P EditorContextMenus.CodeWindow.EditLocalFile

DOM 탐색기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
새로 고침 F5 DOMExplorer.Refresh
요소 선택 Ctrl+B DOMExplorer.SelectElement
레이아웃 표시 Ctrl+Shift+I DOMExplorer.ShowLayout

F# 대화형: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
대화형 평가 취소 Ctrl+Break OtherContextMenus.FSIConsoleContext.CancelInteractiveEvaluation

그래프 문서 편집기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
노드 추가 삽입 ArchitectureContextMenus.DirectedGraphContextMenu.Advanced.Add.AddNode
두 종속성 모두 B ArchitectureContextMenus.DirectedGraphContextMenu.Advanced.Select.BothDependencies
들어오는 종속성 I ArchitectureContextMenus.DirectedGraphContextMenu.Advanced.Select.IncomingDependencies
나가는 종속성 O ArchitectureContextMenus.DirectedGraphContextMenu.Advanced.Select.OutgoingDependencies
새 주석 Ctrl+Shift+K

또는

Ctrl+E, C
ArchitectureContextMenus.DirectedGraphContextMenu.NewComment
제거 삭제 ArchitectureContextMenus.DirectedGraphContextMenu.Remove
이름 바꾸기 F2 ArchitectureContextMenus.DirectedGraphContextMenu.Rename

그래프 진단: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
프레임 캡처 없음 Debug.Graphics.CaptureFrame
픽셀 선택 영역 아래로 이동 Shift+Alt+아래쪽 화살표 Graphics.MovePixelSelectionDown
픽셀 선택 영역 왼쪽으로 이동 Shift+Alt+왼쪽 화살표 Graphics.MovePixelSelectionLeft
픽셀 선택 영역 오른쪽으로 이동 Shift+Alt+오른쪽 화살표 Graphics.MovePixelSelectionRight
픽셀 선택 영역 위로 이동 Shift+Alt+위쪽 화살표 Graphics.MovePixelSelectionUp
실제 크기로 확대/축소 Shift+Alt+0(영) Graphics.ZoomToActualSize
창에 맞게 확대/축소 Shift+Alt+9 Graphics.ZoomToFitInWindow
확대 Shift+Alt+= Graphics.ZoomIn
축소 Shift+Alt+- Graphics.ZoomOut

HTML 편집기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
컨트롤러로 이동 Ctrl+M, Ctrl+G OtherContextMenus.HTMLContext.GoToController

HTML 편집기 디자인 뷰: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
컨트롤 아래로 이동 Ctrl+아래쪽 화살표 편집.컨트롤아래로이동
컨트롤 위로 이동 Ctrl+위쪽 화살표 편집.컨트롤위로이동
굵게 Ctrl+B 서식.굵게
하이퍼링크로 변환 Ctrl+L 서식.하이퍼링크로변환
책갈피 삽입 Ctrl+Shift+L 서식.책갈피삽입
기울임꼴 Ctrl+I 서식.기울임꼴
밑줄 Ctrl+U 서식.밑줄
콘텐츠 페이지 추가 Ctrl+M, Ctrl+C 프로젝트.콘텐츠페이지추가
왼쪽에 열 삽입 Ctrl+Alt+왼쪽 화살표 테이블.왼쪽에열삽입
오른쪽에 열 삽입 Ctrl+Alt+오른쪽 화살표 테이블.오른쪽에열삽입
위에 행 삽입 Ctrl+Alt+위쪽 화살표 테이블.위에행삽입
아래에 행 삽입 Ctrl+Alt+아래쪽 화살표 테이블.아래에행삽입
NET 비가시 컨트롤 Ctrl+Shift+N 보기.ASP.NET비가시컨트롤
마스터 편집 Ctrl+M, Ctrl+M 보기.마스터편집
다음 뷰 Ctrl+PgDn 보기.다음뷰
스마트 태그 표시 Shift+Alt+F10 보기.스마트태그표시
태그 보기 Shift+F7 보기.태그보기
이전 탭 Ctrl+PgUp 창.이전탭

HTML 편집기 소스 뷰: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
컨트롤러로 이동 Ctrl+M, Ctrl+G OtherContextMenus.HTMLContext.GoToController
다음 뷰 Ctrl+PgDn 보기.다음뷰
뷰 동기화 Ctrl+Shift+Y View.SynchronizeViews
뷰 디자이너 Shift+F7 보기.디자이너보기
이전 탭 Ctrl+PgUp 창.이전탭

레이어 다이어그램: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
DELETE Shift+Delete 편집.삭제

관리되는 리소스 편집기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
셀 편집 F2 편집.셀편집
제거 삭제 편집.제거
행 제거 Ctrl+Delete 편집.행제거
선택 취소 Esc 편집.선택취소
오디오 Ctrl+4 리소스.오디오
파일 Ctrl+5 리소스.파일
아이콘 Ctrl+3 리소스.아이콘
이미지 Ctrl+2 리소스.이미지
기타 Ctrl+6 리소스.기타
문자열 Ctrl+1 리소스.문자열

병합 편집기 창: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
왼쪽 창에 포커스 설정 Alt+1 TeamFoundationContextMenus.MergeContextMenu.SetFocusonLeftWindow
결과 창에 포커스 설정 Alt+2 TeamFoundationContextMenus.MergeContextMenu.SetFocusonResultWindow
오른쪽 창에 포커스 설정 Alt+3 TeamFoundationContextMenus.MergeContextMenu.SetFocusonRightWindow

Microsoft SQL Server Data Tools, 스키마 비교: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
SSDT 스키마 비교 비교 Shift+Alt+C SQL.SSDTSchemaCompareCompare
SSDT 스키마 비교 스크립트 생성 Shift+Alt+G SQL.SSDTSchemaCompareGenerateScript
SSDT 스키마 비교 다음 변경 Shift+Alt+. SQL.SSDTSchemaCompareNextChange
SSDT 스키마 비교 이전 변경 Shift+Alt+, SQL.SSDTSchemaComparePreviousChange
SSDT 스키마 비교 중지 Alt+Break SQL.SSDTSchemaCompareStop
SSDT 스키마 비교 쓰기 업데이트 Shift+Alt+U SQL.SSDTSchemaCompareWriteUpdates

Microsoft SQL Server Data Tools, 테이블 디자이너: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
CommitAllEdits Shift+Alt+U
와일드카드 확장 Ctrl+R, E

또는

Ctrl+R, Ctrl+E
SQL.ExpandWildcards
이름 정규화 Ctrl+R, Q

또는

Ctrl+R, Ctrl+Q
SQL.FullyqualifyNames
스키마로 이동 Ctrl+R, M

또는

Ctrl+R, Ctrl+M
SQL.MovetoSchema
이름 바꾸기 F2

또는

Ctrl+R, R

또는

Ctrl+R, Ctrl+R
SQL.Rename
ViewFileInScriptPanel Shift+Alt+PgDn

Microsoft SQL Server Data Tools, T-SQL 편집기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
CommitAllEdits Shift+Alt+U
디버거와 함께 실행 Alt+F5 SQL.ExecuteWithDebugger
와일드카드 확장 Ctrl+R, E

또는

Ctrl+R, Ctrl+E
SQL.ExpandWildcards
이름 정규화 Ctrl+R, Q

또는

Ctrl+R, Ctrl+Q
SQL.FullyqualifyNames
스키마로 이동 Ctrl+R, M

또는

Ctrl+R, Ctrl+M
SQL.MovetoSchema
이름 바꾸기 F2

또는

Ctrl+R, R

또는

Ctrl+R, Ctrl+R
SQL.Rename
T SQL 편집기 쿼리 취소 Alt+Break SQL.TSqlEditorCancelQuery
T SQL 편집기 쿼리 실행 Ctrl+Shift+E SQL.TSqlEditorExecuteQuery
T SQL 편집기 결과를 파일로 Ctrl+D, F SQL.TSqlEditorResultsAsFile
T SQL 편집기 결과를 표로 Ctrl+D, G SQL.TSqlEditorResultsAsGrid
T SQL 편집기 결과를 텍스트로 Ctrl+D, T SQL.TSqlEditorResultsAsText
T SQL 편집기에서 예상 계획 표시 Ctrl+D, E SQL.TSqlEditorShowEstimatedPlan
T SQL 편집기 실행 계획 설정/해제 Ctrl+D, A SQL.TSqlEditorToggleExecutionPlan
T SQL 편집기 결과 창 표시/숨기기 Ctrl+D, R SQL.TSqlEditorToggleResultsPane
T SQL 편집기 쿼리 복제 Ctrl+Alt+N SQL.TSqlEditorCloneQuery
T SQL 편집기 데이터베이스 콤보 Shift+Alt+PgDn SQL.TSqlEditorDatabaseCombo

Microsoft SQL Server Data Tools, T-SQL PDW 편집기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
T SQL 편집기 쿼리 취소 Alt+Break SQL.TSqlEditorCancelQuery
T SQL 편집기 쿼리 실행 Ctrl+Shift+E SQL.TSqlEditorExecuteQuery
T SQL 편집기 결과를 파일로 Ctrl+D, F SQL.TSqlEditorResultsAsFile
T SQL 편집기 결과를 표로 Ctrl+D, G SQL.TSqlEditorResultsAsGrid
T SQL 편집기 결과를 텍스트로 Ctrl+D, T SQL.TSqlEditorResultsAsText
T SQL 편집기에서 예상 계획 표시 Ctrl+D, E SQL.TSqlEditorShowEstimatedPlan
T SQL 편집기 실행 계획 설정/해제 Ctrl+D, A SQL.TSqlEditorToggleExecutionPlan
T SQL 편집기 결과 창 표시/숨기기 Ctrl+D, R SQL.TSqlEditorToggleResultsPane
T SQL 편집기 쿼리 복제 Ctrl+Alt+N SQL.TSqlEditorCloneQuery
T SQL 편집기 쿼리 복제 Shift+Alt+PgDn SQL.TSqlEditorCloneQuery

페이지 검사기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
최소화 F12 PageInspector.Minimize

쿼리 디자이너: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
데이터 검색 취소 Ctrl+T 쿼리디자이너.데이터검색취소
조건 Ctrl+2 쿼리디자이너.조건
다이어그램 Ctrl+1 쿼리디자이너.다이어그램
SQL 실행 Ctrl+R 쿼리디자이너.SQL실행
행으로 이동 Ctrl+G QueryDesigner.GotoRow
조인 모드 Ctrl+Shift+J 쿼리디자이너.조인모드
결과 Ctrl+4 쿼리디자이너.결과
Sql Ctrl+3 쿼리디자이너.SQL

쿼리 결과: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
쿼리 결과 새 행 Alt+End SQL.QueryResultsNewRow
쿼리 결과 새로 고침 Shift+Alt+R SQL.QueryResultsRefresh
쿼리 결과 중지 Alt+Break SQL.QueryResultsStop

보고서 디자이너: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
구분선 Enter 편집.구분선
왼쪽 문자로 왼쪽 화살표 편집.왼쪽문자로
왼쪽 문자까지 선택 Shift+왼쪽 화살표 편집.왼쪽문자까지선택
오른쪽 문자로 오른쪽 화살표 편집.오른쪽문자로
오른쪽 문자까지 선택 Shift+오른쪽 화살표 편집.오른쪽문자까지선택
삽입 탭 Tab 편집.탭삽입
줄 아래로 아래쪽 화살표 편집.줄아래로
한 줄 아래까지 선택 Shift+아래쪽 화살표 편집.한줄아래까지선택
줄 위로 위쪽 화살표 편집.줄위로
한 줄 위까지 선택 Shift+위쪽 화살표 편집.한줄위까지선택
컨트롤 아래로 이동 Ctrl+아래쪽 화살표 편집.컨트롤아래로이동
컨트롤 왼쪽으로 이동 Ctrl+왼쪽 화살표 편집.컨트롤왼쪽으로이동
컨트롤 오른쪽으로 이동 Ctrl+오른쪽 화살표 편집.컨트롤오른쪽으로이동
컨트롤 위로 이동 Ctrl+위쪽 화살표 편집.컨트롤위로이동
선택 취소 Esc 편집.선택취소
아래로 컨트롤 크기 조정 Ctrl+Shift+아래쪽 화살표 편집.아래로컨트롤크기조정
왼쪽으로 컨트롤 크기 조정 Ctrl+Shift+왼쪽 화살표 편집.왼쪽으로컨트롤크기조정
오른쪽으로 컨트롤 크기 조정 Ctrl+Shift+오른쪽 화살표 편집.오른쪽으로컨트롤크기조정
위로 컨트롤 크기 조정 Ctrl+Shift+위쪽 화살표 편집.위로컨트롤크기조정
왼쪽으로 탭 이동 Shift+Tab 편집.왼쪽으로탭이동
원본 Ctrl+Alt+D View.ReportData

시퀀스 다이어그램: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
코드로 이동 F12 ArchitectureDesigner.Sequence.NavigateToCode
DELETE Shift+Del 편집.삭제

설정 디자이너: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
셀 편집 F2 편집.셀편집
행 제거 Ctrl+Delete 편집.행제거
선택 취소 Esc 편집.선택취소
코드 보기 F7 보기.코드보기

솔루션 탐색기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
페이지 검사기에서 보기 Ctrl+K, Ctrl+G ClassViewContextMenus.ClassViewProject.View.ViewinPageInspector

팀 탐색기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
DELETE 삭제 편집.삭제
이름 바꾸기 F2 파일.이름바꾸기
팀 탐색기 탐색으로 이동 Alt+Home TeamFoundationContextMenus.Commands.GoToTeamExplorerNavigation
팀 탐색기 다음 섹션 콘텐츠로 이동 Alt+아래쪽 화살표 TeamFoundationContextMenus.Commands.GoToTeamExplorerNextSectionContent
팀 탐색기 페이지 콘텐츠로 이동 Alt+0(영) TeamFoundationContextMenus.Commands.GoToTeamExplorerPageContent
팀 탐색기 이전 섹션 콘텐츠로 이동 Alt+위쪽 화살표 TeamFoundationContextMenus.Commands.GoToTeamExplorerPreviousSectionContent
팀 탐색기 섹션 1 콘텐츠로 이동 Alt+1 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection1Content
팀 탐색기 섹션 2 콘텐츠로 이동 Alt+2 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection2Content
팀 탐색기 섹션 3 콘텐츠로 이동 Alt+3 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection3Content
팀 탐색기 섹션 4 콘텐츠로 이동 Alt+4 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection4Content
팀 탐색기 섹션 5 콘텐츠로 이동 Alt+5 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection5Content
팀 탐색기 섹션 6 콘텐츠로 이동 Alt+6 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection6Content
팀 탐색기 섹션 7 콘텐츠로 이동 Alt+7 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection7Content
팀 탐색기 섹션 8 콘텐츠로 이동 Alt+8 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection8Content
팀 탐색기 섹션 9 콘텐츠로 이동 Alt+9 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection9Content
팀 탐색기 뒤로 탐색 Alt+왼쪽 화살표 TeamFoundationContextMenus.Commands.TeamExplorerNavigateBackward
팀 탐색기 앞으로 탐색 Alt+오른쪽 화살표 TeamFoundationContextMenus.Commands.TeamExplorerNavigateForward
TFS 컨텍스트 내 작업 페이지 복사본 만들기 wi Shift+Alt+C TeamFoundationContextMenus.MyWorkPageInProgress.TfsContextMyWorkPageCreateCopyWI
TFS 컨텍스트 내 작업 페이지 새 연결된 wi Shift+Alt+L TeamFoundationContextMenus.MyWorkPageInProgress.TfsContextMyWorkPageNewLinkedWI
새로 고침 F5 View.Refresh

테스트 탐색기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
테스트 열기 F12 TestExplorer.OpenTest

텍스트 편집기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
구분선 Enter

또는

Shift+Enter
편집.구분선
왼쪽 문자로 왼쪽 화살표 편집.왼쪽문자로
왼쪽 문자까지 선택 Shift+왼쪽 화살표 편집.왼쪽문자까지선택
왼쪽 문자까지 열 확장 선택 Shift+Alt+왼쪽 화살표 편집.왼쪽문자까지열확장선택
오른쪽 문자로 오른쪽 화살표 편집.오른쪽문자로
오른쪽 문자까지 선택 Shift+오른쪽 화살표 편집.오른쪽문자까지선택
오른쪽 문자까지 열 확장 선택 Shift+Alt+오른쪽 화살표 편집.오른쪽문자까지열확장선택
책갈피 지우기 Ctrl+K, Ctrl+L 편집.책갈피지우기
전체 개요 축소 Ctrl+M, Ctrl+A 편집.전체개요축소
현재 영역 축소 Ctrl+M, Ctrl+S 편집.현재영역축소
태그 축소 Ctrl+M, Ctrl+T 편집.태그축소
정의 부분만 보이기 Ctrl+M, Ctrl+O(문자 ‘O’) 편집.정의부분만보이기
선택 영역 축소 Shift+Alt+- Edit.ContractSelection
선택 영역을 주석으로 처리 Ctrl+K, Ctrl+C 편집.선택영역을주석으로처리
단어 자동 완성 Ctrl+스페이스바

또는

Alt+오른쪽 화살표
편집.단어자동완성
매개 변수 팁 복사 Ctrl+Shift+Alt+C 편집.매개변수팁복사
필터 수준 낮춤 Alt+, 편집.필터수준낮춤
뒤로 삭제 백스페이스

또는

Shift+Bkspce
편집.뒤로삭제
가로 공백 삭제 Ctrl+K, Ctrl+\ 편집.가로공백삭제
문서 끝으로 Ctrl+End 편집.문서끝으로
문서 끝까지 선택 Ctrl+Shift+End 편집.문서끝까지선택
문서 시작으로 Ctrl+Home 편집.문서시작으로
문서 시작까지 선택 Ctrl+Shift+Home 편집.문서시작까지선택
전체 개요 확장 Ctrl+M, Ctrl+X 편집.전체개요확장
현재 영역 확장 Ctrl+M, Ctrl+E 편집.현재영역확장
선택 영역 확장 Shift+Alt+= Edit.ExpandSelection
포함하는 블록으로 선택 영역 확장 Shift+Alt+] Edit.ExpandSelectiontoContainingBlock
문서 서식 Ctrl+K, Ctrl+D 편집.문서서식
선택 영역 서식 Ctrl+K, Ctrl+F 편집.선택영역서식
전체로 이동 Ctrl+T

또는

Ctrl+,
Edit.GotoAll
중괄호로 이동 Ctrl+] Edit.GotoBrace
중괄호 확장으로 이동 Ctrl+Shift+] 편집.중괄호로이동확장
최근 항목으로 이동 Ctrl+T,R Edit.GotoRecent
파일의 다음 문제로 이동 Alt+PgDn Edit.GotoNextIssueinFile
파일의 이전 문제로 이동 Alt+PgUp Edit.GotoPreviousIssueinFile
선택영역 숨기기 Ctrl+M, Ctrl+H 편집.선택영역숨기기
필터 수준 높임 Alt+. 편집.필터수준높임
증분 검색 Ctrl+I 편집.증분검색
일치하는 모든 항목에 캐럿 삽입 Shift+Alt+; Edit.InsertCaretsatAllMatching
일치하는 다음 캐럿 삽입 Shift+Alt+. Edit.InsertNextMatchingCaret
삽입 탭 Tab 편집.탭삽입
줄 잘라내기 Ctrl+L 편집.줄잘라내기
줄 삭제 Ctrl+Shift+L 편집.줄삭제
줄 아래로 아래쪽 화살표 편집.줄아래로
한 줄 아래까지 선택 Shift+아래쪽 화살표 편집.한줄아래까지선택
한 줄 아래까지 열 확장 선택 Shift+Alt+아래쪽 화살표 편집.한줄아래까지열확장선택
줄 끝으로 End 편집.줄끝으로
줄 끝까지 선택 Shift+End 편집.줄끝까지선택
줄 끝까지 열 확장 선택 Shift+Alt+End 편집.줄끝까지열확장선택
위쪽 줄 열기 Ctrl+Enter 편집.위쪽줄열기
아래쪽 줄 열기 Ctrl+Shift+Enter 편집.아래쪽줄열기
줄 시작으로 Home 편집.줄시작으로
줄 시작까지 선택 Shift+Home 편집.줄시작까지선택
줄 시작까지 열 확장 선택 Shift+Alt+Home 편집.줄시작까지열확장선택
줄 바꾸기 Shift+Alt+T 편집.줄바꾸기
줄 위로 위쪽 화살표 편집.줄위로
한 줄 위까지 선택 Shift+위쪽 화살표 편집.한줄위까지선택
한 줄 위까지 열 확장 선택 Shift+Alt+위쪽 화살표 편집.한줄위까지열확장선택
멤버 목록 Ctrl+J 편집.멤버목록
소문자로 Ctrl+U 편집.소문자로
대문자로 Ctrl+Shift+U 편집.대문자로
선택한 줄을 아래로 이동 Alt+아래쪽 화살표 Edit.MoveSelectedLinesDown
선택한 줄을 위로 이동 Alt+위쪽 화살표 Edit.MoveSelectedLinesUp
다음 강조 표시 참조 Ctrl+Shift+아래쪽 화살표 편집.다음강조표시참조
겹쳐쓰기 모드 삽입 편집.겹쳐쓰기모드
페이지 아래로 PgDn 편집.페이지아래로
한 페이지 아래까지 선택 Shift+PgDn 편집.한페이지아래까지선택
페이지 위로 PgUp 편집.페이지위로
한 페이지 위까지 선택 Shift+PgUp 편집.한페이지위까지선택
매개 변수 정보 Ctrl+Shift+스페이스바 편집.매개변수정보
매개 변수 팁 붙여넣기 Ctrl+Shift+Alt+P 편집.매개변수팁붙여넣기
뒤로 피킹 Ctrl+Alt+- Edit.PeekBackward
정의 피킹 Alt+F12 Edit.PeekDefinition
앞으로 피킹 Ctrl+Alt+= Edit.PeekForward
이전 강조 표시 참조 Ctrl+Shift+위쪽 화살표 편집.이전강조표시참조
요약 정보 Ctrl+K, Ctrl+I 편집.요약정보
역방향 증분 검색 Ctrl+Shift+I 편집.역방향증분검색
아래로 줄 스크롤 Ctrl+아래쪽 화살표 편집.아래로줄스크롤
위로 줄 스크롤 Ctrl+위쪽 화살표 편집.위로줄스크롤
현재 단어 선택 Ctrl+W 편집.현재단어선택
선택 취소 Esc 편집.선택취소
이전 위치까지 선택 Ctrl+= 편집.이전위치까지선택
코드 렌즈 메뉴 표시 Ctrl+K, Ctrl+` Edit.ShowCodeLensMenu
탐색 메뉴 표시 Alt+` Edit.ShowNavigateMenu
현재 숨기기 중지 Ctrl+M, Ctrl+U 편집.현재숨기기중지
개요 표시 중지 Ctrl+M, Ctrl+P 편집.개요표시중지
앵커 바꾸기 Ctrl+K, Ctrl+A 편집.앵커바꾸기
왼쪽으로 탭 이동 Shift+Tab 편집.왼쪽으로탭이동
전체 개요 영역 표시/숨기기 Ctrl+M, Ctrl+L 편집.전체개요표시숨기기
책갈피 설정/해제 Ctrl+K, Ctrl+K 편집.책갈피설정해제
완료 모드 설정/해제 Ctrl+Alt+스페이스바 편집.완료모드설정/해제
개요 확장/축소 Ctrl+M, Ctrl+M 편집.개요확장축소
작업 목록 바로 가기 설정/해제 Ctrl+K, Ctrl+H 편집.작업목록바로가기설정해제
자동 줄 바꿈 설정/해제 Ctrl+E, Ctrl+W 편집.자동줄바꿈설정해제
선택 영역의 주석 처리 제거 Ctrl+K, Ctrl+U 편집.선택영역의주석처리제거
뷰 맨 아래로 Ctrl+PgDn 편집.뷰맨아래로
뷰 맨 아래까지 선택 Ctrl+Shift+PgDn 편집.뷰맨아래까지선택
뷰 맨 위로 Ctrl+PgUp 편집.뷰맨위로
뷰 맨 위까지 선택 Ctrl+Shift+PgUp 편집.뷰맨위까지선택
공백 보기 Ctrl+R, Ctrl+W 편집.공백보기
끝까지 단어 삭제 Ctrl+Delete 편집.끝까지단어삭제
시작까지 단어 삭제 Ctrl+백스페이스 편집.시작까지단어삭제
다음 단어로 Ctrl+오른쪽 화살표 편집.다음단어로
다음 단어까지 선택 Ctrl+Shift+오른쪽 화살표 편집.다음단어까지선택
다음 단어까지 열 확장 선택 Ctrl+Shift+Alt+오른쪽 화살표 편집.다음단어까지열확장선택
이전 단어로 Ctrl+왼쪽 화살표 편집.이전단어로
이전 단어까지 선택 Ctrl+Shift+왼쪽 화살표 편집.이전단어까지선택
이전 단어까지 열 확장 선택 Ctrl+Shift+Alt+왼쪽 화살표 편집.이전단어까지열확장선택
단어 바꾸기 Ctrl+Shift+T 편집.단어바꾸기
대화형으로 실행 Alt+Enter EditorContextMenus.CodeWindow.ExecuteInInteractive
대화형으로 줄 실행 Alt+' EditorContextMenus.CodeWindow.ExecuteLineInInteractive
페이지 검사기에서 보기 Ctrl+K, Ctrl+G OtherContextMenus.HTMLContext.ViewinPageInspector
TFS 주석 다음 영역 이동 Alt+PgDn TeamFoundationContextMenus.Annotate.TfsAnnotateMoveNextRegion
TFS 주석 이전 영역 이동 Alt+PgUp TeamFoundationContextMenus.Annotate.TfsAnnotateMovePreviousRegion

UML 작업 다이어그램: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
DELETE Shift+Del 편집.삭제

UML 클래스 다이어그램: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
모델에서 삭제 Shift+Del Edit.DeleteFromModel

UML 구성 요소 다이어그램: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
모델에서 삭제 Shift+Del Edit.DeleteFromModel

UML 사용 사례 다이어그램: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
모델에서 삭제 Shift+Del Edit.DeleteFromModel

VC 액셀러레이터 편집기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
새 가속기 삽입 Edit.NewAccelerator
입력된 다음 키 Ctrl+W Edit.NextKeyTyped

VC 대화 상자 편집기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
컨트롤 아래로 이동 아래쪽 화살표 편집.컨트롤아래로이동
컨트롤 왼쪽으로 이동 왼쪽 화살표 편집.컨트롤왼쪽으로이동
컨트롤 오른쪽으로 이동 오른쪽 화살표 편집.컨트롤오른쪽으로이동
컨트롤 위로 이동 위쪽 화살표 편집.컨트롤위로이동
열을 왼쪽으로 스크롤 Ctrl+왼쪽 화살표 Edit.ScrollColumnLeft
열을 오른쪽으로 스크롤 Ctrl+오른쪽 화살표 Edit.ScrollColumnRight
아래로 줄 스크롤 Ctrl+아래쪽 화살표 편집.아래로줄스크롤
위로 줄 스크롤 Ctrl+위쪽 화살표 편집.위로줄스크롤
아래로 컨트롤 크기 조정 Shift+아래쪽 화살표 편집.아래로컨트롤크기조정
왼쪽으로 컨트롤 크기 조정 Shift+왼쪽 화살표 편집.왼쪽으로컨트롤크기조정
오른쪽으로 컨트롤 크기 조정 Shift+오른쪽 화살표 편집.오른쪽으로컨트롤크기조정
위로 컨트롤 크기 조정 Shift+위쪽 화살표 편집.위로컨트롤크기조정
아래쪽 맞춤 Ctrl+Shift+아래쪽 화살표 Format.AlignBottoms
가운데 맞춤 Shift+F9 Format.AlignCenters
왼쪽 맞춤 Ctrl+Shift+왼쪽 화살표 Format.AlignLefts
중간 맞춤 F9 Format.AlignMiddles
오른쪽 맞춤 Ctrl+Shift+오른쪽 화살표 Format.AlignRights
위쪽 맞춤 Ctrl+Shift+위쪽 화살표 Format.AlignTops
단추 아래쪽 Ctrl+B Format.ButtonBottom
단추 오른쪽 Ctrl+R Format.ButtonRight
가로 가운데 맞춤 Ctrl+Shift+F9 Format.CenterHorizontal
세로 가운데 맞춤 Ctrl+F9 Format.CenterVertical
니모닉 검사 Ctrl+M Format.CheckMnemonics
콘텐츠에 맞게 크기 조정 Shift+F7 Format.SizetoContent
가로질러 배치 Alt+오른쪽 화살표

또는

Alt+왼쪽 화살표
Format.SpaceAcross
아래로 간격 맞춤 Alt+위쪽 화살표

또는

Alt+아래쪽 화살표
Format.SpaceDown
탭 순서 Ctrl+D Format.TabOrder
대화 상자 테스트 Ctrl+T Format.TestDialog
안내선 설정/해제 Ctrl+G Format.ToggleGuides

VC 이미지 편집기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
에어브러시 도구 Ctrl+A 이미지.에어브러시도구
브러시 도구 Ctrl+B 이미지.브러시도구
선택 항목 복사 및 윤곽선 그리기 Ctrl+Shift+U 이미지.선택항목복사및윤곽선그리기
불투명하기 그리기 Ctrl+J 이미지.불투명하게그리기
타원 도구 Alt+P 이미지.타원도구
지우기 도구 Ctrl+Shift+I 이미지.지우기도구
채워진 타원 도구 Ctrl+Shift+Alt+P 이미지.채워진타원도구윤곽선없음
채워진 사각형 도구 Ctrl+Shift+Alt+R 이미지.채워진사각형도구윤곽선없음
모퉁이가 둥근 채워진 사각형 도구 Ctrl+Shift+Alt+W 이미지.모퉁이가둥근채워진사각형도구
채우기 도구 Ctrl+F 이미지.채우기도구
좌우 대칭 이동 Ctrl+H 이미지.좌우대칭
상하 대칭 이동 Shift+Alt+H 이미지.상하대칭
더 큰 브러시 Ctrl+= 이미지.더큰브러시
선 도구 Ctrl+L 이미지.선도구
확대 도구 Ctrl+M 이미지.확대도구
확대 Ctrl+Shift+M 이미지.확대
새 이미지 형식 삽입 이미지.새이미지형식
다음 색 Ctrl+]

또는

Ctrl+오른쪽 화살표
이미지.다음색
다음 오른쪽 색 Ctrl+Shift+]

또는

Ctrl+Shift+오른쪽 화살표
이미지.다음오른쪽색
채워진 타원 도구(윤곽선 있음) Shift+Alt+P 이미지.채워진타원도구윤곽선있음
채워진 사각형 도구(윤곽선 있음) Shift+Alt+R 이미지.채워진사각형도구윤곽선있음
모퉁이가 둥근 채워진 사각형 도구(윤곽선 있음) Shift+Alt+W 이미지.모퉁이가둥근채워진사각형도구윤곽선있음
연필 도구 Ctrl+I 이미지.연필도구
이전 색 Ctrl+[

또는

Ctrl+왼쪽 화살표
이미지.이전색
이전 오른쪽 색 Ctrl+Shift+[

또는

Ctrl+Shift+왼쪽 화살표
이미지.이전오른쪽색
사각형 선택 도구 Shift+Alt+S 이미지.사각형선택도구
사각형 도구 Alt+R 이미지.사각형도구
90도 회전 Ctrl+Shift+H 이미지.90도회전
모퉁이가 둥근 사각형 도구 Alt+W 이미지.모퉁이가둥근사각형도구
모눈 표시 Ctrl+Alt+S 이미지.모눈표시
바둑판식 모눈 표시 Ctrl+Shift+Alt+S 이미지.바둑판식모눈표시
작은 브러시 Ctrl+. 이미지.작은브러시
더 작은 브러시 Ctrl+- 이미지.더작은브러시
텍스트 도구 Ctrl+T 이미지.텍스트도구
선택 항목을 브러시로 사용 Ctrl+U 이미지.선택항목을브러시로사용
확대 Ctrl+Shift+.

또는

Ctrl+위쪽 화살표
이미지.확대
축소 Ctrl+Shift+,

또는

Ctrl+아래쪽 화살표
이미지.축소

VC 문자열 편집기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
New string 삽입 Edit.NewString

뷰 디자이너: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
데이터 검색 취소 Ctrl+T 쿼리디자이너.데이터검색취소
조건 Ctrl+2 쿼리디자이너.조건
다이어그램 Ctrl+1 쿼리디자이너.다이어그램
SQL 실행 Ctrl+R 쿼리디자이너.SQL실행
행으로 이동 Ctrl+G QueryDesigner.GotoRow
조인 모드 Ctrl+Shift+J 쿼리디자이너.조인모드
결과 Ctrl+4 쿼리디자이너.결과
Sql Ctrl+3 쿼리디자이너.SQL

Visual Studio: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
메서드 창 숨기기 Ctrl+1 OtherContextMenus.ORDesignerContext.HideMethodsPane

Windows Forms 디자이너: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
구분선 Enter 편집.구분선
왼쪽 문자로 왼쪽 화살표 편집.왼쪽문자로
왼쪽 문자까지 선택 Shift+왼쪽 화살표 편집.왼쪽문자까지선택
오른쪽 문자로 오른쪽 화살표 편집.오른쪽문자로
오른쪽 문자까지 선택 Shift+오른쪽 화살표 편집.오른쪽문자까지선택
문서 끝으로 End 편집.문서끝으로
문서 끝까지 선택 Shift+End 편집.문서끝까지선택
문서 시작으로 Home 편집.문서시작으로
문서 시작까지 선택 Shift+Home 편집.문서시작까지선택
삽입 탭 Tab 편집.탭삽입
줄 아래로 아래쪽 화살표 편집.줄아래로
한 줄 아래까지 선택 Shift+위쪽 화살표 편집.한줄아래까지선택
줄 위로 위쪽 화살표 편집.줄위로
한 줄 위까지 선택 Shift+아래쪽 화살표 편집.한줄위까지선택
컨트롤 아래로 이동 Ctrl+아래쪽 화살표 편집.컨트롤아래로이동
컨트롤 왼쪽으로 이동 Ctrl+왼쪽 화살표 편집.컨트롤왼쪽으로이동
컨트롤 오른쪽으로 이동 Ctrl+오른쪽 화살표 편집.컨트롤오른쪽으로이동
컨트롤 위로 이동 Ctrl+위쪽 화살표 편집.컨트롤위로이동
선택 취소 Esc 편집.선택취소
아래로 컨트롤 크기 조정 Ctrl+Shift+아래쪽 화살표 편집.아래로컨트롤크기조정
왼쪽으로 컨트롤 크기 조정 Ctrl+Shift+왼쪽 화살표 편집.왼쪽으로컨트롤크기조정
오른쪽으로 컨트롤 크기 조정 Ctrl+Shift+오른쪽 화살표 편집.오른쪽으로컨트롤크기조정
위로 컨트롤 크기 조정 Ctrl+Shift+위쪽 화살표 편집.위로컨트롤크기조정
왼쪽으로 탭 이동 Shift+Tab 편집.왼쪽으로탭이동

작업 항목 편집기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
작업 항목 복사본 만들기 Shift+Alt+C Edit.CreateCopyofWorkItem
작업 항목 새로 고침 F5 Edit.RefreshWorkItem
링크된 새 작업 항목 Shift+Alt+L Team.NewLinkedWorkItem

작업 항목 쿼리 뷰: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
작업 항목 복사본 만들기 Shift+Alt+C Edit.CreateCopyofWorkItem
들여쓰기 Shift+Alt+오른쪽 화살표 Edit.Indent
내어쓰기 Shift+Alt+왼쪽 화살표 Edit.Outdent
링크된 새 작업 항목 Shift+Alt+L Team.NewLinkedWorkItem
새로 고침 F5 Team.Refresh
Toggle Shift+Alt+V Window.Toggle

작업 항목 결과 뷰: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
작업 항목 복사본 만들기 Shift+Alt+C Edit.CreateCopyofWorkItem
들여쓰기 Shift+Alt+오른쪽 화살표 Edit.Indent
내어쓰기 Shift+Alt+왼쪽 화살표 Edit.Outdent
다음 작업 항목으로 이동 Shift+Alt+N Team.GotoNextWorkItem
이전 작업 항목으로 이동 Shift+Alt+P Team.GotoPreviousWorkItem
링크된 새 작업 항목 Shift+Alt+L Team.NewLinkedWorkItem
새로 고침 F5 Team.Refresh
Toggle Shift+Alt+V Window.Toggle

워크플로 디자이너: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
단어 자동 완성 Ctrl+K, W

또는

Ctrl+K, Ctrl+W

또는

Ctrl+스페이스바

또는

Alt+오른쪽 화살표
편집.단어자동완성
필터 수준 낮춤 Alt+, 편집.필터수준낮춤
필터 수준 높임 Alt+. 편집.필터수준높임
멤버 목록 Ctrl+K, L

또는

Ctrl+K, Ctrl+L

또는

Ctrl+J
편집.멤버목록
매개 변수 정보 Ctrl+K, P

또는

Ctrl+K, Ctrl+P

또는

Ctrl+Shift+스페이스바
편집.매개변수정보
요약 정보 Ctrl+K, I

또는

Ctrl+K, Ctrl+I
편집.요약정보
축소 Ctrl+E, Ctrl+C

또는

Ctrl+E, C
WorkflowDesigner.Collapse
모두 축소 또는 WorkflowDesigner.CollapseAll
노드 연결 Ctrl+E, Ctrl+F

또는

Ctrl+E, F
WorkflowDesigner.ConnectNodes
변수 만들기 Ctrl+E, Ctrl+N

또는

Ctrl+E, N
WorkflowDesigner.CreateVariable
모두 확장 Ctrl+E, Ctrl+X

또는

Ctrl+E, X
WorkflowDesigner.ExpandAll
현재 항목 확장 Ctrl+E, Ctrl+E

또는

Ctrl+E, E
WorkflowDesigner.ExpandInPlace
부모로 이동 Ctrl+E, Ctrl+P

또는

Ctrl+E, P
WorkflowDesigner.GoToParent
포커스 이동 Ctrl+E, Ctrl+M

또는

Ctrl+E, M
WorkflowDesigner.MoveFocus
디자이너 탐색 Ctrl+Alt+F6 WorkflowDesigner.NavigateThroughDesigner
복원 Ctrl+E, Ctrl+R

또는

Ctrl+E, R
WorkflowDesigner.Restore
인수 디자이너 표시/숨기기 Ctrl+E, Ctrl+A

또는

Ctrl+E, A
WorkflowDesigner.ShowHideArgumentDesigner
가져오기 디자이너 표시/숨기기 Ctrl+E, Ctrl+I

또는

Ctrl+E, I
WorkflowDesigner.ShowHideImportsDesigner
개요 맵 표시/숨기기 Ctrl+E, Ctrl+O(문자 ‘O’)

또는

Ctrl+E, O
WorkflowDesigner.ShowHideOverviewMap
변수 디자이너 표시/숨기기 Ctrl+E, Ctrl+V

또는

Ctrl+E, V
WorkflowDesigner.ShowHideVariableDesigner
선택 영역 토글 Ctrl+E, Ctrl+S

또는

Ctrl+E, S
WorkflowDesigner.ToggleSelection
확대 Ctrl+Num + WorkflowDesigner.ZoomIn
축소 Ctrl+Num - WorkflowDesigner.ZoomOut

XAML UI 디자이너: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
모두 맞춤 Ctrl+0(영) Design.FitAll
핸들 표시 F9 Design.ShowHandles
확대 Ctrl+Alt+= Design.ZoomIn
축소 Ctrl+Alt+- Design.ZoomOut
디자이너 옵션 Ctrl+Shift+;
텍스트 편집 F2 Format.EditText
모두 Ctrl+Shift+R Format.ResetLayout.All
프로젝트 코드 실행 Ctrl+F9
숨기기(Blend에만 해당) Ctrl+H Timeline.Hide(Blend에만 해당)
잠금(Blend에만 해당) Ctrl+L Timeline.Lock(Blend에만 해당)
표시(Blend에만 해당) Ctrl+Shift+H Timeline.Show(Blend에만 해당)
잠금 해제(Blend에만 해당) Ctrl+Shift+L Timeline.Unlock(Blend에만 해당)
왼쪽 가장자리를 왼쪽으로 이동 Ctrl+Shift+, View.EdgeLeftMoveLeft
왼쪽 가장자리 오른쪽으로 이동 Ctrl+Shift+. View.EdgeLeftMoveRight
오른쪽 가장자리를 왼쪽으로 이동 Ctrl+Shift+Alt+, View.EdgeRightMoveLeft
오른쪽 가장자리를 오른쪽으로 이동 Ctrl+Shift+Alt+. View.EdgeRightMoveRight
속성 마커 메뉴 표시 Ctrl+스페이스바 View.ShowPropertyMarkerMenu

XML(텍스트) 편집기: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
XSLT 디버깅 시작 Alt+F5 XML.StartXSLTDebugging
디버그하지 않고 XSLT 시작 Ctrl+Alt+F5 XML.StartXSLTWithoutDebugging

XML 스키마 디자이너: 컨텍스트별 바로 가기 키

이 컨텍스트와 관련된 바로 가기 키는 다음과 같습니다.

명령 바로 가기 키 명령 ID
아래쪽에서 위쪽 Alt+위쪽 화살표 GraphView.BottomtoTop
왼쪽에서 오른쪽 Alt+오른쪽 화살표 GraphView.LefttoRight
오른쪽에서 왼쪽 Alt+왼쪽 화살표 GraphView.RighttoLeft
위쪽에서 아래쪽 Alt+아래쪽 화살표 GraphView.ToptoBottom
작업 영역에서 제거 삭제 기타상황에맞는메뉴.그래프뷰.작업영역에서제거
콘텐츠 모델 뷰 표시 Ctrl+2 XSD디자이너.콘텐츠모델뷰표시
그래프 뷰 표시 Ctrl+3 XSD디자이너.그래프뷰표시
시작 뷰 표시 Ctrl+1 XSD디자이너.시작뷰표시