Configurar BFD no ExpressRoute

O ExpressRoute dá suporte à BFD (Detecção de Encaminhamento Bidirecional) em emparelhamento privado e da Microsoft. Ao habilitar a BFD sobre ExpressRoute, você poderá acelerar a detecção de falhas de link entre dispositivos MSEE (Microsoft Enterprise Edge) e roteadores para os quais o circuito do ExpressRoute é configurado (CE/PE). É possível configurar o ExpressRoute nos dispositivos de roteamento de borda ou dispositivos de roteamento de Borda do Parceiro (se tiver optado pelo serviço de conexão gerenciado da Camada 3). Este documento explica a necessidade de BFD e de como habilitar a BFD no ExpressRoute.

Necessidade de BFD

O diagrama a seguir mostra o benefício de habilitar a BFD no circuito do ExpressRoute: 1

É possível habilitar o circuito do ExpressRoute por meio de conexões da Camada 2 ou por conexões gerenciadas da Camada 3. Em ambos os casos, se houver um ou mais dispositivos de Camada 2 no caminho de conexão do ExpressRoute, a responsabilidade de detectar qualquer falha de vínculo no caminho está na sessão BGP sobreposta.

Nos dispositivos MSEE, o tempo em espera e de keep alive de BGP são tipicamente configurados como 60 e 180 segundos, respectivamente. Por isso, quando uma falha de link acontece, poderá levar até três minutos para detectá-la e alternar o tráfego para uma conexão alternativa.

É possível controlar os temporizadores de BGP, configurando um tempo em espera e de keep alive de BGP inferior no seu dispositivo de emparelhamento de borda. Se os temporizadores BGP não forem os mesmos entre os dois dispositivos de emparelhamento, a sessão BGP será estabelecida usando o valor de tempo menor. O keep alive do BGP pode ser definido por três segundos e o tempo de espera por 10 segundos. No entanto, a definição de um temporizador BGP muito agressivo não é recomendada porque o protocolo tem uso intensivo de processo.

Nesse cenário, a BFD pode ajudar. A BFD fornece detecção de falha de vínculo de baixa sobrecarga em um intervalo de tempo em fração de segundos.

Observação

O BFD fornece um tempo de failover mais rápido quando uma falha de link é detectada, mas a convergência de conexão geral levará até um minuto para o failover entre os gateways de rede virtual do ExpressRoute e os MSEEs.

Habilitar BFD

A BFD é configurada por padrão em todas as interfaces de emparelhamento privado do ExpressRoute criadas recentemente nos MSEEs. Dessa forma, para habilitar a BFD, você só precisará configurá-la em seus dispositivos primários e secundários. Configurar a BFD é um processo de duas etapas. Configure a BFD na interface e vincule-a à sessão BGP.

Um exemplo de configuração de CE/PE (usando o Cisco IOS XE) é mostrado abaixo.

interface TenGigabitEthernet2/0/0.150
   description private peering to Azure
   encapsulation dot1Q 15 second-dot1q 150
   ip vrf forwarding 15
   ip address 192.168.15.17 255.255.255.252
   bfd interval 300 min_rx 300 multiplier 3


router bgp 65020
   address-family ipv4 vrf 15
      network 10.1.15.0 mask 255.255.255.128
      neighbor 192.168.15.18 remote-as 12076
      neighbor 192.168.15.18 fall-over bfd
      neighbor 192.168.15.18 activate
      neighbor 192.168.15.18 soft-reconfiguration inbound
   exit-address-family

Observação

Para habilitar a BFD em um emparelhamento privado já existente, será necessário redefinir o emparelhamento. Consulte Redefinir emparelhamentos do ExpressRoute

Negociação de temporizador de BFD

Entre pares de BFD, o mais lento dos dois pares determina a taxa de transmissão. Os intervalos de transmissão/recepção de BFD dos MSEEs estão definidos para 300 milissegundos. Em determinados cenários, o intervalo pode ser definido em um valor mais alto de 750 milissegundos. Ao configurar um valor mais alto, você poderá forçar esses intervalos a ser mais longos, mas não será possível torná-los mais curtos.

Observação

Se você configurou circuitos ExpressRoute com redundância geográfica ou usou a conectividade VPN IPSec site a site como backup. A habilitação de BFD ajudará o failover mais rápido após uma falha de conectividade do ExpressRoute.

Próximas etapas

Para obter mais informações ou ajuda, confira os seguintes links: