Solucionar problemas de implantação ao reiniciar ou redimensionar uma VM do Windows existente no Azure

Ao tentar iniciar uma máquina virtual (VM) do Azure parada ou redimensionar uma VM do Azure existente, o erro comum encontrado é uma falha de alocação. Esse erro ocorre quando o cluster ou a região não tem recursos disponíveis ou não oferece suporte ao tamanho de VM solicitado.

Se o seu problema do Azure não for abordado neste artigo, visite os fóruns do Azure em MSDN e Stack Overflow. Você pode postar seu problema nesses fóruns ou postar em @AzureSupport no Twitter. Você também pode enviar uma solicitação de suporte do Azure. Para enviar uma solicitação de suporte, na página Suporte do Azure, selecione Obter suporte.

Coletar logs de atividade

Para iniciar a solução de problemas, colete os logs de atividades para identificar o erro associado ao problema. Os links a seguir contêm informações detalhadas sobre o processo:

Ver operações de implantação

Visualizar logs de atividades para gerenciar recursos do Azure

Problema: erro ao iniciar uma VM parada

Você tenta iniciar uma VM parada, mas obtém uma falha de alocação.

Motivo

A solicitação para iniciar a VM interrompida deve ser tentada no cluster original que hospeda o serviço de nuvem. No entanto, o cluster não tem espaço livre disponível para atender à solicitação.

Solução

  • Pare todas as VMs no conjunto de disponibilidade e reinicie cada VM.

    1. Clique em Grupos de recursos>seu grupo de recursos>Recursos>seu conjunto de disponibilidade>Máquinas Virtuais>sua máquina virtual>Parar.
    2. Depois que todas as VMs pararem, selecione cada uma das VMs paradas e clique em Iniciar.
  • Repita a solicitação de reinicialização mais tarde.

Problema: erro ao redimensionar uma VM existente

Você tenta redimensionar uma VM existente, mas obtém uma falha de alocação.

Motivo

A solicitação para redimensionar a VM deve ser tentada no cluster original que hospeda o serviço de nuvem. No entanto, o cluster não oferece suporte ao tamanho de VM solicitado.

Solução

  • Repita a solicitação usando um tamanho de VM menor.

  • Se o tamanho da VM solicitada não puder ser alterado:

    1. Pare todas as VMs no conjunto de disponibilidade.

      • Clique em Grupos de recursos>seu grupo de recursos>Recursos>seu conjunto de disponibilidade>Máquinas Virtuais>sua máquina virtual>Parar.
    2. Depois que todas as VMs pararem, redimensione a VM desejada para um tamanho maior.

    3. Selecione a VM redimensionada e clique em Iniciar e, em seguida, inicie cada uma das VMs interrompidas.

Erro ao parar, iniciar, reiniciar ou reimplantar uma VM existente

Quando você tenta parar, iniciar, reiniciar ou reimplantar uma VM existente, o processo falha e você recebe um "Erro inesperado ao processar o perfil de rede da VM. Tente novamente a mensagem de erro posterior. Quando esse erro ocorre, a VM é colocada em estado de falha.

Motivo

Esse problema ocorre se houver um problema na alocação ou atualização de recursos de rede.

Solução

Tente reaplicar o estado da máquina virtual. Esta operação executa novamente o provisionamento de VM e ajuda a resolver a falha de estado da VM que ocorre se o provisionamento de VM falhou quando você executou uma ação de VM anterior.

  1. Navegue até a VM que está travada no estado de falha.
  2. Em Ajuda, selecione Reimplementar reaplicar.
  3. Selecione a opção Aplicar novamente.

Próximas etapas

Se você encontrar problemas ao criar uma nova VM do Windows no Azure, consulte Solucionar problemas de implantação ao criar uma nova máquina virtual do Windows no Azure.

Entre em contato conosco para obter ajuda

Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.