Loop de reinicialização do Windows em uma VM do Azure

Este artigo descreve o loop de reinicialização que pode ocorrer em uma máquina virtual (VM) do Windows no Microsoft Azure.

Sintoma

Ao usar o Diagnóstico de inicialização para obter as capturas de tela de uma VM, você descobre que a máquina virtual está inicializando, mas o processo de inicialização está sendo interrompido e o processo está reiniciando.

A captura de tela mostra que a máquina virtual está inicializando.

Motivo

O loop de reinicialização ocorre devido às seguintes causas:

Causa 1

Há um serviço de terceiros sinalizado como crítico e não pode ser iniciado. Isso faz com que o sistema operacional seja reinicializado. Para resolve esse problema, consulte Solução para causa 1.

Causa 2

Algumas mudanças foram feitas no sistema operacional. Normalmente, eles estão relacionados a uma instalação de atualização, instalação de aplicativo ou uma nova política. Você pode ter que verificar os seguintes logs para obter detalhes adicionais:

  • Logs de evento
  • CBS.logWindows
  • Update.log

Para resolve esse problema, consulte Solução para causa 2.

Causa 3

Uma corrupção de hive do registro pode causar esse problema. Para resolve esse problema, consulte Solução para causa 3.

Solução

Dica

Se você tiver um backup recente da VM, tente restaurar a VM do backup para corrigir o problema de inicialização.

Para resolver esse problema, faça backup do disco do sistema operacional e anexe o disco do sistema operacional a uma VM de resgate e siga as opções de solução apropriadas ou tente as soluções uma a uma.

Solução para a causa 1

  1. Depois que o disco do sistema operacional estiver conectado a uma VM em funcionamento, certifique-se de que o disco esteja sinalizado como Online no console de Gerenciamento de Disco e anote a letra da unidade da partição que contém a pasta \Windows.

  2. Se o disco estiver definido como Offline, defina-o como Online.

  3. Crie uma cópia da pasta \Windows\System32\config caso seja necessário reverter as alterações.

  4. Na VM de resgate, abra o Editor do Registro do Windows (regedit).

  5. Selecione a chave HKEY_LOCAL_MACHINE e, em seguida, selecione Arquivo>Carregar Hive no menu.

  6. Navegue até o arquivo SYSTEM na pasta \Windows\System32\config.

  7. Selecione Abrir, digite BROKENSYSTEM para o nome, expanda a chave HKEY_LOCAL_MACHINE e você verá uma chave adicional chamada BROKENSYSTEM.

  8. Verifique de qual ControlSet o computador está inicializando. Você verá seu número de chave na seguinte chave de registro.

    HKEY_LOCAL_MACHINE\BROKENSYSTEM\Select\Current

  9. Verifique qual é a criticidade do serviço do agente VM por meio da seguinte chave de registro.

    HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\RDAgent\ErrorControl

  10. Se o valor da chave de registro não estiver definido como 2, vá para a próxima mitigação.

  11. Se o valor da chave de registro estiver definido como 2, altere o valor de 2 para 1.

  12. Se alguma das seguintes chaves existir e tiver o valor 2 ou 3, altere esses valores para 1 de acordo:

    • HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\AzureWLBackupCoordinatorSvc\ErrorControl
    • HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\AzureWLBackupInquirySvc\ErrorControl
    • HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\AzureWLBackupPluginSvc\ErrorControl
  13. Selecione a chave BROKENSYSTEM e, em seguida, selecione Arquivo>Descarregar Hive no menu.

  14. Desanexe o disco do sistema operacional da VM de solução de problemas.

  15. Remova o disco da VM de solução de problemas e aguarde cerca de 2 minutos para que o Azure libere esse disco.

  16. Crie uma nova VM a partir do disco do sistema operacional.

  17. Se o problema for corrigido, talvez seja necessário reinstalar o RDAgent (WaAppAgent.exe).

Solução para a causa 2

Restaure a VM para a última configuração válida, siga as etapas em Como iniciar a VM do Windows do Azure com a última configuração válida.

Solução para a causa 3

Observação

O procedimento a seguir deve ser usado apenas como último recurso. Embora a restauração do regback possa restaurar o acesso à máquina, o sistema operacional não é considerado estável, pois há dados perdidos no registro entre o registro de data e hora da seção e o dia atual. Você precisa criar uma nova VM e fazer planos para migrar dados.

  1. Depois que o disco estiver conectado a uma VM de solução de problemas, verifique se o disco está sinalizado como Online no console de gerenciamento de disco.

  2. Crie uma cópia da pasta \Windows\System32\config caso seja necessário reverter as alterações.

  3. Copie os arquivos da pasta \Windows\System32\config\regback e substitua os arquivos da pasta \Windows\System32\config.

  4. Remova o disco da VM de solução de problemas e aguarde cerca de 2 minutos para que o Azure libere esse disco.

  5. Crie uma nova VM a partir do disco do sistema operacional.

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