A inicialização da VM está travada em "Preparando o Windows. Não desligue o computador" no Azure

Este artigo descreve as telas "Preparando- se" e "Preparando o Windows" que você pode encontrar ao iniciar uma VM (máquina virtual) do Windows no Microsoft Azure. Ele fornece etapas para ajudá-lo a coletar dados para um tíquete de suporte.

Observação

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Sintomas

Uma VM do Windows não inicia. Ao usar o Diagnóstico de inicialização para obter a captura de tela da VM, você pode ver que a VM exibe a mensagem "Preparando" ou "Preparando o Windows".

Captura de tela da VM do Windows Server 2012 R2 mostrando a mensagem: Preparando.

Captura de tela do V M, mostrando a mensagem: Preparando o Windows.

Motivo

Normalmente, esse problema ocorre quando o servidor faz a reinicialização final após a alteração da configuração. A alteração de configuração pode ser inicializada pelas atualizações do Windows ou pelas alterações nas funções ou no recurso do servidor. Para Windows Update, se as atualizações forem grandes, o sistema operacional precisará de mais tempo para reconfigurar as alterações.

Solução 1: restaurar a VM de um backup

Se você tiver um backup recente da VM, poderá tentar restaurar a VM do backup para corrigir o problema de inicialização.

Solução 2: Coletar um arquivo de despejo de memória do sistema operacional

Se a restauração da VM do backup não for possível ou não resolve o problema, você precisará coletar um arquivo de despejo de memória para que a falha possa ser analisada.

Etapa 1: Coletar o arquivo de despejo diretamente

Parte 1: Anexe o disco do sistema operacional a uma VM de recuperação
  1. Faça um instantâneo do disco do sistema operacional da VM afetada para criar um backup. Para obter mais informações, consulte Criar um instantâneo de um disco rígido virtual.

  2. Anexe o disco do SO a uma VM de recuperação.

  3. Use o Protocolo de Área de Trabalho Remota (RDP) para se conectar à VM de recuperação.

  4. Se o disco do sistema operacional da VM afetada estiver criptografado, desative a criptografia antes de passar para a próxima etapa. Para saber mais, consulte Descriptografar o disco criptografado do sistema operacional.

Parte 2: Localize o arquivo de despejo e envie um tíquete de suporte
  1. Na VM de recuperação, vá para a pasta do Windows no disco do sistema operacional anexado. Por exemplo, se a letra do driver atribuída ao disco do sistema operacional anexado for F, vá para F:\Windows.

  2. Localize o arquivo Memory.dmp e, em seguida, envie um tíquete de suporte com o arquivo de dump.

Se você não conseguir localizar o arquivo de despejo, vá para as próximas etapas para habilitar o log de despejo e o console serial e, em seguida, acione o processo de despejo de memória.

Parte 2: habilitar um log de dump e o console serial

Importante

Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para maior proteção, faça backup do Registro antes de modificar, para poder restaurar se ocorrer um problema. Para saber mais sobre como fazer o backup e restaurar o registro, consulte Como fazer o backup e restaurar o registro no Windows.

Para habilitar o log de despejo e o console serial, execute o seguinte script:

  1. Abra uma sessão de prompt de comando elevado como administrador.

  2. Execute os seguintes comandos BCDEdit usando as opções /ems e /emssettings:

    Ative o Console Serial:

    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON
    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
    
  3. Verifique se o espaço livre no disco do sistema operacional é maior que o tamanho da memória (RAM) na VM.

    Se não houver espaço suficiente no disco do sistema operacional, altere o local onde o arquivo de despejo de memória será criado e indique esse local para qualquer disco de dados anexado à VM que tenha espaço livre suficiente. Para alterar o local, substitua %SystemRoot% pela letra da unidade do disco de dados, como F:, nos comandos a seguir.

    Para habilitar o arquivo de despejo do sistema operacional, execute os seguintes comandos load, add e unload para implementar a configuração sugerida usando a ferramenta reg:

    Carregue o Hive de Registro do disco do sistema operacional quebrado:

    reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
    

    Ativar no ControlSet001:

    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Ativar no ControlSet002:

    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Descarregue o disco quebrado do sistema operacional:

    reg unload HKLM\<broken-system>
    

Verifique se há espaço suficiente no disco para alocar tanta memória quanto a RAM, o que depende do tamanho que você está selecionando para esta VM. Se não houver espaço suficiente ou se houver uma VM de tamanho grande (série G, GS ou E), você poderá alterar o local em que esse arquivo é criado e encaminhá-lo a qualquer outro disco de dados anexado à VM. Para fazer isso, você precisa modificar as chaves do registro, conforme mostrado no seguinte código:

reg load HKLM\BROKENSYSTEM F:\windows\system32\config\SYSTEM

REG ADD "HKLM\BROKENSYSTEM\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "<DRIVE LETTER OF YOUR DATA DISK>:\MEMORY.DMP" /f
REG ADD "HKLM\BROKENSYSTEM\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "<DRIVE LETTER OF YOUR DATA DISK>:\MEMORY.DMP" /f

reg unload HKLM\BROKENSYSTEM

Etapa 3: Disparar o processo de despejo de memória

  1. Desanexe o disco do SO e Reconecte o disco do SO à VM afetada.

  2. Inicie a VM e acesse o console serial.

  3. Selecione Send Non-Maskable Interrupt(NMI) para acionar o despejo de memória.

    Captura de tela do item Send Non-Maskable Interrupt.

  4. Siga as instruções na Etapa 1: Colete o arquivo de despejo diretamente novamente .

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