O Windows mostra um erro de tela azul ao inicializar uma VM do Azure

Este artigo lista os erros de tela azul que você pode receber ao iniciar uma máquina virtual (VM) do Windows no Microsoft Azure. Ele fornece etapas para ajudá-lo a coletar dados para um tíquete de suporte.

Sintomas

Uma VM do Windows não inicia. Ao verificar as capturas de tela de inicialização em Diagnóstico de inicialização, você verá uma das seguintes mensagens de erro em uma tela azul:

Seu PC encontrou um problema e precisa ser reiniciado. Estamos apenas coletando algumas informações de erro e você pode reiniciar.

Seu PC encontrou um problema e precisa ser reiniciado.

Motivo

Pode haver muitas razões pelas quais você experimenta um erro de parada. As causas mais comuns são os seguintes problemas:

  • Problema com um driver
  • Arquivo de sistema ou memória corrompidos
  • Um aplicativo acessa um setor proibido da memória

Solução

Dica

Se você tiver um backup recente da VM, tente restaurar a VM do backup para corrigir o problema de inicialização.

Para resolver esse problema, primeiro você precisa coletar um arquivo de despejo para a falha antes de entrar em contato com o suporte. Para excluir o arquivo de despejo, siga estas etapas:

Parte 1: localize o arquivo dump e envie um tíquete de suporte

Parte 1: Anexe o disco do sistema operacional a uma VM de recuperação
  1. Faça um instantâneo do disco do sistema operacional da VM afetada para criar um backup. Para obter mais informações, consulte Criar um instantâneo de um disco rígido virtual.

  2. Anexe o disco do SO a uma VM de recuperação.

  3. Use o Protocolo de Área de Trabalho Remota (RDP) para se conectar à VM de recuperação.

  4. Se o disco do sistema operacional da VM afetada estiver criptografado, desative a criptografia antes de passar para a próxima etapa. Para saber mais, consulte Descriptografar o disco criptografado do sistema operacional.

Parte 2: Localize o arquivo de despejo e envie um tíquete de suporte
  1. Na VM de recuperação, vá para a pasta do Windows no disco do sistema operacional anexado. Por exemplo, se a letra do driver atribuída ao disco do sistema operacional anexado for F, vá para F:\Windows.

  2. Localize o arquivo Memory.dmp e, em seguida, envie um tíquete de suporte com o arquivo de dump.

Se você não conseguir encontrar o arquivo de dump, passe para as próximas etapas para habilitar um log de dump e um console serial, e reproduza o problema

Parte 2: habilitar um log de dump e o console serial

Importante

Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para maior proteção, faça backup do Registro antes de modificar, para poder restaurar se ocorrer um problema. Para saber mais sobre como fazer o backup e restaurar o registro, consulte Como fazer o backup e restaurar o registro no Windows.

Para habilitar o log de dump e o console serial, siga estas etapas:

  1. Abra uma sessão de prompt de comando elevado como administrador.

  2. Execute os seguintes comandos BCDEdit usando as opções /ems e /emssettings:

    Ative o Console Serial:

    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON
    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
    
  3. Verifique se o espaço livre no disco do sistema operacional é maior que o tamanho da memória (RAM) na VM.

    Se não houver espaço suficiente no disco do sistema operacional, altere o local onde o arquivo de despejo de memória será criado e indique esse local para qualquer disco de dados anexado à VM que tenha espaço livre suficiente. Para alterar o local, substitua %SystemRoot% pela letra da unidade do disco de dados, como F:, nos comandos a seguir.

    Para habilitar o arquivo de despejo do sistema operacional, execute os seguintes comandos load, add e unload para implementar a configuração sugerida usando a ferramenta reg:

    Carregue o Hive de Registro do disco do sistema operacional quebrado:

    reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
    

    Ativar no ControlSet001:

    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Ativar no ControlSet002:

    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Descarregue o disco quebrado do sistema operacional:

    reg unload HKLM\<broken-system>
    

Etapa 3: reproduzir o problema

  1. Desanexe o disco do sistema operacional e reconecte o disco do sistema operacional à VM afetada.

  2. Inicie a VM para reproduzir o problema e, em seguida, um arquivo de despejo será gerado.

  3. Repita as instruções na Etapa 1: localize o arquivo de dump e envie uma seção de tíquete de suporte.

Entre em contato conosco para obter ajuda

Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.