Windows loop de reinicialização em uma VM do Azure

Este artigo descreve o loop de reinicialização que você pode experimentar em uma Windows Virtual Machine (VM) em Microsoft Azure.

Sintoma

Quando você usa diagnósticos de inicialização para obter as capturas de tela de uma VM, você descobre que a máquina virtual está sendo inicializada, mas o processo de inicialização está sendo interrompido e o processo está começando de novo.

Tela inicial 1

Motivo

O loop de reinicialização ocorre devido às seguintes causas:

Causa 1

Há um serviço de terceiros que é sinalizado como crítico e não pode ser iniciado. Isso faz com que o sistema operacional seja reiniciado.

Causa 2

Algumas alterações foram feitas no sistema operacional. Normalmente, eles estão relacionados a uma instalação de atualização, instalação de aplicativo ou uma nova política. Talvez seja preciso verificar os seguintes logs para obter detalhes adicionais:

  • Logs de eventos
  • CBS.logWindows
  • Update.log

Causa 3

A corrupção do sistema de arquivos pode causar isso. No entanto, é difícil diagnosticar e identificar a alteração que causa a corrupção do sistema operacional.

Solução

Dica

Se você tiver um backup recente da VM, poderá tentar restaurar a VM do backup para corrigir o problema de inicialização.

Para resolver esse problema, backup do disco do sistemaoperacional e anexar o disco do sistema operacional a uma VMde salvamento e, em seguida, siga as opções de solução adequadamente ou tente as soluções uma a uma.

Solução para a causa 1

  1. Depois que o disco do sistema operacional for anexado a uma VM de trabalho, certifique-se de que o disco seja sinalizado como Online no console de Gerenciamento de Disco e anote a letra da unidade da partição que contém a pasta \Windows.

  2. Se o disco estiver definido como Offline, des defini-lo como Online.

  3. Crie uma cópia da pasta \Windows\System32\config no caso de uma reação nas alterações ser necessária.

  4. Na VM de salvamento, abra Windows Editor de Registro (regedit).

  5. Selecione a HKEY_LOCAL_MACHINE e selecione Hive de Carga de Arquivo > no menu.

  6. Navegue até o arquivo SYSTEM na pasta \Windows\System32\config.

  7. Selecione Abrir, digite BROKENSYSTEM para o nome, expanda a tecla HKEY_LOCAL_MACHINE e, em seguida, você verá uma chave adicional chamada BROKENSYSTEM.

  8. Verifique de qual ControlSet o computador está inicializando. Você verá seu número de chave na chave do Registro a seguir.

    HKEY_LOCAL_MACHINE\BROKENSYSTEM\Select\Current

  9. Verifique qual é a criticidade do serviço de agente VM por meio da seguinte chave do Registro.

    HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\RDAgent\ErrorControl

  10. Se o valor da chave do Registro não estiver definido como 2, vá para a próxima mitigação.

  11. Se o valor da chave do Registro estiver definido como 2, altere o valor de 2 para 1.

  12. Se alguma das teclas a seguir existir e elas têm o valor 2 ou 3 e, em seguida, altere esses valores para 1 de acordo:

    • HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\AzureWLBackupCoordinatorSvc\ErrorControl
    • HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\AzureWLBackupInquirySvc\ErrorControl
    • HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\AzureWLBackupPluginSvc\ErrorControl
  13. Selecione a tecla BROKENSYSTEM e selecione Hive > de Descarregamento de Arquivo no menu.

  14. Desconectar o disco do sistema operacional da VM de solução de problemas.

  15. Remova o disco da VM de solução de problemas e aguarde cerca de 2 minutos para o Azure liberar esse disco.

  16. Crie uma nova VM a partir do disco do sistema operacional.

  17. Se o problema for corrigido, talvez seja preciso reinstalar o RDAgent (WaAppAgent.exe).

Solução para a causa 2

Restaure a VM para a última boa configuração conhecida, siga as etapas em How to start Azure Windows VM with Last Known Good Configuration.

Solução para a causa 3

Observação

O procedimento a seguir deve ser usado apenas como último recurso. Embora a restauração do regback possa restaurar o acesso ao computador, o sistema operacional não é considerado estável, pois há dados perdidos no registro entre o datastamp do hive e o dia atual. Você precisa criar uma nova VM e fazer planos para migrar dados.

  1. Depois que o disco for anexado a uma VM de solução de problemas, certifique-se de que o disco seja sinalizado como Online no console de Gerenciamento de Disco.

  2. Crie uma cópia da pasta \Windows\System32\config no caso de uma reação nas alterações ser necessária.

  3. Copie os arquivos na pasta \Windows\System32\config\regback e substitua os arquivos na pasta \Windows\System32\config.

  4. Remova o disco da VM de solução de problemas e aguarde cerca de 2 minutos para o Azure liberar esse disco.

  5. Crie uma nova VM a partir do disco do sistema operacional.