Codificações e términos de linhaEncodings and line endings

Os seguintes caracteres são interpretados como quebras de linha no Visual Studio:The following characters are interpreted as line breaks in Visual Studio:

  • CR LF: retorno de carro + alimentação de linha, caracteres Unicode 000D + 000ACR LF: Carriage return + line feed, Unicode characters 000D + 000A

  • LF: alimentação de linha, caractere Unicode 000ALF: Line feed, Unicode character 000A

  • NEL: próxima linha, caractere Unicode 0085NEL: Next line, Unicode character 0085

  • LS: separador de linha, caractere Unicode 2028LS: Line separator, Unicode character 2028

  • PS: separador de parágrafo, caractere Unicode 2029PS: Paragraph separator, Unicode character 2029

O texto copiado de outros aplicativos mantém a codificação original e os caracteres de quebra de linha.Text that is copied from other applications keeps the original encoding and line break characters. Por exemplo, quando você copia texto do Bloco de notas e o cola em um arquivo de texto no Visual Studio, o texto tem as mesmas configurações que ele tinha no Bloco de notas.For example, when you copy text from Notepad and paste it into a text file in Visual Studio, the text has the same settings that it had in Notepad.

Ao abrir um arquivo que tem caracteres de quebra de linha diferentes, talvez você veja uma caixa de diálogo que pergunta se os caracteres de quebra de linha inconsistentes devem ser normalizados e quais os tipo de quebras de linha você deseja escolher.When you open a file that has different line break characters, you may see a dialog box that asks whether the inconsistent line break characters should be normalized, and which type of line breaks to choose.

Opções avançadas de salvamentoAdvanced save options

Você pode usar a File > caixa de diálogo Opções de salvamento avançadas do arquivo para determinar o tipo de caracteres de quebra de linha desejado.You can use the File > Advanced Save Options dialog box to determine the type of line break characters you want. Também é possível alterar a codificação de um arquivo com as mesmas configurações.You can also change the encoding of a file with the same settings.

caixa de diálogo Opções avançadas de salvar

Observação

Se você não vir Opções Avançadas de Salvamento no menu Arquivo, você poderá adicioná-la.If you don't see Advanced Save Options on the File menu, you can add it.

  1. Escolha ferramentas, Personalizar,Choose Tools, Customize,
  2. Escolha a guia comandos , selecione o botão de opção barra de menus e, na lista suspensa correspondente, escolha arquivo.Choose the Commands tab, select the Menu bar radio button and from the corresponding drop-down list choose File. Escolha o botão Adicionar comando .Choose the Add Command button.
  3. Na caixa de diálogo Adicionar Comando, em Categorias, escolha Arquivo e, em seguida, na lista Comandos, escolha Opções Avançadas de Salvamento.In the Add Command dialog box, under Categories, choose File, and then in the Commands list, choose Advanced Save Options. Escolha o botão OK .Choose OK button.
  4. Use os botões mover para cima e mover para baixo para mover o comando para qualquer lugar no menu.Use the Move Up and Move Down buttons to move the command to any place in the menu. Escolha Fechar para fechar a caixa de diálogo Personalizar.Choose Close to close the Customize dialog box. Para obter mais informações, consulte Personalizar menus e barras de ferramentas.For more information, see Customize menus and toolbars.

Como alternativa, você pode acessar a caixa de diálogo Opções de salvamento avançadas escolhendo arquivo > Salvar <file> como.Alternatively, you can access the Advanced Save Options dialog box by choosing File > Save <file> As. Na caixa de diálogo salvar arquivo como , escolha o triângulo suspenso ao lado do botão salvar e, em seguida, escolha salvar com codificação.In the Save File As dialog box, choose the drop-down triangle next to the Save button and then choose Save with encoding.

Confira tambémSee also