Recursos do editor de códigoFeatures of the code editor

O editor do Visual Studio fornece muitos recursos que facilitam escrever e gerenciar seu código e texto.The Visual Studio editor provides many features that make it easier for you to write and manage your code and text. Você pode expandir e recolher blocos de código diferentes usando a estrutura de tópicos.You can expand and collapse different blocks of code by using outlining. Você pode aprender mais sobre o código através do IntelliSense, do Pesquisador de Objetos e da Hierarquia de Chamada.You can learn more about the code by using IntelliSense, the Object Browser, and the Call Hierarchy. Você pode localizar o código usando recursos como Navegar Para, Ir para Definição e Localizar Todas as Referências.You can find code by using features such as Go To, Go To Definition, and Find All References. Você pode inserir blocos de código com snippets de código e pode gerar código usando recursos como o Gerar do uso.You can insert blocks of code with code snippets, and you can generate code by using features such as Generate From Usage. Se você nunca usou o editor do Visual Studio, consulte Editar o código para obter uma visão geral rápida.If you have never used the Visual Studio editor before, see Edit your code for a quick overview.

Note

Este tópico aplica-se ao Visual Studio no Windows.This topic applies to Visual Studio on Windows. Para o Visual Studio para Mac, confira Editor de código-fonte (Visual Studio para Mac).For Visual Studio for Mac, see Source editor (Visual Studio for Mac).

Você pode exibir seu código de várias maneiras diferentes.You can view your code in a number of different ways. Por padrão, o Gerenciador de Soluções mostra seu código organizado por arquivos.By default, Solution Explorer shows your code organized by files. Você pode clicar na guia Modo de Exibição de Classe na parte inferior da janela para exibir o código organizado por classes.You can click on the Class View tab at the bottom of the window to view your code organized by classes.

Você pode pesquisar e substituir texto em um ou vários arquivos.You can search and replace text in single or multiple files. Para obter mais informações, consulte Localizar e substituir texto.For more information, see Find and replace text. É possível usar expressões regulares para localizar e substituir texto.You can use regular expressions to find and replace text. Para obter mais informações, confira Usar expressões regulares no Visual Studio.For more information, see Use regular expressions in Visual Studio.

As diferentes linguagens do Visual Studio oferecem conjuntos de recursos diferentes e, em alguns casos, os recursos se comportam de forma diferente nas diferentes linguagens.The different Visual Studio languages offer different sets of features, and in some cases the features behave differently in different languages. Muitas dessas diferenças são especificadas nas descrições dos recursos, mas para obter mais informações, consulte as seções sobre as linguagens específicas do Visual Studio.Many of these differences are specified in the descriptions of the features, but for more information you can see the sections on specific Visual Studio languages.

Recursos do editorEditor features

Coloração de sintaxeSyntax Coloring Alguns elementos de sintaxe dos arquivos de código e de marcação são coloridos de maneiras diferentes para diferenciá-los.Some syntax elements of code and markup files are colored differently to distinguish them. Por exemplo, palavras-chave (como using no C# e Imports no Visual Basic) são de uma cor, mas tipos (como Console e Uri) são de outra cor.For example, keywords (such as using in C# and Imports in Visual Basic) are one color, but types (such as Console and Uri) are another color. Outros elementos de sintaxe também são coloridos, como comentários e literais de cadeia de caracteres.Other syntax elements are also colorized, such as string literals and comments. O C++ usa cores para fazer diferenciação entre tipos, enumerações e macros, entre outros tokens.C++ uses color to differentiate among types, enumerations, and macros, among other tokens.

Você pode ver a cor padrão de cada tipo e pode alterar a cor de qualquer elemento de sintaxe específico na caixa de diálogo Fontes e Cores, Ambiente, Opções, que pode ser aberta no menu Ferramentas.You can see the default color for each type, and you can change the color for any specific syntax element in the Fonts and Colors, Environment, Options dialog box, which you can open from the Tools menu.
Marcas de Erro e AvisoError and Warning Marks Enquanto adiciona código e compila sua solução, você pode ver: (a)sublinhados ondulados de cores diferentes (conhecidos como rabiscos) ou (b) lâmpadas que aparecem em seu código.As you add code and build your solution, you may see (a) different-colored wavy underlines (known as squiggles) or (b) light bulbs appearing in your code. Rabiscos vermelhos indicam erros de sintaxe, azul indica erros de compilador, verde indica avisos e roxo indica outros tipos de erros.Red squiggles denote syntax errors, blue denotes compiler errors, green denotes warnings, and purple denotes other types of errors. As Ações Rápidas sugerem correções para problemas e facilitam a aplicação da correção.Quick Actions suggest fixes for problems and make it easy to apply the fix.

Você pode ver a cor padrão de cada rabisco de erro e de aviso na caixa de diálogo Ferramentas > Opções > Ambiente > Fontes e Cores.You can see the default color for each error and warning squiggle in the Tools > Options > Environment > Fonts and Colors dialog box. Procure por Erro de Sintaxe, Erro do Compilador, Aviso e Outro Erro.Look for Syntax Error, Compiler Error, Warning, and Other Error.
Correspondência de chaveBrace Matching Quando o ponto de inserção é colocado em uma chave de abertura em um arquivo de código, essa chave de abertura e a chave de fechamento são realçadas.When the insertion point is placed on an open brace in a code file, both it and the closing brace are highlighted. Esse recurso fornece comentários imediatos sobre chaves no local incorreto ou ausentes.This feature gives you immediate feedback on misplaced or missing braces. Você pode ativar ou desativar a correspondência de chaves com a configuração Realce Automático de Delimitadores (Ferramentas > Opções > Editor de Texto).You can turn brace matching on or off with the Automatic Delimiter Highlighting setting (Tools > Options > Text Editor). Você pode alterar a cor do realce na configuração Fontes e Cores (Ferramentas > Opções > Ambiente).You can change the highlight color in the Fonts and Colors setting (Tools > Options > Environment). Procure Correspondência de Chaves (Realce) ou Correspondência de Chaves (Retângulo) .Look for Brace Matching (Highlight) or Brace Matching (Rectangle).
Visualizador de EstruturaStructure Visualizer Linhas pontilhadas conectam chaves correspondentes nos arquivos de código, o que facilita ver a abertura e o fechamento de pares de chave.Dotted lines connect matching braces in code files, making it easier to see opening and closing brace pairs. Isso pode ajudar a localizar o código em sua base de código mais rapidamente.This can help you find code in your codebase more quickly. Você pode ativar ou desativar essas linhas em Mostrar diretrizes de estrutura na seção Exibição da página Ferramentas > Opções > Editor de Texto > Geral.You can turn these lines on or off with the Show structure guidelines in the Display section of the Tools > Options > Text Editor > General page.
Números de LinhaLine Numbers Os números de linha podem ser exibidos na margem esquerda da janela de código.Line numbers can be displayed in the left margin of the code window. Eles não são exibidos por padrão.They are not displayed by default. Você poderá ativar essa opção nas configurações Todas as Linguagens do Editor de Texto (Ferramentas > Opções > Editor de Texto > Todas as Linguagens).You can turn this option on in the Text Editor All Languages settings (Tools > Options > Text Editor > All Languages). Você pode exibir números de linha para linguagens de programação individuais, alterando as configurações para essas linguagens (Ferramentas > Opções > Editor de Texto > <linguagem> ).You can display line numbers for individual programming languages by changing the settings for those languages (Tools > Options > Text Editor > <language>). Para imprimir os números de linha é necessário selecionar Incluir números de linha na caixa de diálogo Imprimir.For line numbers to print, you must select Include line numbers in the Print dialog box.
Controle de AlteraçõesChange Tracking A cor da margem esquerda permite que você mantenha o controle das alterações feitas em um arquivo.The color of the left margin allows you to keep track of the changes you have made in a file. As alterações que foram feitas desde que o arquivo foi aberto mas não foram salvas são indicadas por uma barra amarela na margem esquerda (conhecida como a margem de seleção).Changes you have made since the file was opened but not saved are denoted by a yellow bar on the left margin (known as the selection margin). Depois de salvar as alterações (mas antes de fechar o arquivo), a barra ficará verde.After you have saved the changes (but before closing the file), the bar turns green. Se você desfizer uma alteração depois de salvar o arquivo, a barra ficará laranja.If you undo a change after you have saved the file, the bar turns orange. Para desativar e ativar esse recurso, altere a opção Controlar Alterações nas configurações Editor de Texto (Ferramentas > Opções > Editor de Texto).To turn this feature off and on, change the Track changes option in the Text Editor settings (Tools > Options > Text Editor).
Seleção de código e textoSelecting Code and Text É possível selecionar texto no modo padrão de fluxo contínuo ou no modo de caixa, no qual você seleciona uma parte retangular do texto em vez de um conjunto de linhas.You can select text either in the standard continuous stream mode or in box mode, in which you select a rectangular portion of text instead of a set of lines. Para fazer uma seleção no modo de caixa, pressione a tecla Alt enquanto arrasta o mouse sobre a seleção (ou pressione Alt+Shift+ <tecla de direção> ).To make a selection in box mode, press Alt as you drag the mouse over the selection (or press Alt+Shift+<arrow key>). A seleção inclui todos os caracteres dentro do retângulo definido pelo primeiro caractere e o último caractere na seleção.The selection includes all of the characters within the rectangle defined by the first character and the last character in the selection. Tudo que é digitado ou colado na área selecionada é inserido no mesmo ponto em cada linha.Anything typed or pasted into the selected area is inserted at the same point on each line.
Aplicar ZoomZoom Você pode ampliar ou reduzir em qualquer janela de código pressionando a tecla Ctrl e, mantendo-a pressionada, mover a roda de rolagem do mouse (ou Ctrl+Shift+ ).You can zoom in or out in any code window by pressing and holding the Ctrl key and moving the scroll wheel on the mouse (or Ctrl+Shift+. para aumentar e Ctrl+Shift+ , para diminuir).to increase and Ctrl+Shift+, to decrease). Você também pode usar a caixa Zoom no canto inferior esquerdo da janela de código para definir um percentual específico de zoom.You can also use the Zoom box in the lower left corner of the code window to set a specific zoom percentage. O recurso de aplicar zoom não funciona em janelas de ferramentas.The zoom feature does not work in tool windows.
Espaço virtualVirtual Space Por padrão, as linhas nos editores do Visual Studio terminam após o último caractere, de forma que a tecla Seta para a Direita, ao final de uma linha, move o cursor para o início da próxima linha.By default, lines in Visual Studio editors end after the last character, so that the Right Arrow key at the end of a line moves the cursor to the beginning of the next line. Em alguns editores uma linha não termina depois do último caractere e é possível colocar o cursor em qualquer lugar na linha.In some other editors a line does not end after the last character, and you can place your cursor anywhere on the line. Você pode habilitar o espaço virtual no editor nas configurações Ferramentas > Opções > Editor de Texto > Todas as Linguagens.You can enable virtual space in the editor in the Tools > Options > Text Editor > All Languages settings. Observe que você pode habilitar Espaço virtual ou Quebra automática de linha, mas não ambos.Note that you can enable either Virtual Space or Word Wrap, but not both.
ImprimindoPrinting Você pode usar as opções da caixa de diálogo Imprimir para incluir números de linha ou ocultar regiões de código recolhidas ao imprimir um arquivo.You can use the options in the Print dialog box to include line numbers or hide collapsed regions of code when you print a file. Na caixa de diálogo Configuração de Página também é possível imprimir o caminho completo e o nome do arquivo, escolhendo Cabeçalho de Página.In the Page Setup dialog box, you can also choose to print the full path and the name of the file by choosing Page header.

Você pode definir opções de impressão a cores na caixa de diálogo Ferramentas > Opções > Ambiente > Fontes e Cores.You can set color printing options in the Tools > Options > Environment > Fonts and Colors dialog box. Escolha Impressora na lista Mostrar configurações de para personalizar a impressão a cores.Choose Printer in the Show settings for list to customize color printing. Você pode especificar cores para imprimir um arquivo diferentes das cores para edição de um arquivo.You can specify different colors for printing a file than for editing a file.
Desfazer global e RefazerGlobal Undo and Redo O comandos Desfazer Última Ação Global e Refazer Última Ação Global no menu Editar desfazem ou refazem ações globais que afetam vários arquivos.The Undo Last Global Action and Redo Last Global Action commands on the Edit menu undo or redo global actions that affect multiple files. As ações globais incluem renomeação de uma classe ou namespace, executar uma operação de localização e substituição em uma solução, refatoração de um banco de dados ou qualquer outra ação que altera vários arquivos.Global actions include renaming a class or namespace, performing a find-and-replace operation across a solution, refactoring a database, or any other action that changes multiple files. Você pode aplicar os comandos desfazer e refazer global para ações na sessão atual do Visual Studio, mesmo depois de fechar a solução na qual a ação foi aplicada.You can apply the global undo and redo commands to actions in the current Visual Studio session, even after you close the solution in which an action was applied.

Recursos de edição avançadaAdvanced editing features

Você pode encontrar uma série de recursos avançados no menu Editar > Avançado na barra de ferramentas.You can find a number of advanced features on the Edit > Advanced menu on the toolbar. Nem todos esses recursos estão disponíveis para todos os tipos de arquivos de código.Not all of these features are available for all types of code files.

Formatar DocumentoFormat Document Define o recuo adequado das linhas de código e move as chaves para separar linhas no documento.Sets the proper indentation of lines of code and moves curly braces to separate lines in the document.
Formatar SeleçãoFormat Selection Define o recuo adequado das linhas de código e move as chaves para separar linhas na seleção.Sets the proper indentation of lines of code and moves curly braces to separate lines in the selection.
Tabular linhas selecionadasTabify Selected Lines Troca espaços à esquerda por tabulações quando for apropriado.Changes leading spaces to tabs where appropriate.
Cancelar tabulação das linhas selecionadasUntabify Selected Lines Troca tabulações à esquerda por espaços.Changes leading tabs to spaces. Se você desejar converter todos os espaços em seu arquivo para tabulações (ou todas as tabulações para espaços), você poderá usar os comandos Edit.ConvertSpacesToTabs e Edit.ConvertTabsToSpaces.If you want to convert all the spaces in your file to tabs (or all the tabs to spaces), you can use the Edit.ConvertSpacesToTabs and Edit.ConvertTabsToSpaces commands. Esses comandos não são exibidos nos menus do Visual Studio, mas você pode chamá-los por meio da janela Acesso Rápido ou da janela Comando.These commands do not appear in Visual Studio menus, but you can call them from the Quick Access window or the command window.
Colocar em MaiúsculasMake Uppercase Alterar todos os caracteres na seleção para maiúsculos ou se não houver nenhuma seleção, altera o caractere no ponto de inserção para maiúsculo.Changes all characters in the selection to uppercase, or if there is no selection, changes the character at the insertion point to uppercase. Atalho: Ctrl+Shift+U.Shortcut: Ctrl+Shift+U.
Colocar em MinúsculasMake Lowercase Alterar todos os caracteres na seleção para minúsculos ou se não houver nenhuma seleção, altera o caractere no ponto de inserção para minúsculo.Changes all characters in the selection to lowercase, or if there is no selection, changes the character at the insertion point to lowercase. Atalho: Ctrl+U.Shortcut: Ctrl+U.
Mover linhas selecionadas para cimaMove selected Lines Up Move a linha selecionada uma linha para cima.Moves the selected line up one line. Atalho: Alt+Seta para Cima.Shortcut: Alt+Up Arrow.
Mover Linhas Selecionadas para BaixoMove Selected Lines Down Move a linha selecionada uma linha para baixo.Moves the selected line down one line. Atalho: Alt+Seta para Baixo.Shortcut: Alt+Down Arrow.
Excluir Espaço em Branco HorizontalDelete Horizontal White Space Exclui tabulações ou espaços ao final da linha atual.Deletes tabs or spaces at the end of the current line. Atalho: Ctrl+K, Ctrl+ \Shortcut: Ctrl+K, Ctrl+\
Exibir Espaço em BrancoView White Space Exibe espaços como pontos elevados e tabulações como setas.Displays spaces as raised dots, and tabs as arrows. O final de um arquivo é exibido como um glifo retangular.The end of a file is displayed as a rectangular glyph. Se Ferramentas > Opções > Editor de Texto > Todas as Linguagens > Quebra automática de linha > Mostrar glifos visíveis para quebra automática de linha estiver selecionado, esse glifo também será exibido.If Tools > Options > Text Editor > All Languages > Word Wrap > Show visible glyphs for word wrap is selected, that glyph is also displayed.
Quebra automática de linhaWord Wrap Faz com que todas as linhas em um documento sejam visíveis na janela de código.Causes all the lines in a document to be visible in the code window. Você pode ativar e desativar a quebra automática de linha nas configurações Todas as Linguagens do Editor de Texto (Ferramentas > Opções > Editor de Texto > Todas as Linguagens).You can turn word wrap off and on in the Text Editor All Languages settings (Tools > Options > Text Editor > All Languages).
Comentar SeleçãoComment Selection Adiciona caracteres de comentários na seleção ou na linha atual.Adds comment characters to the selection or the current line. Atalho: Ctrl+K, Ctrl+CShortcut: Ctrl+K, Ctrl+C
Remover Comentários da SeleçãoUncomment Selection Remove caracteres de comentários da seleção ou da linha atual.Removes comment characters from the selection or the current line. Atalho: Ctrl+K, Ctrl+UShortcut: Ctrl+K, Ctrl+U
Aumentar recuo de linhaIncrease Line Indent Adiciona uma tabulação (ou os espaços equivalentes) nas linhas selecionadas ou na linha atual.Adds a tab (or the equivalent spaces) to the selected lines or the current line.
Diminuir recuo de linhaDecrease Line Indent Remove uma tabulação (ou os espaços equivalentes) das linhas selecionadas ou da linha atual.Removes a tab (or the equivalent spaces) from the selected lines or the current line.
Selecionar MarcaSelect Tag Em um documento que contém marcas (por exemplo, XML ou HTML), seleciona a marca.In a document that contains tags (for example, XML or HTML), selects the tag.
Selecionar Conteúdo da MarcaSelect Tag Content Em um documento que contém marcas (por exemplo, XML ou HTML), seleciona o conteúdo.In a document that contains tags (for example, XML or HTML), selects the content.

Você pode se mover pelo editor de códigos de várias maneiras diferentes, incluindo navegar para trás e para frente até pontos de inserção anteriores, exibir a definição de um tipo ou membro e saltar até um método específico, usando a barra de navegação.You can move around in the code editor in several different ways, including navigating backwards and forwards to previous insertion points, viewing the definition of a type or member, and jumping to a specific method using the navigation bar. Para obter mais informações, consulte Navegar pelo código.For more information see Navigate code.

Localizar referências na base de códigoFind references in your code base

Para encontrar o local em que elementos de código específicos são referenciados na base de código, use o comando Localizar Todas as Referências ou pressione Shift+F12.To find where particular code elements are referenced throughout your codebase, you can use the Find All References command or press Shift+F12. Além disso, quando você clica em um tipo ou membro, o recurso realce de referência destaca automaticamente todas as referências a esse tipo ou membro.Also, when you click on a type or member, the reference highlighting feature automatically highlights all references to that type or member. Para obter mais informações, confira Localizar referências no código.For more information, see Find references in your code.

Personalizar o editorCustomize the editor

É possível compartilhar configurações do Visual Studio com outro desenvolvedor, fazer com que suas configurações estejam em conformidade com um padrão ou retornar às configurações padrão do Visual Studio usando o comando Assistente de Importação e Exportação de Configurações no menu Ferramentas.You can share your Visual Studio settings with another developer, have your settings conform to a standard, or return to Visual Studio default settings by using the Import and Export Settings Wizard command on the Tools menu. No Assistente de Importação e Exportação de Configurações, é possível alterar configurações gerais selecionadas ou idioma e configurações específicas do projeto.In the Import and Export Settings Wizard, you can change selected general settings or language and project-specific settings.

Para definir novas teclas de atalho ou redefinir as teclas de atalho existentes, vá até Ferramentas > Opções > Ambiente > Teclado.To define new hotkeys or redefine existing hotkeys, go to Tools > Options > Environment > Keyboard. Para saber mais sobre teclas de atalho, veja Atalhos de teclado padrão.For more information about hotkeys, see Default keyboard shortcuts.

Para conferir opções do editor específicas ao JavaScript, confira Opções do editor de JavaScript.For JavaScript-specific editor options, see JavaScript editor options.

Consulte tambémSee also