Personalizando o IDECustomizing the IDE

O Visual Studio para Mac pode ser personalizado de várias maneiras, permitindo que os usuários desenvolvam aplicativos em um ambiente que atenda suas necessidades estéticas e de eficiência.Visual Studio for Mac can be customized in a variety of ways, allowing users to develop apps in an environment that meets their needs for both efficiency and aesthetics. Este artigo explora as várias formas em que o Visual Studio para Mac pode ser adaptado para atender às suas necessidades.This article explores the variety of ways that Visual Studio for Mac can be adapted to suit your needs.

Tema escuroDark theme

Exibição de tema escuro

Você pode mudar os temas no Visual Studio para Mac navegando até Visual Studio > Preferências > Ambiente > Estilo Visual e selecionando o tema desejado na lista suspensa Tema da Interface do Usuário, conforme ilustrado na imagem a seguir:You can switch themes in Visual Studio for Mac by browsing to Visual Studio > Preferences > Environment > Visual Style and selecting your desired theme from the User Interface Theme drop-down, as illustrated in the following image:

Seleção de tema escuro

LocalizaçãoLocalization

O Visual Studio para Mac está traduzido nos 14 idiomas a seguir, permitindo que ele fique acessível para mais desenvolvedores:Visual Studio for Mac is localized in the following 14 languages, enabling it to be accessible to more developers:

  • Chinês – ChinaChinese - China
  • Chinês – TaiwanChinese - Taiwan
  • TchecoCzech
  • FrancêsFrench
  • AlemãoGerman
  • InglêsEnglish
  • ItalianoItalian
  • JaponêsJapanese
  • CoreanoKorean
  • PolonêsPolish
  • Português - BrasilPortuguese - Brazil
  • RussoRussian
  • EspanholSpanish
  • TurcoTurkish

Para alterar o idioma exibido pelo Visual Studio para Mac, navegue até Visual Studio > Preferências > Ambiente > Estilo Visual e selecione o idioma desejado na lista suspensa Idioma da Interface do Usuário, conforme ilustrado na imagem a seguir:To change the language displayed by Visual Studio for Mac, browse to Visual Studio > Preferences > Environment > Visual Style and select your desired language from the User Interface Language drop-down, as illustrated in the following image:

Seleção de Idioma

Informações do autorAuthor information

O painel de informações do autor permite que você adicione informações relevantes sobre si mesmo como nome, endereço de email, o proprietário dos direitos autorais do seu trabalho, sua empresa e marca registrada:The author information panel allows you to add relevant information about yourself such as your name, email address, the copyright owner for your work, your company, and trademark:

Seção Editar Informações do Autor

Essas informações são usadas para popular os cabeçalhos de arquivo padrão, como uma licença, que podem ser adicionadas a novos arquivos:This information is used to populate standard file headers, such as a license, that you might add to new files:

Opções de cabeçalho padrão

Os campos Nome e Email populados serão usados em qualquer confirmação feita por meio do Controle de Versão no Visual Studio para Mac.Populated Name and Email fields will be used in any commit that is made through Version Control in Visual Studio for Mac. Se você não popular esses campos, o Visual Studio para Mac solicitará que você faça isso quando você tentar usar o Controle de Versão.If you have not populated these fields, Visual Studio for Mac will prompt you to do so when you try to use Version Control.

Associações de teclasKey bindings

Associações de teclas permitem adaptar seu ambiente de desenvolvimento para que você possa mover-se com mais eficiência por todo o Visual Studio para Mac.Key bindings allow you to adapt your development environment so that you can move more efficiently throughout Visual Studio for Mac. Ele fornece associações de teclas familiares para muitos IDEs populares, como o Visual Studio (no Windows), o ReSharper, o Visual Studio Code e o Xcode.It provides familiar key bindings for many popular IDEs, such as Visual Studio (on Windows), ReSharper, Visual Studio Code, and Xcode.

As associações de teclas podem ser definidas navegando para Visual Studio > Preferências > Ambiente > Associações de Teclas, conforme ilustrado na imagem a seguir:Key bindings can be set by browsing to Visual Studio > Preferences > Environment > Key Bindings, as illustrated by the following image:

Definir associações de teclas

Aqui você pode pesquisar combinações de associações de teclas, exibir associações conflitantes, adicionar novas associações e editar as associações existentes.From here you can search for key binding combinations, view conflicting bindings, add new bindings, and edit the existing bindings.

Layout do workspaceWorkspace layout

O workspace do Visual Studio para Mac consiste em uma área de documento principal (normalmente o editor, superfície do designer ou o arquivo de opções), cercada por painéis complementares que contêm informações úteis para acessar e gerenciar arquivos de aplicativo, teste e depuração.Visual Studio for Mac's workspace consists of a main document area (normally the editor, designer surface, or options file), surrounded by complimentary pads that contain useful information for accessing and managing application files, testing, and debugging.

Layout do workspace

Exibindo e organizando os painéisViewing and arranging pads

Quando você abrir qualquer nova solução ou arquivo no Visual Studio para Mac, observe alguns painéis no workspace, incluindo o Painel de Soluções, Estrutura de tópicos do documento e Erros:When you open any new solution or file in Visual Studio for Mac, you should notice some pads in the workspace, including the Solution Pad, Document Outline, and Errors:

Painéis de Solução

O Visual Studio para Mac fornece painéis que contém informações adicionais, ferramentas e auxílios de navegação que podem ser acessados navegando para o item de menu Exibir > Painéis e selecionando um painel para adicioná-lo:Visual Studio for Mac provides pads containing additional information, tools, and navigation aids, all of which can be accessed by browsing to the View > Pads menu item and selecting a pad to add it:

Selecionar novo painel

Os painéis também podem ser abertos automaticamente por vários comandos, como o comando Localizar nos arquivos (Shift + Cmd + F), que abre um painel desanexado dos resultados da pesquisa.Pads may also be opened automatically by various commands, such as the Find in Files (Shift + Cmd + F) command, which opens a detached pad of search results.

Painéis podem ser movidos e organizados por todo o fluxo de trabalho da forma que for mais útil para você.Pads can be moved and arranged throughout your workflow in whatever way is most useful to you. Por exemplo, eles podem ser encaixados em qualquer lado do editor de documentos, adjacente a outro painel, acima ou abaixo de outro painel ou como um conjunto de painéis com guias que permite alternar rapidamente entre elas.For example, they can be docked on any side of the document editor, adjacent to another pad, above or below another pad, or as a set of tabbed pads enabling you to quickly switch between them.

Para os painéis usados com frequência, você também pode desanexar completamente um painel da janela do Visual Studio para Mac e criar uma janela separada para esse painel.For frequently used pads, you can also completely detach a pad from the Visual Studio for Mac window, and create a separate window for that pad.

Os painéis podem ser ocultos e fechados usando os botões no canto superior direito de cada painel:Pads can be hidden and closed by the toggles in the top-right corner of each pad:

Ocultando e fechando painéis

Os painéis ocultos automaticamente ficam encaixados nas laterais do workspace e podem ser acessados facilmente quando necessário.Autohidden pads are docked to the sides of the workspace making them easily accessible when they are required. Focalizar o painel o exibirá novamente e ele será ocultado quando o foco do teclado e do mouse sair dele.Hovering over the pad displays it again, and it will be hidden when the mouse and keyboard focus leaves it.

Organizando layoutsOrganizing layouts

Os painéis que são exibidos a qualquer momento dependem do contexto atual.The pads that are displayed at any time are dependent on the current context. Por exemplo, ao usar o designer visual, os painéis da caixa de ferramentas e da grade de propriedade são mais importantes; durante a depuração, é útil ter painéis do depurador para exibir a pilha e os locais.For example, when using the visual designer, the toolbox and property grid pads are most important; when debugging, it is useful to have the debugger pads for viewing the stack and locals.

O estado dos painéis abertos é representado por um layout.The state of the open pads is represented by a layout. Os layouts podem ser alternados manualmente por meio do menu Exibir, conforme ilustrado na imagem a seguir ou são alternados automaticamente quando você executar uma ação, como depuração ou ao abrir um Storyboard:The layouts can be switched manually through the View menu, as illustrated in the following image, or it is switched automatically when you carry out an action, such as debugging, or opening a Storyboard:

Selecionar novos Layouts

Sempre há um layout de ativo e qualquer alteração feita em um layout, como adicionar ou reposicionar um painel, alterará apenas o layout ativo.There is always one active layout and any change you make in a layout, such as adding or repositioning a pad, will only change the active layout. Quando você fechar o Visual Studio para Mac, as alterações feitas não serão salvas.Once you close Visual Studio for Mac, the changes you have made will not be saved.

No entanto, é possível criar um layout usando o item de menu Exibir > Salvar Layout Atual.However, it is possible to create a new layout by using the View > Save Current Layout menu item. Isso adicionará o layout atual ao menu para que você pode selecioná-lo a qualquer momento:This will add your current layout to the menu so that you can select it at any time:

Salva o layout atual

Suporte à edição lado a ladoSide-by-side editing support

O Visual Studio para Mac permite abrir os editores de texto lado a lado ou usar um editor como uma janela flutuante desanexada.Visual Studio for Mac allows you to open text editors side by side, or to have an editor as a detached floating window.

O modo de duas colunas pode ser habilitado por meio do item de menu Exibir selecionando Exibir > Colunas do Editor > Duas colunas ou arrastando uma guia do editor para uma das bordas da área do editor:2-column mode can be enabled through the View menu item by selecting View > Editor Columns > 2 columns, or by dragging an editor tab to one of the edges of the editor area:

Modo de duas colunas lado a lado

As guias do Editor podem ser arrastadas para fora da área de documento para criar uma janela flutuante do editor.Editor tabs can be dragged out of the document area to create a floating editor window. Essa janela flutuante também dá suporte a editores lado a lado e pode conter várias guias do editor:This floating window also supports side-by-side editors, and can contain several editor tabs:

Criar nova janela

Duas colunas lado a lado com guias adicionais

Para reverter para um único editor aberto, selecione Exibir > Colunas do Editor > Uma coluna.To revert to a single open editor, select View > Editor Columns > 1 column.

Consulte tambémSee also