Чтение и понимание кода C++ в Visual StudioRead and understand C++ code in Visual Studio

Редактор кода C++ и Visual Studio IDE предоставляют различные вспомогательные средства кодирования.The C++ code editor and Visual Studio IDE provide many coding aids. Одни уникальны для C++, а другие фактически одинаковы для всех языков Visual Studio.Some are unique to C++, and some are essentially the same for all Visual Studio languages. Дополнительные сведения об общих функциях см. в разделе Написание кода в редакторе кода и текста.For more information about the shared features, see Writing Code in the Code and Text Editor.

Выделение цветомColorization

Visual Studio выделяет цветом элементы синтаксиса, чтобы вы могли различать типы символов, такие как ключевые слова языка, имена типов, имена переменных, параметры функций, строковые литералы и т. д.Visual Studio colorizes syntax elements to differentiate between types of symbols such as language keywords, type names, variable names, function parameters, string literals, and so on.

Выделение кода цветомCode colorization

Неиспользуемый код (например код в разделе #if 0) имеет более приглушенный цвет.Unused code (such as code under an #if 0) is more faded in color.

Неактивный кодInactive code

Вы можете настраивать цвета. Для этого введите "шрифты" в поле быстрого запуска и выберите Шрифты и цвета.You can customize the colors by typing "Fonts" in Quick Launch, and then choosing Fonts and Colors. В диалоговом окне Шрифты и цвета прокрутите вниз до параметров C/C++, а затем выберите пользовательский шрифт и цвет.In the Fonts and Colors dialog scroll down to the C/C++ options and then choose a custom font and/or color.

СтруктуризацияOutlining

Щелкните правой кнопкой мыши в любом месте файла исходного кода и выберите Структура, чтобы свернуть или развернуть блоки кода и (или) настраиваемые области. Так вы упростите просмотр, отображая только нужный вам код.Right-click anywhere in a source code file and choose Outlining to collapse or expand code blocks and/or custom regions to make it easier to browse only the code you are interested in. Дополнительные сведения см. в разделе Структура.For more information, see Outlining.

С++: пункт "Структурирование"C++ Outlining

Если вы поместите курсор перед фигурной скобкой ({ или }), редактор выделит ее парную часть.When you place your cursor in front of a curly brace, '{' or '}', the editor highlights its matching counterpart.

Другие параметры структурирования можно настроить, выбрав Изменить > Структура в главном меню.Other outlining options are located under Edit > Outlining in the main menu.

Номера строкLine numbers

Вы можете добавлять номера строк в проект. Для этого выберите Средства > Параметры > Текстовый редактор > Все языки > Общие или введите "номер строки" в поле быстрого запуска (CTRL+Q) .You can add line numbers to your project by going to Tools > Options > Text Editor > All Languages > General or by searching for "line num" with Quick Launch (Ctrl + Q). Номера строк можно задать для всех языков или определенных языков, включая C++.Line numbers can be set for all languages or for specific languages only, including C++.

Прокрутка и изменение масштабаScroll and zoom

Вы можете увеличивать или уменьшать масштаб в редакторе. Для этого прокрутите колесико мыши, удерживая клавишу CTRL.You can zoom in or out in the editor by pressing the Ctrl key and scrolling with your mouse wheel. Кроме того, изменить масштаб можно с помощью параметров масштабирования в левом нижнем углу.You can also zoom by using the zoom setting in the bottom left corner.

С++: элемент управления масштабомC++ Zoom Control

Режим карты для полосы прокрутки позволяет быстро прокручивать и просматривать файл кода, не покидая текущего расположения.Scrollbar Map Mode enables you to quickly scroll and browse through a code file without leaving your current location. Чтобы перейти непосредственно в это расположение, можно также щелкнуть в любом месте на карте кода.You can click anywhere on the code map to go directly to that location.

С++: карта кодаCode Map in C++

Чтобы включить режим карты, введите "карта" в поле быстрого запуска на главной панели инструментов и выберите Использовать режим карты прокрутки.To turn on Map Mode, type "map" in the Quick Launch search box in the main toolbar and choose Use scroll map mode. Дополнительные сведения см. в разделе Практическое руководство. Отслеживание кода за счет настройки полосы прокрутки.For more information, see How to: Track your code by customizing the scrollbar.

При включенном режиме карты полоса прокрутки выделяет изменения, внесенные в файл.When Map Mode is off, the scroll bar still highlights the changes you have made in the file. Зеленый цвет означает, что изменения сохранены, а желтый — не сохранены.Green indicates saved changes and yellow indicates unsaved changes.

Краткие сведения и сведения о параметрахQuick Info and Parameter Info

Наведите указатель на любую переменную, функцию или другой символ, чтобы просмотреть сведения, включая объявление и комментарии.Hover over any variable, function, or other symbol to get information about it, including the declaration, and any comments that are located just preceding it.

Снимок экрана: подсказка в Visual Studio 2019Screenshot showing the Quick Info tooltip in Visual Studio 2019.

Подсказки с краткими сведениями включают ссылку для поиска в Интернете.The Quick Info tooltip has a Search Online link. Выберите Средства > Параметры > Текстовый редактор > C++ > Представление, чтобы указать поставщик поиска.Go to Tools > Options > Text Editor > C++ > View to specify the search provider.

Если в коде есть ошибка, можно навести указатель мыши на нее, чтобы в окне с краткими сведениями просмотреть сообщение об ошибке.If there is an error in your code, you can hover over it and Quick Info will display the error message. Сообщение об ошибке также можно просмотреть в окне со списком ошибок.You can also find the error message in the Error List window.

Краткие сведения об ошибкеQuick Info on error

Снимок экрана: подсказка в Visual Studio 2017Screenshot showing the Quick Info tooltip in Visual Studio 2017.

Если в коде есть ошибка, можно навести указатель мыши на нее, чтобы в окне с краткими сведениями просмотреть сообщение об ошибке.If there is an error in your code, you can hover over it and Quick Info will display the error message. Сообщение об ошибке также можно просмотреть в окне со списком ошибок.You can also find the error message in the Error List window.

Краткие сведения об ошибкеQuick Info on error

При вызове функции в окне со сведениями о параметрах отображаются типы параметров и порядок их ввода.When you call a function, Parameter Info shows the types of parameters and the order in which they are expected.

С++: сведения о параметреParameter Info in C++

Показать определениеPeek Definition

Наведите указатель мыши на объявление переменной или функции, щелкните правой кнопкой мыши, а затем выберите Показать определение, чтобы увидеть встроенное представление определения, не покидая текущее расположение.Hover over a variable or function declaration, right-click, then choose Peek Definition to see an inline view of its definition without navigating away from your current location. Дополнительные сведения см. в разделе Команда "Показать определение" (ALT+F12).For more information, see Peek Definition (Alt+F12).

С++: команда "Показать определение"C++ Peek Definition

справка F1F1 Help

Чтобы перейти непосредственно к соответствующему справочному разделу на сайте docs.microsoft.com, поместите курсор на любой тип, ключевое слово или функцию (либо сразу за ними) и нажмите клавишу F1.Place the cursor on or just after any type, keyword or function and press F1 to go directly to the relevant reference topic on docs.microsoft.com. Клавиша F1 также работает с элементами в списке ошибок и в некоторых диалоговых окнах.F1 also works on items in the error list, and in many dialog boxes.

Представление классовClass View

Представление классов отображает доступный для поиска набор деревьев всех символов кода, а также их области и иерархий (родительских и дочерних), упорядоченных по проектам.Class View displays a searchable set of trees of all code symbols and their scope and parent/child hierarchies, organized on a per-project basis. Вы можете настроить отображаемое в представлении классов содержимое с помощью параметров представления классов (значок с шестеренкой в верхней части окна).You can configure what Class View displays from Class View Settings (click the gear box icon at the top of the window).

С++: представление классовClass View in C++

Создать диаграмму включаемых файловGenerate graph of include files

Щелкните правой кнопкой мыши файл кода в проекте и выберите Создать диаграмму включаемых файлов для просмотра диаграммы файлов, которые являются включаемыми (из других файлов).Right click on a code file in your project and choose Generate graph of include files to see a graph of which files are included by other files.

С++: граф включаемых файловC++ graph of include files

Просмотр иерархии вызововView Call Hierarchy

Щелкните правой кнопкой мыши любой вызов функции и просмотрите рекурсивный список всех функций, которые он вызывает, а также все функции, которые вызывают его.Right click on any function call and view a recursive list of all the functions that it calls, and all the functions that call it. Каждую функцию в списке можно развернуть одинаковым образом.Each function in the list can be expanded in the same way. Дополнительные сведения см. в разделе Иерархия вызовов.For more information, see Call Hierarchy.

С++: иерархия вызововC++ Call Hierarchy

См. также:See Also

Редактирование и рефакторинг кода C++Edit and refactor code (C++)
Перемещение по базе кода С++ в Visual StudioNavigate your C++ code base in Visual Studio
Совместная работа с использованием Live Share для C++Collaborate with Live Share for C++