Наборы обязательных элементов API диалоговых оконDialog API requirement sets

Наборы обязательных элементов — именованные группы элементов API. Надстройки Office с помощью наборов обязательных элементов, указанных в манифесте, или проверки в среде выполнения определяют, поддерживает ли ведущее приложение Office необходимые API. Дополнительные сведения см. в статье Версии Office и наборы обязательных элементов.Requirement sets are named groups of API members. Office Add-ins use requirement sets specified in the manifest or use a runtime check to determine whether an Office host supports APIs that an add-in needs. For more information, see Office versions and requirement sets.

Надстройки Office работают в нескольких версиях Office. В приведенной ниже таблице перечислены наборы обязательных элементов Dialog API, ведущие приложения Office, которые их поддерживают, а также номера сборок или версий для этих приложений.Office Add-ins run across multiple versions of Office. The following table lists the Dialog API requirement sets, the Office host applications that support that requirement set, and the build or version numbers for the Office application.

Набор обязательных элементовRequirement set Office 2013 для Windows*Office 2013 on Windows*
(единовременная покупка)(one-time purchase)
Office 2016 или более поздней версии в Windows*Office 2016 or later on Windows*
(единовременная покупка)(one-time purchase)
Office для WindowsOffice on Windows
(подключено к подписке Office 365)(connected to Office 365 subscription)
Office на iPadOffice on iPad
(подключено к подписке Office 365)(connected to Office 365 subscription)
Office на MacOffice on Mac
(подключено к подписке Office 365)(connected to Office 365 subscription)
Office в ИнтернетеOffice on the web Office Online ServerOffice Online Server
DialogApi 1.1DialogApi 1.1 Сборка 15.0.4855.1000 или более поздняяBuild 15.0.4855.1000 or later Сборка 16.0.4390.1000 или более поздняяBuild 16.0.4390.1000 or later Версия 1602 (сборка 6741.0000) или более поздняяVersion 1602 (Build 6741.0000) or later 1.22 или более поздняя1.22 or later 15.20 или более поздняя15.20 or later Январь 2017 г.January 2017 Версия 1608 (сборка 7601.6800) или более поздняяVersion 1608 (Build 7601.6800) or later

*Пользователи одноразового приобретения Office могут не принять все исправления и обновления.* Users of the one-time purchase Office may not have accepted all patches and updates. Если да, то библиотека DLL, используемая Office для отправки отчетов о версии в пользовательском интерфейсе, может быть больше, чем перечисленные здесь версии, даже если обновленные библиотеки DLL, необходимые для поддержки DialogApi, не установлены на компьютере пользователя.If so, the DLL that Office uses to report its version in the UI may be greater than the versions listed here even if the updated DLLs needed to support DialogApi have not be installed on the user's computer. Чтобы убедиться, что необходимое исправление установлено, пользователь должен перейти в список обновлений Office (список office 2013 или список Office 2016), выполнить поиск осфклиент-x-noneи установить указанное исправление.To ensure that the needed patch is installed, the user must go to the Office update list (Office 2013 list or Office 2016 list), search for osfclient-x-none, and install the listed patch.

Статьи и разделы с дополнительными сведениями о версиях, номерах сборок и Office Online Server:To find out more about versions, build numbers, and Office Online Server, see:

Наборы обязательных элементов общего API для OfficeOffice Common API requirement sets

Сведения о наборах обязательных элементов общего API см. в статье Наборы обязательных элементов общего API для Office.For information about Common API requirement sets, see Office Common API requirement sets.

Dialog API 1.1Dialog API 1.1

Dialog API 1.1 — это первая версия этого API.The Dialog API 1.1 is the first version of the API. Дополнительные сведения об этом API см. в справочной статье о Dialog API.For details about the API, see the Dialog API reference topic.

См. такжеSee also