Начало работы с набором средств Visual Studio для UnityGetting Started with Visual Studio Tools for Unity

Note

Эта статья относится к Visual Studio 2015.This article applies to Visual Studio 2015. Если вы ищете последние версии документации Visual Studio, используйте средство выбора версии в верхнем левом углу.If you're looking for the latest Visual Studio documentation, use the version selector at the top left. Мы рекомендуем выполнить обновление до Visual Studio 2019.We recommend upgrading to Visual Studio 2019. Скачать эту версию можно здесьDownload it here

В этом разделе вы узнаете, как установить инструменты Visual Studio для Unity и настроить проект Unity для работы с Visual Studio.In this section, you'll learn how to install Visual Studio Tools for Unity and configure your Unity project to work with Visual Studio.

Important

В Unity 5.2 добавлена встроенная поддержка инструментов Visual Studio для Unity 2.1, что упрощает настройку проекта.Unity 5.2 adds built-in support for Visual Studio Tools for Unity 2.1, which simplifies project setup. Для использования этой возможности потребуется Unity 5.2.0 или более поздней версии в Windows и инструменты Visual Studio для Unity 2.1 или более поздней версии.To take advantage of this, you'll need Unity version 5.2.0 or higher on Windows, and Visual Studio Tools for Unity version 2.1 or higher.

PrerequisitesPrerequisites

Для использования средств Visual Studio для Unity вам потребуется следующее:To use Visual Studio Tools for Unity, you'll need:

  • версия Visual Studio , поддерживающая расширение, например Visual Studio Community, Professional, Premium или EnterpriseA version of Visual Studio that supports extensions, such as Visual Studio Community, Professional, Premium, or Enterprise. (скачать Visual Studio Community можно бесплатно);You can download Visual Studio Community for free.

    Скачать Visual Studio CommunityDownload Visual Studio Community

  • Unity 4.0.0 или более поздней версии; Unity 5.2.0 или более поздней версии для использования встроенной поддержки инструментов Visual Studio для Unity 2.1 или более поздней версии.Unity version 4.0.0 or higher; Unity version 5.2.0 or higher to take advantage of built-in support for Visual Studio Tools for Unity version 2.1 or higher.

    Скачать UnityDownload Unity

Установка набора средств Visual Studio для UnityInstall Visual Studio Tools for Unity

Загрузите и установите набор средств Visual Studio для Unity из галереи Visual Studio.Download and install Visual Studio Tools for Unity from the Visual Studio Gallery. Необходимо установить нужный пакет для вашей версии Visual Studio.You'll need to install the right package for your version of Visual Studio. Для использования встроенной поддержки инструментов Visual Studio для Unity в Unity 5.2 или более поздней версии установите инструменты Visual Studio для Unity 2.1 или более поздней версии.Make sure to install Visual Studio Tools for Unity version 2.1 or higher to take advantage of built-in support for VSTU in Unity 5.2 or higher.

Note

Версии Visual Studio Express не поддерживают расширения, такие как набор средств Visual Studio для Unity.Express versions of Visual Studio don't support extensions such as Visual Studio Tools for Unity. Visual Studio 2013 Community — это бесплатная версия Visual Studio, которая поддерживает набор средств Visual Studio для Unity и другие расширения.Visual Studio Community is a free version of Visual Studio that supports Visual Studio Tools for Unity and other extensions. Для большинства пользователей версия Visual Studio Community является более предпочтительной, чем версия Express.For most users, Visual Studio Community is a better choice than Express.

Ваш первый проект Unity с набором средств Visual Studio для UnityYour first Unity project with Visual Studio Tools for Unity

Теперь, когда у вас есть все необходимое, вы готовы к своему первому проекту Unity с Visual Studio.Now that you have everything you need, you're ready for your first Unity project with Visual Studio. Настройка проекта Unity производится по-разному в зависимости от того, какие версии Unity и инструментов Visual Studio для Unity установлены.Setting up your Unity project is different depending on which versions of Unity and Visual Studio Tools for Unity are installed. Выполните приведенные ниже инструкции для установленной версии Unity и инструментов Visual Studio для Unity.Follow the steps below for the version of Unity and Visual Studio Tools for Unity that you have installed.

Unity 5.2 или более поздней версии (требуются инструменты Visual Studio для Unity 2.1 или более поздней версии)Unity 5.2 and higher (requires VSTU 2.1 or higher)

Начиная с версии Unity 5.2 больше не нужно импортировать пакет unitypackage инструментов Visual Studio в проекты.Starting with Unity 5.2, you no longer have to import the Visual Studio Tools unitypackage into your projects. Если проект импортирует этот пакет unitypackage, Unity 5.2 игнорирует его и напрямую загружает инструменты Visual Studio для Unity из папки установки.If your project imports this unitypackage, Unity 5.2 ignores it and directly loads Visual Studio Tools for Unity from its installed location.

1. Создание проекта Unity1 - Create a Unity Project

Если у вас уже есть опыт работы с Unity, вы можете создать новый проект или загрузить один из собственных.If you're already experienced with Unity, you can create a new project or load one of your own. Если вы загружаете проект, который импортировал пакет unitypackage инструментов Visual Studio для использования инструментов Visual Studio для Unity с предыдущей версией Unity, мы рекомендуем удалить его, удалив каталог UnityVS.If you're loading a project that imported the Visual Studio Tools unitypackage to use Visual Studio Tools for Unity with a previous version of Unity, we recommend that you remove it by deleting the UnityVS directory.

В противном случае, если у вас нет опыта работы с Unity, ознакомьтесь с базовым учебным пособием.Otherwise, if you're new to Unity, start small with a basic tutorial. На странице "Изучение Unity" найдите учебники с примерами проектов, с которых вы можете начать, а также с уроками, которые позволят вам создать собственную игру с помощью Unity.Visit the Unity Learn page to find tutorials on example projects you can start with and lessons you can learn from to build your own game with Unity. На данной странице имеются удобные учебники для нескольких различных игр.The Unity Learn page has easy-to-follow tutorials for several different games.

Учебники — страница "Изучение Unity"Tutorials – Unity Learn page

2. Настройка редактора Unity для использования набора средств Visual Studio для Unity2 - Configure Unity Editor to use Visual Studio Tools for Unity

Чтобы в проекте можно было использовать инструменты Visual Studio для Unity, просто задайте Visual Studio в качестве внешнего редактора скриптов.To enable your project to use Visual Studio Tools for Unity, just set Visual Studio as its external script editor. В редакторе Unity в главном меню выберите пункт Edit > Preferences(Правка > Настройки), а затем в диалоговом окне Unity Preferences (Настройки Unity) выберите External Tools(Внешние средства).In the Unity Editor, on the main menu, choose Edit, Preferences; then, in the Unity Preferences dialog, choose External Tools. Далее укажите в качестве значения свойства External Script Editor (Внешний редактор скриптов) версию Visual Studio, которую нужно использовать (для этой версии Visual Studio должны быть установлены инструменты Visual Studio для Unity), и убедитесь в том, что задано свойство Editor Attaching (Присоединение редактора).Next, set the External Script Editor property to the version of Visual Studio you want to use (Visual Studio Tools for Unity must be installed for this version of Visual Studio) and make sure the Editor Attaching property is set.

Чтобы проверить, включена ли встроенная поддержка инструментов Visual Studio для Unity, воспользуйтесь диалоговым окном About Unity (Сведения о Unity).To make sure that built-in support for Visual Studio Tools for Unity is now enabled, see the About Unity dialog. In the Unity editor, on the main menu, choose Help > About UnityIn the Unity editor, on the main menu, choose Help, About Unity. (Справка > Сведения о Unity). Если инструменты Visual Studio для Unity установлены и правильно настроены, в левом нижнем углу диалогового окна About Unity (Сведения о Unity).If Visual Studio Tools for Unity is installed and correctly configured, you'll see a message displayed in the lower left-hand corner of the About Unity dialog.

Наконец, убедитесь в том, что вы установили целевой объект сборки на странице Build Settings (Параметры сборки) и что функция Script Debugging (Отладка скриптов) включена.Finally, make sure you've set a build target through the Build Settings page and that Script Debugging is enabled.

Настройка параметров сборки Unity для отладки.Configure the Unity build settings for debugging.

3. Запуск Visual Studio из редактора Unity3 - Launch Visual Studio from the Unity Editor

Начиная с версии Unity 5.2 меню расширения Инструменты Visual Studio больше не требуется для запуска Visual Studio или настройки инструментов Visual Studio для Unity.Starting with Unity 5.2, the Visual Studio Tools extension menu is no longer needed to launch Visual Studio or to configure Visual Studio Tools for Unity. Вместо этого после настройки Visual Studio в качестве внешнего редактора скриптов просто выберите файл скрипта в редакторе Unity, и ваш код откроется в Visual Studio.Instead, once Visual Studio is configured as your external script editor, just choose the script file from the Unity editor and your code will be opened in Visual Studio.

Предыдущие версии Unity (до версии 5.2)Previous versions of Unity (pre-5.2)

До версии Unity 5.2 встроенная поддержка инструментов Visual Studio для Unity отсутствовала.Before Unity 5.2, there was no built-in support for Visual Studio Tools for Unity. Поэтому для использования инструментов Visual Studio для Unity каждому проекту приходилось импортировать пакет unitypackage инструментов Visual Studio и настраивать другие параметры проекта.Instead, each project had to import the Visual Studio Tools unitypackage and configure other project settings in order to use Visual Studio Tools for Unity.

1. Создание проекта Unity1 - Create a Unity Project

Если у вас уже есть опыт работы с Unity, вы можете создать новый проект или загрузить один из собственных.If you're already experienced with Unity, you can create a new project or load one of your own. Если вы начинаете новый проект, импортируйте пакет unitypackage инструментов Visual Studio при его создании.If you're starting a new project, import the Visual Studio Tools unitypackage when you create it.

В противном случае, если у вас нет опыта работы с Unity, ознакомьтесь с базовым учебным пособием.Otherwise, if you're new to Unity, start small with a basic tutorial. На странице "Изучение Unity" найдите учебники с примерами проектов, с которых вы можете начать, а также с уроками, которые позволят вам создать собственную игру с помощью Unity.Visit the Unity Learn page to find tutorials on example projects you can start with and lessons you can learn from to build your own game with Unity. На данной странице имеются удобные учебники для нескольких различных игр.The Unity Learn page has easy-to-follow tutorials for several different games.

Учебники — страница "Изучение Unity"Tutorials – Unity Learn page

2. Настройка редактора Unity для использования набора средств Visual Studio для Unity2 - Configure Unity Editor to use Visual Studio Tools for Unity

Если вы используете существующий проект Unity или не импортировали пакет unitypackage инструментов Visual Studio на этапе создания проекта, необходимо импортировать этот пакет.If you're starting from an existing Unity project or you didn't import the Visual Studio Tools unitypackage when you created the project, you need to import the unitypackage now. В редакторе Unity в главном меню выберите Assets > Import Package > Visual Studio 2015 Tools (Ресурсы > Импорт пакета > Набор средств Visual Studio 2015) (вы увидите вариант для версии Visual Studio, которую вы установили).In the Unity editor, on the main menu, choose Assets, Import Package, Visual Studio 2015 Tools (you should see an option for the version of Visual Studio you have installed).

Импортируйте пакет VSTU в проект Unity.Import the VSTU package into your Unity project.

Наконец, убедитесь в том, что вы установили целевой объект сборки на странице Build Settings (Параметры сборки) и что функция Script Debugging (Отладка скриптов) включена.Finally, make sure you've set a build target through the Build Settings page and that Script Debugging is enabled.

Настройка параметров сборки Unity для отладки.Configure the Unity build settings for debugging.

3. Запуск Visual Studio из редактора Unity3 - Launch Visual Studio from Unity Editor

Теперь необходимо запустить Visual Studio из Unity.The final step is to start Visual Studio from Unity. При этом создается решение Visual Studio для вашего проекта, которое открывается в Visual Studio.This creates a Visual Studio Solution for your project, and then opens it in Visual Studio.

В редакторе Unity в главном меню выберите "Средства Visual Studio", "Открыть в Visual Studio" .In the Unity Editor, on the main menu, choose Visual Studio Tools, Open in Visual Studio.

Откройте проект Unity в Visual Studio.Open your unity project in Visual Studio.

Следующие шагиNext steps

Информацию о работе с проектом Unity и его отладке в Visual Studio см. в разделе Using Visual Studio Tools for Unity.To learn how to work with and debug your Unity project in Visual Studio, see Using Visual Studio Tools for Unity.

См. такжеSee Also

Главная страница UnityUnity Homepage