СтруктуризацияOutlining

Можно скрыть часть кода из представления, свернув область кода так, чтобы она отображалась со знаком "плюс" ( + ).You can choose to hide some code from view by collapsing a region of code so that it appears under a plus sign ( + ). Чтобы развернуть свернутую область, нужно щелкнуть знак "плюс".You expand a collapsed region by clicking the plus sign. Если вы предпочитаете использовать клавиатуру, то можете нажать клавиши CTRL+M+M для свертывания и развертывания.If you are a keyboard user, you can choose Ctrl+M+M to collapse and expand. Можно также свернуть область структуры, дважды щелкнув любую строку в области в поле структуры, которая появляется слева от кода.You can also collapse an outlining region by double-clicking any line in the region on the outlining margin, which appears just to the left of the code. Содержимое свернутой области отображается в виде всплывающей подсказки при наведении указателя мыши на эту область.You can see the contents of a collapsed region as a tooltip when you hover over the collapsed region.

Примечание

Этот раздел относится к Visual Studio в Windows.This topic applies to Visual Studio on Windows. Информацию о Visual Studio для Mac см. в статье Редактор исходного кода (Visual Studio для Mac).For Visual Studio for Mac, see Source editor (Visual Studio for Mac).

Области в поле структуры также выделяются при наведении указателя мыши на поле.Regions in the outlining margin are also highlighted when you hover over the margin with the mouse. В некоторых конфигурациях цветов цвет выделения по умолчанию может показаться едва заметным.The default highlighting color may seem rather faint in some color configurations. Его можно изменить, последовательно выбрав Сервис > Параметры > Среда > Шрифты и цвета > Свертываемая область .You can change it in Tools > Options > Environment > Fonts and Colors > Collapsible Region .

При работе в структурированном коде можно развернуть нужные для работы разделы, свернуть их после работы, а затем перейти к другим разделам.When you work in outlined code, you can expand the sections you want to work on, collapse them when you are done, and then move to other sections. Чтобы структура не отображалась, воспользуйтесь командой Прекратить показ структуры , чтобы удалить сведения о структурировании, не затрагивая базовый код.When you do not wish to have outlining displayed, you can use the Stop Outlining command to remove the outline information without disturbing your underlying code.

Эти действия выполняются с помощью команд Отменить и Вернуть в меню Правка .The Undo and Redo commands on the Edit menu affect these actions. Операции Копировать , Вырезать , Вставить и операции перетаскивания сохраняют сведения о структуре, но не состояние свертываемой области.The Copy , Cut , Paste , and drag-and-drop operations retain outlining information, but not the state of the collapsible region. Например, при копировании свернутой области операция Вставить вставит скопированный текст в виде развернутой области.For example, when you copy a region that is collapsed, the Paste operation will paste the copied text as an expanded region.

Внимание!

При изменении области структуры структурирование может быть утеряно.When you change an outlined region, the outlining may be lost. Например, операции удаления или поиска и замены могут удалить конец области.For example, deletions or Find and Replace operations may erase the end of the region.

Приведенные ниже команды находятся в подменю Правка > Структурирование .The following commands can be found on the Edit > Outlining submenu.

nameName ОписаниеDescription
Скрыть выделенноеHide Selection ( CTRL+M , CTRL+H ) — сворачивает выбранный блок кода, который обычно недоступен для структурирования, например блок if.( Ctrl+M , Ctrl+H ) - Collapses a selected block of code that would not normally be available for outlining, for example an if block. Чтобы удалить пользовательскую область, используйте команду Прервать скрытие текущей области (или сочетание клавиш CTRL+M , CTRL+U ).To remove the custom region, use Stop Hiding Current (or Ctrl+M , Ctrl+U ). Недоступно в Visual Basic.Not available in Visual Basic.
Свернуть/развернуть сегментToggle Outlining Expansion ( CTRL+M , CTRL+L ) — отменяет текущее скрытое или развернутое состояние самого внутреннего раздела структуры, если курсор находится во вложенном свернутом разделе.( Ctrl+M , Ctrl+M ) - Reverses the current hidden or expanded state of the innermost outlining section when the cursor lies in a nested collapsed section.
Свернуть/развернуть все сегментыToggle All Outlining ( CTRL+M , CTRL+L ) — задает для всех областей то же свернутое или развернутое состояние.( Ctrl+M , Ctrl+L ) - Sets all regions to the same collapsed or expanded state. Если одни области развернуты, а другие свернуты, свернутые области будут развернуты.If some regions are expanded and some collapsed, then the collapsed regions are expanded.
Прекратить показ структурыStop Outlining ( CTRL+M , CTRL+P ) — удаляет все сведения о структуре для всего документа.( Ctrl+M , Ctrl+P ) - Removes all outlining information for the entire document.
Прервать скрытие текущей областиStop Hiding Current ( CTRL+M , CTRL+U ) — удаляет сведения о структуре для текущей выбранной определяемой пользователем области.( Ctrl+M , Ctrl+U ) - Removes the outlining information for the currently selected user-defined region. Недоступно в Visual Basic.Not available in Visual Basic.
Свернуть в определенияCollapse to Definitions ( CTRL+M , CTRL+O ) — сворачивает члены всех типов.( Ctrl+M , Ctrl+O ) - Collapses the members of all types.
Свернуть блок:<logical boundary>Collapse Block:<logical boundary> (C++) Сворачивает область в функции, в которой находится точка вставки.(C++) Collapses a region in the function containing the insertion point. Например, если точка вставки находится внутри цикла, цикл скрывается.For example, if the insertion point lies inside a loop, the loop is hidden.
Свернуть все в: <logical structures>Collapse All in: <logical structures> (C++) Сворачивает все структуры внутри функции.(C++) Collapses all the structures inside the function.

Для определения областей текста, которые требуется развернуть или свернуть, можно также использовать пакет SDK для Visual Studio.You can also use the Visual Studio SDK to define the text regions you want to expand or collapse. См. Пошаговое руководство: структуризация.See Walkthrough: Outlining.

См. такжеSee also