Felsöka åtkomst till Azure-resurser som nekas i Privileged Identity Management

Har du problem med Privileged Identity Management (PIM) i Microsoft Entra-ID? Informationen som följer kan hjälpa dig att få saker att fungera igen.

Åtkomst till Azure-resurser nekas

Problem

Som aktiv ägare eller administratör för användaråtkomst för en Azure-resurs kan du se resursen i Privileged Identity Management, men du kan inte utföra några åtgärder som t.ex. att göra en berättigad tilldelning eller visa en lista med rolltilldelningar från resursöversiktssidan. Dessa åtgärder resulterar i ett auktoriseringsfel.

Orsak

Problemet kan inträffa när rollen Administratör för användaråtkomst för PIM-tjänstens huvudnamn har tagits bort av misstag från prenumerationen. För att tjänsten Privileged Identity Management ska kunna komma åt Azure-resurser bör MS-PIM-tjänstens huvudnamn alltid ha rollen Administratör för användaråtkomst tilldelad.

Åtgärd

Tilldela rollen Administratör för användaråtkomst till tjänstens huvudnamn för privilegierad identitetshantering (MS–PIM) på prenumerationsnivå. Tilldelningen bör ge Privileged Identity Management-tjänsten åtkomst till Azure-resurserna. Rollen kan tilldelas på hanteringsgruppsnivå eller prenumerationsnivå, beroende på dina behov. Mer information om tjänstens huvudnamn finns i Tilldela ett program till en roll.

Nästa steg