Du kan inte logga in på Skype för företag Online eftersom certifikatet inte kan hämtas eller verifieras

Problem

När en Microsoft 365-användare försöker logga in på Skype för företag Online (tidigare Lync Online) med hjälp av Lync 2010 eller Lync 2013 får användaren följande felmeddelande:

There was a problem acquiring a personal certificate required to sign in. If the problem continues, please contact your support team.

När du försöker logga in på Lync efter ett nätverksfel eller ett avbrott i Skype för företag Online-tjänsten visas dessutom följande felmeddelande:

Cannot sign into Lync. There was a problem verifying the certificate from the server.

Orsak

Det här problemet kan inträffa om ett eller flera av följande villkor är uppfyllda:

  • Programvaran är inaktuell.

    • Lync-klienten är inaktuell.
    • Microsoft Online Services Sign-In Assistant är inaktuell.
  • Certifikaten kan inte hämtas eller verifieras.

    • Det personliga Skype för företag onlinecertifikatet eller de cachelagrade autentiseringsuppgifterna är skadade eller är inaktuella.
    • En del av certifikatkedjan är inte betrodd och certifikatkedjan misslyckas med valideringen.

Lösning

Lösning för Lync 2013

Ta bort inloggningsinformationen

Under inloggningsprocessen cachelagrar Lync 2013 dina autentiseringsuppgifter och annan information om anslutningen till Skype för företag Online. Om du har problem med att logga in på Skype för företag Online klickar du på Ta bort min inloggningsinformation så tar Lync 2013 automatiskt bort alla sparade lösenord, certifikat och anslutningsinställningar för användarkontot.

Skärmbild som visar inloggningssidan för Lync 2013 med alternativet Ta bort min inloggningsinformation valt.

Lösning för Lync 2010

  1. Uppdatera Lync-klienten till den senaste versionen som är tillgänglig på sidan Nedladdningar i Microsoft 365-portalen.

  2. Kontrollera att Inloggningsassistenten för Microsoft Online Services körs på Windows Services genom att följa dessa steg:
    (De här stegen gäller för Windows 10)

    1. Högerklicka på startknappen och välj Kör.
    2. Skriv services.msc och välj OK.
    3. I fönstret Tjänster kontrollerar du om Status för Inloggningsassistenten för Microsoft Online Services visas som Körs.
  3. Rensa dina cachelagrade certifikat, autentiseringsuppgifter och anslutningar.

Ytterligare felsökningssteg för Lync 2013 och Lync 2010

Obs!

Följ stegen i det här avsnittet noggrant. Det kan uppstå allvarliga problem om du gör felaktiga ändringar i registret. Innan du ändrar det bör du först säkerhetskopiera registret för återställning om problem skulle uppstå.

Om stegen tidigare i den här artikeln inte löser problemet kan du prova följande metoder efter behov för din situation:

  • När Lync ansluter till en specifik klientdelsserver cachelagrar den slutpunkten för att göra inloggningsprocessen snabbare i framtiden. Men ibland kan slutpunkten ändras och det kan leda till att inloggningen misslyckas. Följ dessa steg om du vill ta bort slutpunktscacheminnet:

    1. Leta upp den lokala programdatamappen:
      • Windows Vista, Windows 7 och Windows 8 (exklusive Windows 8 RT):

        %LOCALAPPDATA%\Microsoft\Communicator<sip_address@contoso.com>\

    • Windows XP:

      %USERPROFILE%\Local Settings\Application Data\Microsoft\Communicator<sip_address@contoso.com>\

    1. Ta bort mappen som är associerad med din inloggningsadress.
    2. Starta om Lync och försök sedan logga in på Skype för företag Online.
  • Om du använder Lync 2010 tar du bort det personliga Skype för företag Online-certifikatet och laddar sedan ned ett nytt. Tänk på att när användaren klickar på Spara lösenord i Lync 2010 sparar den här åtgärden även certifikatet i Windows Certificate Manager.

    Följ dessa steg om du vill ta bort ett personligt certifikat:

    1. Ta bort certifikatet i Windows Certificate Manager. Gör så här:
      1. Öppna Windows Certificate Manager. Det gör du genom att trycka på Windows + R, skriva certmgr.msc och sedan klicka på OK.
      2. Expandera Personligt och expandera sedan Certifikat.
      3. Sortera efter kolumnen Utfärdat av och leta sedan efter ett certifikat som utfärdats av kommunikationsservern.
      4. Kontrollera att certifikatet finns och att det inte har upphört att gälla.
      5. Ta bort certifikatet och försök logga in på Skype för företag Online. Om du inte kan logga in på Skype för företag Online går du till steg 2.
    2. Om du kör Windows 7 tar du bort användarens lagrade autentiseringsuppgifter i Windows Credential Manager. Gör så här:
      1. Öppna Kontrollpanelen och klicka sedan på Autentiseringshanteraren.

      2. Leta upp den uppsättning autentiseringsuppgifter som används för att ansluta till Skype för företag Online.

      3. Expandera uppsättningen med autentiseringsuppgifter och välj sedan Ta bort från valvet.

      4. Försök att logga in på Skype för företag Online igen och ange sedan din nya uppsättning autentiseringsuppgifter.

        Obs!

        De här stegen är inte nödvändiga i Lync 2013 eftersom de steg som nämndes tidigare om att ta bort inloggningsinformation tar bort certifikaten automatiskt.

  • Töm DNS-cachen. Gör så här:

    1. Tryck på Windows + R, skriv följande kommando och tryck sedan på Retur:

      Ipconfig /flushdns

  • Varning Allvarliga problem kan uppstå om du ändrar registret felaktigt med hjälp av Registereditorn eller med hjälp av en annan metod. Dessa problem kan kräva att du installerar om operativsystemet. Microsoft kan inte garantera att dessa problem kan lösas. Ändra registret på egen risk.

    Kontrollera följande registernyckel på de berörda datorerna:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\MachineGuid

    Om värdet för MachineGuid innehåller klammerparenteser runt GUID (till exempel {c1cbd94c-0d35-414c-89ef-dd092b984883}) tar du bort klammerparenteserna, startar om Lync och försöker sedan logga in igen.

Lösning för Skype för företag Online-administratörer: Verifiera certifikatkedjan

Slutanvändarna kan få ett felmeddelande om att certifikatet inte kan verifieras, och detta inträffar vanligtvis eftersom ett av certifikaten i kedjan inte är betrott och inte kan verifieras. Detta inträffar vanligtvis för kunder som använder enkel inloggning i Microsoft 365 eller för kunder som har Lync-hybriddistributioner.

Mer information om certifikatverifiering med Lync finns i Lync Mobile-användare kan inte logga in när de har uppdaterat till klientversion 5.4.

Obs!

Även om den här artikeln är skriven för mobila enheter gäller samma begrepp för Lync-klienter.

Mer information

Om problemet kvarstår när du har slutfört de här felsökningsstegen kontaktar du Teknisk support för Microsoft 365 eller Microsoft 365 Community-forumen. I vissa fall kan Active Directory Domain Services användarkonto vara ofullständigt eller skadat. Därför kan Skype för företag Online inte generera ett personligt certifikat. Detta kanske inte påverkar alla en klientorganisations konton eftersom effekten beror på serverns tillstånd när användarkontot skapades.

Begränsa problemet genom att avgöra om problemet uppstår för flera användarkonton på samma dator. Försök sedan logga in på Skype för företag Online från samma dator med hjälp av flera användarkonton. Den här processen anger om problemet är relaterat till datorns konfiguration eller ett problem med Skype för företag Online-användarkontot.

Löstes problemet?

  • Kontrollera om problemet är åtgärdat.
  • Vi uppskattar din feedback. Om du vill ge feedback eller rapportera eventuella problem med den här lösningen skickar du ett e-postmeddelande till oss.

Behöver du fortfarande hjälp? Gå till Microsoft Community.