Routerkonfigurationsexempel för att konfigurera och hantera routning

Den här sidan innehåller konfigurationsexempel för gränssnitt och routning för Routrar i Cisco IOS-XE- och Juniper MX-serien när du arbetar med Azure ExpressRoute.

Viktigt

Exemplen på den här sidan är enbart för vägledning. Du måste samarbeta med leverantörens sälj-/teknikteam och ditt nätverksteam för att hitta lämpliga konfigurationer som uppfyller dina behov. Microsoft stöder inte problem som rör konfigurationer som anges på den här sidan. Kontakta enhetsleverantören för supportproblem.

MTU- och TCP MSS-inställningar på routergränssnitt

Den maximala överföringsenheten (MTU) för ExpressRoute-gränssnittet är 1500, vilket är den typiska standard-MTU:n för ett Ethernet-gränssnitt på en router. Om routern inte har en annan MTU som standard behöver du inte ange något värde i routergränssnittet.

Till skillnad från en Azure VPN-gateway behöver inte TCP-maximal segmentstorlek (MSS) för en ExpressRoute-krets anges.

Routerkonfigurationsexempel i den här artikeln gäller för alla peerings. Mer information om routning finns i ExpressRoute-peerings och ExpressRoute-routningskrav.

Cisco IOS-XE-baserade routrar

Exemplen i det här avsnittet gäller för alla routrar som kör OS-familjen IOS-XE.

Konfigurera gränssnitt och undergränssnitt

Du behöver ett undergränssnitt per peering i varje router som du ansluter till Microsoft. Ett underinterface kan identifieras med ett VLAN-ID eller ett staplat par VLAN-ID:n och en IP-adress.

Definition av Dot1Q-gränssnitt

Det här exemplet innehåller definitionen av undergränssnittet för ett underinterface med ett enda VLAN-ID. VLAN-ID:t är unikt för varje peering. Den sista oktetten i din IPv4-adress är alltid ett udda tal.

interface GigabitEthernet<Interface_Number>.<Number>
 encapsulation dot1Q <VLAN_ID>
 ip address <IPv4_Address><Subnet_Mask>

Definition av QinQ-gränssnitt

Det här exemplet innehåller definitionen av ett underord med två VLAN-ID: er. Det yttre VLAN-ID:t (s-tag), om det används, förblir detsamma för alla peerings. Det inre VLAN-ID:t (c-tag) är unikt per peering. Den sista oktetten i din IPv4-adress är alltid ett udda tal.

interface GigabitEthernet<Interface_Number>.<Number>
 encapsulation dot1Q <s-tag> second-dot1Q <c-tag>
 ip address <IPv4_Address><Subnet_Mask>

Konfigurera eBGP-sessioner

Du måste konfigurera en BGP-session med Microsoft för varje peering. Konfigurera en BGP-session med hjälp av följande exempel. Om den IPv4-adress som du använde för ditt undergränssnitt var a.b.c.d blir IP-adressen för BGP-grannen (Microsoft) a.b.c.d+1. Den sista oktetten i BGP-grannens IPv4-adress är alltid ett jämnt tal.

router bgp <Customer_ASN>
 bgp log-neighbor-changes
 neighbor <IP#2_used_by_Azure> remote-as 12076
 !
 address-family ipv4
 neighbor <IP#2_used_by_Azure> activate
 exit-address-family
!

Konfigurera prefix som ska annonseras under BGP-sessionen

Konfigurera routern för att annonsera utvalda prefix till Microsoft med hjälp av följande exempel.

router bgp <Customer_ASN>
 bgp log-neighbor-changes
 neighbor <IP#2_used_by_Azure> remote-as 12076
 !
 address-family ipv4
  network <Prefix_to_be_advertised> mask <Subnet_mask>
  neighbor <IP#2_used_by_Azure> activate
 exit-address-family
!

Ruttkartor

Använd vägkartor och prefixlistor för att filtrera prefix som sprids till nätverket. Se följande exempel och se till att du har rätt prefixlistor konfigurerade.

router bgp <Customer_ASN>
 bgp log-neighbor-changes
 neighbor <IP#2_used_by_Azure> remote-as 12076
 !
 address-family ipv4
  network <Prefix_to_be_advertised> mask <Subnet_mask>
  neighbor <IP#2_used_by_Azure> activate
  neighbor <IP#2_used_by_Azure> route-map <MS_Prefixes_Inbound> in
 exit-address-family
!
route-map <MS_Prefixes_Inbound> permit 10
 match ip address prefix-list <MS_Prefixes>
!

Konfigurera BFD

Du konfigurerar BFD på två platser: en på gränssnittsnivå och en annan på BGP-nivå. Exemplet här är för QinQ-gränssnittet.

interface GigabitEthernet<Interface_Number>.<Number>
 bfd interval 300 min_rx 300 multiplier 3
 encapsulation dot1Q <s-tag> second-dot1Q <c-tag>
 ip address <IPv4_Address><Subnet_Mask>

router bgp <Customer_ASN>
 bgp log-neighbor-changes
 neighbor <IP#2_used_by_Azure> remote-as 12076
 !
 address-family ipv4
  neighbor <IP#2_used_by_Azure> activate
  neighbor <IP#2_used_by_Azure> fall-over bfd
 exit-address-family
!

Juniper MX-serieroutrar

Exemplen i det här avsnittet gäller för alla Routrar i Juniper MX-serien.

Konfigurera gränssnitt och undergränssnitt

Definition av Dot1Q-gränssnitt

Det här exemplet innehåller definitionen av undergränssnittet för ett underinterface med ett enda VLAN-ID. VLAN-ID:t är unikt per peering. Den sista oktetten i din IPv4-adress är alltid ett udda tal.

    interfaces {
        vlan-tagging;
        <Interface_Number> {
            unit <Number> {
                vlan-id <VLAN_ID>;
                family inet {
                    address <IPv4_Address/Subnet_Mask>;
                }
            }
        }
    }

QinQ-gränssnittsdefinition

Det här exemplet innehåller definitionen av undergränssnittet för ett underinterface med två VLAN-ID:er. Det yttre VLAN-ID:t (s-tag), om det används, förblir detsamma för alla peerings. Det inre VLAN-ID:t (c-tag) är unikt per peering. Den sista oktetten i din IPv4-adress är alltid ett udda tal.

    interfaces {
        <Interface_Number> {
            flexible-vlan-tagging;
            unit <Number> {
                vlan-tags outer <S-tag> inner <C-tag>;
                family inet {
                    address <IPv4_Address/Subnet_Mask>;
                }                           
            }                               
        }                                   
    }                           

Konfigurera eBGP-sessioner

Du måste konfigurera en BGP-session med Microsoft för varje peering. Konfigurera en BGP-session med hjälp av följande exempel. Om den IPv4-adress som du använde för ditt undergränssnitt var a.b.c.d blir IP-adressen för BGP-grannen (Microsoft) a.b.c.d+1. Den sista oktetten i BGP-grannens IPv4-adress är alltid ett jämnt tal.

    routing-options {
        autonomous-system <Customer_ASN>;
    }
    }
    protocols {
        bgp { 
            group <Group_Name> { 
                peer-as 12076;              
                neighbor <IP#2_used_by_Azure>;
            }                               
        }                                   
    }

Konfigurera prefix som ska annonseras via BGP-sessionen

Konfigurera routern för att annonsera utvalda prefix till Microsoft med hjälp av följande exempel.

    policy-options {
        policy-statement <Policy_Name> {
            term 1 {
                from protocol OSPF;
                route-filter; 
                <Prefix_to_be_advertised/Subnet_Mask> exact;
                then {
                    accept;
                }
            }
        }
    }
    protocols {
        bgp { 
            group <Group_Name> { 
                export <Policy_Name>;
                peer-as 12076;              
                neighbor <IP#2_used_by_Azure>;
            }                               
        }                                   
    }

Vägprinciper

Du kan använda vägkartor och prefixlistor för att filtrera prefix som sprids till nätverket. Se följande exempel och se till att du har rätt prefixlistor konfigurerade.

    policy-options {
        prefix-list MS_Prefixes {
            <IP_Prefix_1/Subnet_Mask>;
            <IP_Prefix_2/Subnet_Mask>;
        }
        policy-statement <MS_Prefixes_Inbound> {
            term 1 {
                from {
                    prefix-list MS_Prefixes;
                }
                then {
                    accept;
                }
            }
        }
    }
    protocols {
        bgp { 
            group <Group_Name> { 
                export <Policy_Name>;
                import <MS_Prefixes_Inbound>;
                peer-as 12076;              
                neighbor <IP#2_used_by_Azure>;
            }                               
        }                                   
    }

Konfigurera BFD

Konfigurera ENDAST BFD under protokollets BGP-avsnitt.

    protocols {
        bgp { 
            group <Group_Name> { 
                peer-as 12076;              
                neighbor <IP#2_used_by_Azure>;
                bfd-liveness-detection {
                       minimum-interval 3000;
                       multiplier 3;
                }
            }                               
        }                                   
    }

Konfigurera MACSec

För MACSec-konfiguration måste Anslutningsassociaty-nyckel (CAK) och Anslutningsassociatypnyckelnamn (CKN) matcha med konfigurerade värden via PowerShell-kommandon.

    security {
        macsec {
            connectivity-association <Connectivity_Association_Name> {
                cipher-suite gcm-aes-xpn-128;
                security-mode static-cak;
                pre-shared-key {
                    ckn <Connectivity_Association_Key_Name>;
                    cak <Connectivity_Association_Key>; ## SECRET-DATA
                }
            }
            interfaces {
                <Interface_Number> {
                    connectivity-association <Connectivity_Association_Name>;
                }
            }
        }
    }

Nästa steg

Se Vanliga frågor och svar om ExpressRoute för mer information.