401 Access denied error when you run the Test-OAuthConnectivity cmdlet
Ursprungligt KB-nummer: 3090197
Symptom
När du kör cmdleten för att testa OAuth-autentisering för en användare misslyckas åtgärden och du får ett meddelande som Test-OAuthConnectivity
ser ut ungefär så här:
401 Access denied
Orsak
Det här problemet kan uppstå om något av följande villkor är sant:
- Det servicehuvudnamn (SPN) som krävs för OAuth-autentisering saknas.
- Du testar ett konto som inte synkroniseras mellan den lokala miljön och Microsoft Exchange Online.
Lösning
Lös problemet genom att vidta någon av följande åtgärder, lämplig för din situation.
Scenario 1 – SPN saknas
Öppna Exchange Management Shell.
Kör följande kommando:
Get-IntraOrganizationConfiguration
Observera vilka värden som returneras för
OnPremisesDiscoveryEndPoint
ochOnPremisesWebServiceEndPoint
.Kör följande kommando:
(Get-MsolServicePrincipal -ServicePrincipalName "00000002-0000-0ff1-ce00-000000000000").ServicePrincipalNames
Kontrollera om domännamnen som visas för slutpunkterna returneras.
Om domännamnen inte returneras använder du
Set-MsolServicePrincipal
cmdleten för att lägga till dem.Följande kommando lägger till exempel till Mail.contoso.com domän.
Set-MsolServicePrincipal -ServicePrincipalName "00000002-0000-0ff1-ce00-000000000000").Mail.contoso.com
Scenario 2 – Du använder ett konto som inte synkroniseras mellan den lokala miljön och Exchange Online
När du kör cmdleten kontrollerar du att du använder ett konto som är synkroniserat mellan den lokala miljön Test-OAuthConnectivity
och Exchange Online. Det här problemet uppstår till exempel om du använder ett lokalt administratörskonto.
I följande exempel är Fred ett användarkonto som synkroniseras mellan den lokala miljön och Exchange Online.
Test-OAuthConnectivity -Service EWS -TargetUri https://cas.contoso.com/ews/ -Mailbox "Fred"
Mer information
Behöver du fortfarande hjälp? Gå till Microsoft Community eller Microsoft Q &A.