"550 5.1.10 RESOLVER. ADR. RecipientNotFound" när Microsoft 365-användare skickar e-post till lokala användare i en hybriddistribution
Ursprungligt KB-nummer: 3197393
Problem
En Microsoft 365-användare kan inte skicka e-postmeddelanden till lokala Exchange-användare i en Exchange-hybriddistribution. Microsoft 365-användaren får följande nondelivery-rapport (NDR):
Det gick inte att leverera meddelandet till User@contoso.com .
Användaren hittades inte på <contoso.com>
NDR innehåller följande felkod:
550 5.1.10 RESOLVER. ADR. RecipientNotFound; Mottagaren hittades inte av SMTP-adresssökningen
Orsak
Det här problemet uppstår om användaren skapades i Microsoft 365. I det här scenariot har den lokala Exchange-miljön inget objekt att referera till för användaren. Därför misslyckas alla frågor för den SMTP-adressen.
Lösning
Lös problemet genom att skapa en fjärrpostlåda i den lokala miljön och sedan vänta tills katalogsynkroniseringen eller framtvinga katalogsynkronisering ska ske. Gör så här:
Skapa ett lokalt objekt för molnpostlådan med hjälp av cmdleten New-RemoteMailbox i Exchange Management Shell.
Obs!
Det här objektet måste ha samma namn, alias och användarhuvudnamn (UPN) som molnpostlådan. Mer information finns i New-RemoteMailbox.
Ange egenskapen ExchangeGuid för det nya lokala objektet som du skapade i steg 1 för att matcha molnpostlådan. Gör så här:
Anslut till Exchange Online med hjälp av en fjärransluten PowerShell.
Mer information finns i Anslut till Exchange Online PowerShell.
Använd cmdleten Get-Mailbox för att hämta värdet för egenskapen för
ExchangeGuid
molnpostlådan. Kör till exempel följande kommando:Get-Mailbox <MailboxName>| FL ExchangeGuid
Mer information finns i Hämta postlåda.
Öppna Exchange Management Shell på den lokala Exchange-servern.
Använd cmdleten
Set-RemoteMailbox
för att ange värdetExchangeGuid
för egenskapen för det lokala objektet till det värde som du hämtade i steg 2b. Kör till exempel följande kommando:Set-RemoteMailbox <MailboxName> -ExchangeGuid <GUID>
Mer information finns i Set-RemoteMailbox.
Vänta tills katalogsynkroniseringen har slutförts. Eller tvinga katalogsynkronisering.
Mer information finns i Synkronisera dina kataloger.
Kontrollera att Microsoft 365-användarobjektet visas som Synkroniserat med Active Directory.
Mer information
Behöver du fortfarande hjälp? Gå till Microsoft Community.
Feedback
https://aka.ms/ContentUserFeedback.
Kommer snart: Under hela 2024 kommer vi att fasa ut GitHub-problem som feedbackmekanism för innehåll och ersätta det med ett nytt feedbacksystem. Mer information finns i:Skicka och visa feedback för