Du får ett felmeddelande när du försöker öppna ett Office-dokument

Symptom

När du försöker öppna en fil i alla Microsoft Office-program som anges i avsnittet "Gäller för" får du något av följande felmeddelanden:

Filnamnet är inte giltigt.

Det gick inte att komma åt filen.

Sökvägen som du angav, "filnamn", är för lång. Ange en kortare sökväg.

det gick inte att hitta filnamnet. Kontrollera stavningen av filnamnet och kontrollera att filsökvägen är korrekt.

Ett DDE-fel har inträffat och en beskrivning av felet kan inte visas eftersom det är för långt. Om filnamnet eller sökvägen är lång kan du prova att byta namn på filen eller kopiera den till en annan mapp.

Skärmbild av felmeddelandet.

Obs!

Det här problemet uppstår när du öppnar en fil från en mappad enhet, en UNC-sökväg eller en URL (webbadress).

Orsak

Det här problemet uppstår på grund av en teckengräns för att skapa och spara filer i Office-produkter. Det här problemet uppstår om sökvägen till filen som du öppnar eller sparar uppfyller följande villkor:

  • Microsoft Word, Microsoft PowerPoint och Microsoft Access: den totala längden på sökvägen och filnamnet, inklusive filnamnstillägget, överstiger 259 tecken.

  • Microsoft Excel: den totala längden på sökvägen och filnamnet, inklusive filnamnstillägget, överstiger 218 tecken.

Obs!

Den här gränsen omfattar de tre tecken som representerar enheten, tecknen i mappnamnen, omvänt snedstreck mellan mappnamnen och tecknen i själva filnamnet.

Lösning

Använd någon av följande metoder för att lösa problemet:

Lösning 1: minska antalet tecken

  • Byt namn på filen så att den har ett kortare namn.
  • Byt namn på en eller flera mappar som innehåller filen så att de har kortare namn.
  • Flytta filen till en mapp som har ett kortare sökvägsnamn.

Lösning 2: manuell åtkomst, öppna och reparera

  1. Starta Word, Excel eller PowerPoint.

  2. På fliken Arkiv väljer du Öppna>Bläddra för att hitta den skadade filen.

    Skärmbild av att öppna en dialogruta.

  3. Markera filen, välj menyn Öppna längst ned i fönstret och välj sedan Öppna och reparera.

    Skärmbild på alternativet Öppna och reparera.

Det här alternativet reparerar skadan på filen och öppnar sedan filen. När du har reparerat dokumentet, arbetsboken eller presentationen är det viktigt att kontrollera att problemet har lösts. Det gör du genom att börja arbeta med filen och se till att allt fungerar som förväntat.

Lösning 3: ändra filformat och spara om

Du kanske kan rädda en skadad fil genom att spara den i ett annat filformat och sedan återställa den till det ursprungliga formatet. I det här exemplet används Word.

Steg 1: spara filen i ett annat format

  1. Starta Word.

  2. Arkiv-menyn väljer du Öppna och letar sedan upp och öppnar den skadade filen.

  3. Välj Spara som>Bläddra i Arkiv-menyn.

  4. Gå till den filsökväg som du vill spara i.

  5. Välj önskat filformat i listan Filformat. Välj till exempel RTF-format (*rtf).

    Skärmbild av alternativet Filformat.

  6. Välj Spara och sedan Arkiv>Stäng.

Steg 2: spara om filen som ett Word-dokument

  1. Välj Arkiv>Öppna.

  2. Välj den nya fil som sparas som en RTF-fil och välj sedan Öppna.

  3. Välj Arkiv>Spara som.

  4. Välj Word-dokument i listan Filformat.

  5. Byt namn på filen och klicka sedan på Spara.

    Skärmbild av alternativet Spara en kopia.

Du behöver bara göra detta en gång för att se till att dokumentet nu fungerar korrekt på enheten. Tänk dock på att du skapar en annan fil genom att spara filen som ett nytt dokument. För att undvika förvirring namnger du den nya filen något distinkt och arkiverar eller tar bort den skadade versionen. På så sätt öppnar du inte den ursprungliga filen som inte har formaterats om av misstag.

Lösning 4: öppna okänt filformat

Om du kan utesluta att filen skadas som den skyldige letar du efter filassociationer och okända filformat. Ibland öppnas inte en fil på enheten eftersom enheten som filen skapades på använt program som enheten inte har.

I Word vill du till exempel visa en PDF-fil som är kopplad till ett e-postmeddelande. Du har dock inte ett PDF-visningsprogram installerat. Därför vet enheten inte vilket program som ska öppnas för att visa filen. I det här fallet kan du ändra filens format så att det matchar ett program som du har installerat.

  1. Spara den bifogade filen på datorn. Det gör du genom att välja nedåtpilen bredvid den bifogade filen i meddelandet, välja Spara som, gå till önskad plats och sedan välja Spara.

  2. Klicka på Öppna>Bläddra i Arkiv-menyn för att hitta filen.

  3. Högerklicka på filen, peka på Öppna med och välj sedan ett annat program för att öppna filen.

  4. Om det önskade programmet inte finns med i listan väljer du "Välj en annan app" för att hitta ett annat program.

    Obs!

    Om detta fungerar och du vill att det valda programmet alltid ska öppna den här typen av fil markerar du kryssrutan Använd alltid den här appen för att öppna .docx-filer (till exempel). Skärmbild av kryssrutan Använd alltid den här appen för att öppna .docx-filer.

Mer information om filformat och hur du hanterar dem finns i Läs mer om filformat.

Lösning 5: frigör lite diskutrymme

Du kanske inte kan öppna en ny fil eller spara en fil på enheten om du får slut på utrymme på hårddisken. På en full disk förbrukas mycket av utrymmet av tillfälliga, duplicerade och onödiga objekt. Den snabbaste och enklaste metoden för att frigöra utrymme på en hårddisk är att använda diskrensningsappen som ingår i Windows.

  1. Välj Sök och skriv Diskrensning.

  2. I resultatlistan väljer du Diskrensning.

    Skärmbild av diskrensning.

  3. En dialogruta öppnas och ger alternativ för att ta bort onödiga filer. Markera kryssrutan bredvid varje kategori av objekt som du vill ta bort från enheten och välj sedan OK. Allt i den här listan kan tas bort på ett säkert sätt.

    Skärmbild av diskrensning för lokal disk (C:).

  4. När du uppmanas att göra det bekräftar du att du vill ta bort de onödiga filerna permanent.

    Skärmbild på alternativet Ta bort filer.

Följande filtyper är exempel på flyttbara objekt som du kan se i listan Diskrensning:

  • Windows Update: de senaste filerna som har laddats ned från Windows Update (om du väljer dessa tar du inte bort installerade uppdateringsversioner)
  • Nedladdade programfiler: onödiga programfiler, ofta relaterade till programinstallationen
  • Tillfälliga Internetfiler: filer som sparas automatiskt av webbläsare när du besöker webbplatser
  • Windows Felrapportering: felrapporteringsfiler som skapas av systemet
  • Papperskorg: alla filer som lagras i papperskorgen som du inte har tagit bort manuellt
  • Temporära filer: andra temporära filer som skapas av program eller webbläsare
  • Användarfilhistorik: filer som registrerar webbhistoriken (webbplatser som du har använt, sökresultat och så vidare)

Mer information

Behöver du fortfarande hjälp? Gå till Microsoft Community.