Det går inte att läsa in ett tillägg när du sänker säkerhets nivån för makron

Anteckning

Office 365 ProPlus byter namn till Microsoft 365-appar för företag. Mer information om den här ändringen finns i det här blogginlägget.

Symptom

När du sänker säkerhets nivån för makron i Microsoft PowerPoint och sedan öppnar en PowerPoint-tilläggs fil (*. ppa), kan det hända att den nya makro säkerheten inte tillämpas och tilläggs filen kanske inte fungerar som den ska. Tillägget visas som ett tillgängligt tillägg i dialog rutan tillägg, men kryss rutan är inte markerad och du får ett fel meddelande av följande slag när du försöker markera kryss rutan:

    • Det gick inte att läsa in tillägget * fil namn * * *.

Orsak

Det här problemet kan uppstå om följande gäller:

  1. Du försöker öppna en PowerPoint-tilläggs fil med kommandot Öppna på Arkiv-menyn när säkerhets nivån för makron är inställd på hög.
  2. Du sänker inställningen för säkerhets nivån för makron.
  3. Du öppnar samma PowerPoint-tilläggs fil med kommandot Öppna på Arkiv-menyn.

När du försöker öppna en tilläggs fil, och tillägget inte läses in på grund av makro säkerhet, lagras ett tillfälligt fel i PowerPoint för att läsa in information om felet. Det går inte att ladda tillägget när du har sänkt säkerhets nivån tills den rensar den cachelagrade informationen.

Lösning

Undvik det här problemet genom att rensa den cachelagrade informationen och sedan läsa in tillägget på något av följande sätt efter att du har ändrat inställningen för makro säkerhets nivån.

Metod 1: avsluta och starta om PowerPoint

  1. Avsluta PowerPoint.
  2. Starta om PowerPoint.
  3. Öppna tilläggs filen.
  4. Klicka på "Jag godkänner" för att ladda tillägget.

Metod 2: ta bort och Lägg till tillägget

Så här tar du bort och lägger till tillägget i PowerPoint 2002:

  1. På menyn verktyg klickar du på tillägg.
  2. I listan tillgängliga tillägg klickar du på tillägget och sedan på ta bort.
  3. Klicka på Lägg till ny, Välj tillägget, klicka på OK, klicka på "Jag godkänner" för att ladda tillägget och klicka sedan på Stäng.

Så här tar du bort tillägget i PowerPoint 2007:

  1. Klicka på Microsoft Office-knappen, klicka på PowerPoint-alternativoch klicka sedan på tillägg.
  2. Välj PowerPoint-tilläggi listan Hantera och klicka sedan på OK.
  3. I listan tillgängliga tillägg väljer du det tillägg som du vill ta bort, klickar på ta bortoch klickar sedan på Stäng.

Så här lägger du till tillägget i PowerPoint 2007:

  1. Klicka på Microsoft Office-knappen, klicka på PowerPoint-alternativoch klicka sedan på tillägg.
  2. Klicka på PowerPoint- tillägg i listan Hantera och klicka sedan på OK.
  3. Klicka på Lägg till ny i dialog rutan tillägg.
  4. I dialog rutan Lägg till nytt PowerPoint-tillägg bläddrar du till det tillägg som du vill lägga till och klickar sedan på OK.
  5. Ett säkerhets meddelande visas. Om du är säker på att tillägget kommer från en betrodd källa klickar du på Aktivera makronoch sedan på Stäng.

Status

Microsoft har bekräftat att det här är ett problem i Microsoft-produkterna som nämns i "gäller".

Steg för att återskapa problemet

PowerPoint 2007

  1. Starta PowerPoint 2007.

  2. Klicka på makro säkerhet i gruppen kod på fliken utvecklare .

    Anteckning

    Fliken utvecklare visas inte som standard. Visa fliken utvecklare genom att klicka på Microsoft Office-knappen, klicka på PowerPoint- alternativ, välja Visa fliken Utvecklare i menyfliksområdet under de vanligaste alternativen för att arbeta med PowerPointoch klicka sedan på OK.

  3. På sidan säkerhets Center under makro inställningarväljer du inaktivera alla makron med aviseringaroch klicka sedan på OK.

  4. Klicka på ÖppnaOffice -menyn.

  5. Klicka på pilen i list rutan fil format och välj PowerPoint-tillägg (. PPAM;. PPA), Välj tillägget och klicka på öppna.

    Anteckning

    Tillägget läses inte in som förväntat.

  6. Klicka på makro säkerhet i gruppen kod på fliken utvecklare .

  7. På sidan säkerhets Center väljer du Aktivera alla makron (rekommenderas inte, kod som eventuellt är skadlig kan köras) under makro inställningaroch klicka sedan på OK.

  8. Klicka på ÖppnaOffice -menyn.

  9. Klicka på pilen i list rutan fil format och välj PowerPoint-tillägg (. PPAM;. PPA), Välj tillägget och klicka på öppna.

    Anteckning

    Du tillfrågas inte om du vill aktivera eller inaktivera makrot. Dessutom laddas inte tillägget ändå.

PowerPoint 2002

  1. Starta PowerPoint.

  2. På menyn Verktyg pekar du på makro och klickar sedan på säkerhet.

  3. Klicka på hög på fliken säkerhets nivå.

  4. Klicka på öppna på Arkiv-menyn.

  5. Klicka på pilen i rutan fil format , Välj PowerPoint-tillägg, Välj tillägget och klicka sedan på öppna.

    Anteckning

    Tillägget läses inte in som förväntat.

  6. På menyn Verktyg pekar du på makro och klickar sedan på säkerhet.

  7. Klicka på medium på fliken säkerhets nivå.

  8. Klicka på öppna på Arkiv-menyn.

  9. Klicka på pilen i rutan fil format , Välj PowerPoint-tillägg, Välj tillägget och klicka sedan på öppna.

    Anteckning

    Du tillfrågas inte om du vill aktivera eller inaktivera makrot och tillägget laddas fortfarande inte.