"Det går inte att återställa användarens lösenord" när en administratör återställer lösenordet för en domänmedlems användare
Anteckning
Office 365 ProPlus byter namn till Microsoft 365-appar för företag. Mer information om den här ändringen finns i det här blogginlägget.
Problem
Tänk dig följande scenario: En användare kan inte logga in på en Microsoft-molntjänst som Office 365, Microsoft Azure eller Microsoft Intune med hjälp av ett användar-ID som är medlem i en molntjänstdomän som tidigare konfigurerades för enkel inloggning (SSO). I det här scenariot får administratören följande felmeddelande när en molntjänstadministratör försöker återställa användarens lösenord med hjälp av molntjänstportalen eller Azure Active Directory-modulen för Windows PowerShell:
Det går inte att återställa användarens lösenord. Försök igen senare.
Orsak
Det här problemet inträffar om användaren är medlem i en molntjänstdomän som tidigare var enkel inloggningsaktiverad (SSO) och om användar-ID:t inte konverterats till standardautentisering.
Det här problemet kan till exempel uppstå om följande Windows PowerShell-cmdlet användes:
convert-MSOLDomainToStandard –skipuserconversion:$true
Lösning
Lös problemet genom att konvertera användar-ID:t till en standardtyp (icke-federerad). Gör så här:
- Skriv in följande cmdlet i samma Windows PowerShell-konsol som du använde för att verifiera problemet och tryck sedan på Retur:
Convert-MsolFederatedUser -userprincipalname < user ID >
Anteckning
I den här cmdleten representerar platshållaren <användar-ID> användar-ID:t.
- Ge användaren ett tillfälligt lösenord. Nästa gång användaren loggar in på molntjänsten måste de ändra sitt tillfälliga lösenord innan de kan komma åt molntjänstresurser.
Mer information
Anteckning
För Windows PowerShell-cmdletarna i den här artikeln krävs Azure Active Directory-modulen för Windows PowerShell.
Behöver du fortfarande hjälp? Gå till Microsoft Community eller webbplatsen för Azure Active Directory-forumen.