Det går inte att hitta ditt digitala ID-namn när du dekrypterar ett meddelande med hjälp av ett 3DES-certifikat

Ursprungligt KB-nummer: 4459215

Symptom

När du öppnar ett krypterat e-postmeddelande i Microsoft Outlook med hjälp av ett certifikat som bara har 3DES-krypteringsfunktioner får du följande felmeddelande:

Ditt digitala ID-namn kan inte hittas av det underliggande säkerhetssystemet

Orsak

Från och med Outlook build 16.0.8518.1000 uppgraderade Microsoft standardåterställningsalgoritmen från 3DES till AES256. I det problem som nämns i avsnittet Symptom skickas det krypterade e-postmeddelandet av en användare som använder den här Outlook-versionen eller en senare version.

Åtgärd

Viktigt

Följ stegen i det här avsnittet noggrant. Det kan uppstå allvarliga problem om du gör felaktiga ändringar i registret. Innan du ändrar det bör du först säkerhetskopiera registret för att kunna återställa det om problem skulle uppstå.

För att lösa det här problemet rekommenderar vi att du krypterar meddelanden med hjälp av ett certifikat som har AES256-krypteringsfunktioner eller högre.

Om du måste använda 3DES-krypteringsalgoritmen kan du lägga till följande registervärden på avsändarens dator:

HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Security

DWORD = UseAlternateDefaultEncryptionAlg
Värde = 1

String = DefaultEncryptionAlgOID
Värde = 1.2.840.113549.3.7

Obs!

Det angivna strängvärdet visar OID för 3DES-krypteringsalgoritmen.

Mer information

Certifikatet som avsändaren använde för att kryptera e-postmeddelandet innehåller SMIMECapabilities inte attributet . Det innebär att Outlook inte kunde fastställa mottagarens funktioner i förväg. Därför valde den en allmänt accepterad säker algoritm.

Mer information finns i avsnittet 2.5.2 SMIME Capabilities Attribute i IETF (Internet Engineering Task Force) RFC 5751: