Överbliven post för PowerPivot-tjänstprogramdatabas

Den här artikeln skrevs av Zakir Haveliwala, senior supporteskaleringstekniker.

Symptom

Du kan få följande fel i Loggarna för Windows Loggboken eller SharePoint Unified Logging Service (ULS):

Det går inte att öppna databasen "Databasnamn för PowerPivot Service-program" som begärdes vid inloggningen. Inloggningen misslyckades. Inloggningen misslyckades för användaren "användarnamn".

Orsak

Detta är en indikation på en överbliven post om PowerPivot-tjänstprogramdatabasen i SharePoint. Det här problemet kan inträffa när du har tagit bort ett PowerPivot-tjänstprogram. Posterna för den borttagna PowerPivot-tjänstprogramdatabasen tas ibland inte bort från SharePoint-konfigurationsdatabasen. Därför genererar SharePoint ett fel när det inte går att öppna PowerPivot-tjänstprogramdatabasen eftersom den inte längre finns.

Åtgärd

Åtgärda problemet genom att ta bort dessa överblivna poster. Du kan öppna SharePoint Management Shell på en SharePoint-server och köra följande kommando:

Get-SPDatabase | där {$_.exists -eq $false}

Då visas en lista över de databaser som inte längre finns på SharePoint-databasservern. Den PowerPivot-databas som refereras till i föregående fel bör visas i den här listan. När du har bekräftat detta kan du ta bort den överblivna posten genom att köra det här kommandot:

Get-SPDatabase | där {$.exists -eq $false} | foreach {$.delete()}

Sedan tas den överblivna posten som pekar på den gamla PowerPivot-tjänstprogramdatabasen bort och felet som du märkte tidigare kommer att sluta att uppstå.