HoloLens (första generationen) Basics 100: Komma igång med Unity

Viktigt

Självstudierna Mixed Reality Academy har utformats med HoloLens (1:a gen), Unity 2017 och Mixed Reality Immersive Headsets i åtanke. Därför anser vi att det är viktigt att lämna de här självstudierna på plats för utvecklare som fortfarande letar efter vägledning i utvecklingen för dessa enheter. De här självstudierna uppdateras inte med de senaste verktygen eller interaktionerna som används för HoloLens 2 och kanske inte är kompatibla med nyare versioner av Unity. De kommer att finnas kvar för att fortsätta arbeta med de enheter som stöds. En ny serie självstudier har publicerats för HoloLens 2.

I den här självstudien får du lära dig hur du skapar en grundläggande mixed reality-app som skapats med Unity.

Stöd för enheter

Kurs HoloLens Integrerande headset
MR Basics 100: Komma igång med Unity ✔️ ✔️

Förutsättningar

Kapitel 1 – Skapa en ny Project

Om du vill skapa en app med Unity måste du först skapa ett projekt. Det här projektet är indeat i några mappar, varav den viktigaste är mappen Assets. Det här är den mapp som innehåller alla tillgångar som du importerar från verktyg för att skapa digitalt innehåll, till exempel Maya, Max Valfri 4D eller Gör, all kod som du skapar med Visual Studio eller din favoritkodredigerare och val annat antal innehållsfiler som Unity skapar när du skapar scener, animeringar och andra Unity-tillgångstyper i redigeraren.

För att skapa och distribuera UWP-appar kan Unity exportera projektet som en Visual Studio lösning som innehåller alla nödvändiga tillgångs- och kodfiler.

  1. Starta Unity
  2. Välj Ny
  3. Ange ett projektnamn (t.ex. "MixedRealityIntroduction")
  4. Ange en plats för att spara projektet
  5. Kontrollera att 3D-växlingsknappen är markerad
  6. Välj Skapa projekt

Grattis! Nu är du konfigurerad för att komma igång med dina anpassningar av mixad verklighet.

Kapitel 2 – Konfigurera kameran

Unity Main Camera hanterar huvudspårning och stereorendering. Det finns några ändringar att göra i huvudkameran för att använda den med mixad verklighet.

  1. Välj File > New Scene (Ny scen)

Först blir det enklare att placera ut din app om du tänker dig användarens startposition som (X: 0, Y: 0, Z: 0). Eftersom huvudkameran spårar förflyttning av användarens huvud kan användarens startposition anges genom att ange startpositionen för huvudkameran.

  1. Välj Huvudkamera i hierarkipanelen
  2. I kontrollpanelen hittar du komponenten Transformera och ändrar Position från (X: 0, Y: 1, Z: -10) till (X: 0, Y: 0, Z: 0)

För det andra behöver du tänka på bakgrundskameran som är standard.

För HoloLens program bör den verkliga världen visas bakom allt som kameran återger, inte en Skybox-struktur.

  1. När huvudkameran fortfarande är markerad i panelen Hierarki hittar du kamerakomponenten i kontrollpanelen och ändrar listrutan Rensa flaggor från Skybox till Solid Color.
  2. Välj färgväljaren Bakgrund och ändra RGBA-värdena till (0, 0, 0, 0)

För program med mixad verklighet som riktar sig till integrerande headset kan vi använda Standard-Skybox-strukturen som Unity tillhandahåller.

  1. När huvudkameran fortfarande är markerad i panelen Hierarki hittar du kamerakomponenten i kontrollpanelen och behåller listrutan Clear Flags (Rensa flaggor) i Skybox.

För det tredje ska vi titta på det nära klippplanet i Unity och förhindra att objekt återges för nära användarnas ögon när en användare närmar sig ett objekt eller ett objekt närmar sig en användare.

För HoloLens program kan nära klippplanet ställas in på den HoloLens rekommenderade 0,85 meter.

  1. När huvudkameran fortfarande är markerad i hierarkipanelen hittar du kamerakomponenten i kontrollpanelen och ändrar fältet Nära klippplanet från standardvärdet 0,3 till HoloLens 0,85.

För mixed reality-program som riktar sig till integrerande headset kan vi använda standardinställningen som Unity tillhandahåller.

  1. Med huvudkameran fortfarande markerad i panelen Hierarki hittar du kamerakomponenten i kontrollpanelen och behåller fältet Nära klippplanet till standardvärdet 0,3.

Låt oss slutligen spara våra framsteg så här långt. Om du vill spara scenändringarna väljer du Arkiv > Spara scen som, ger scenen namnet Main och väljer Spara.

Kapitel 3 – Konfigurera Project Inställningar

I det här kapitlet anger vi några Unity-projektinställningar som hjälper oss att rikta in Windows Holographic SDK för utveckling. Vi kommer också att ange vissa kvalitetsinställningar för vårt program. Slutligen ser vi till att våra byggmål är inställda på Universal Windows Platform.

Prestanda- och kvalitetsinställningar för Unity

Unity-kvalitetsinställningar för HoloLens

Unity-kvalitetsinställningar för HoloLens

Eftersom det är så viktigt att ha HoloLens hög bildrutehastighet vill vi ha kvalitetsinställningarna finjusterade för snabbaste prestanda. Mer detaljerad prestandainformation finns i Prestandarekommendationer för Unity.

  1. Välj Redigera > Project Inställningar > Kvalitet
  2. Välj listrutan under Universal Windows Platform-logotypen och välj Mycket låg. Du vet att inställningen tillämpas korrekt när rutan i kolumnen Universal Windows Platform och Raden Mycket låg är grön.

För program med mixad verklighet som är riktade mot ockluderade skärmar kan du lämna standardvärdena för kvalitetsinställningarna.

Sdk för Windows 10 mål

Mål-WINDOWS Holographic SDK

Mål-WINDOWS Holographic SDK

Vi måste meddela Unity att appen som vi försöker exportera ska skapa en integrerande vy i stället för en 2D-vy. Vi gör detta genom att aktivera stöd för Virtual Reality på Unity med Windows 10 SDK.

  1. Gå till Redigera > Project Inställningar > Player.
  2. Välj ikonen Universal Windows Platform på panelen Inställningar Player.
  3. Expandera XR-Inställningar gruppen.
  4. I avsnittet Rendering markerar du kryssrutan Virtual Reality Supported (Virtuell verklighet stöds) för att lägga till en ny VIRTUAL Reality-LISTA.
  5. Kontrollera Windows Mixed Reality visas i listan. Annars väljer du + knappen längst ned i listan och väljer Windows Mixed Reality.

Anteckning

Om du inte ser ikonen Universal Windows Platform kontrollerar du att du har valt Universal Windows Platform Build Support under installationen. Annars kan du behöva installera om Unity med rätt Windows installation.

Bra jobbat med att få alla projektinställningar tillämpade. Nu ska vi lägga till ett hologram!

Kapitel 4 – Skapa en kub

Att skapa en kub i ditt Unity-projekt är precis som att skapa andra objekt i Unity. Det är enkelt att placera en kub framför användaren eftersom Unitys koordinatsystem mappas till den verkliga världen – där en mätare i Unity är ungefär en mätare i den verkliga världen.

  1. I det övre vänstra hörnet på panelen Hierarki väljer du listrutan Skapa och väljer 3D-objekt > Kub.
  2. Välj den nyligen skapade kubenpanelen Hierarki
  3. I Kontroll hittar du komponenten Transformera och ändrar Position till (X: 0, Y: 0, Z: 2). Då placeras kuben 2 meter framför användarens startposition.
  4. I transformeringskomponenten ändrar du Rotation till (X: 45, Y: 45, Z: 45) och ändrar Skala till (X: 0,25, Y: 0,25, Z: 0,25). Detta skalar kuben till 0,25 meter.
  5. Om du vill spara scenändringarna väljer du Arkiv > Spara scen.

Kapitel 5 – Verifiera på enheten från Unity-redigeraren

Nu när vi har skapat vår kub är det dags att göra en snabb incheckning på enheten. Du kan göra detta direkt från Unity-redigeraren.

Inledande konfiguration

  1. Öppna Fönstret File > Build Inställningar (Skapa Inställningar) i Unity på utvecklingsdatorn.
  2. Ändra Plattform till Universal Windows Platform och klicka på Växla plattform

För HoloLens unity-fjärrkommunikation

  1. Installera och HoloLens Holographic Remoting Playerpå din dator, som är tillgänglig från Windows Store. Starta programmet på enheten och ange ett väntetillstånd och visa IP-adressen för enheten. Anteckna IP-adressen.
  2. Öppna Window > XR > Holographic Emulation.
  3. Ändra emuleringsläge från Ingen till Fjärr till Enhet.
  4. I Fjärrdator anger du IP-adressen för den HoloLens du antecknade tidigare.
  5. Klicka på Anslut.
  6. Se till att Anslutningsstatus ändras till grönt Ansluten.
  7. Nu kan du klicka på Spela upp i Unity-redigeraren.

Nu kan du se kuben i enheten och i redigeraren. Du kan pausa, inspektera objekt och felsöka precis som när du kör en app i redigeraren, eftersom det i princip är vad som händer, men med video, ljud och enhetsindata som överförs fram och tillbaka över nätverket mellan värddatorn och enheten.

För andra headset som stöds av mixad verklighet

  1. Anslut till utvecklingsdatorn med hjälp av USB-kabeln och HDMI- eller skärmportskabeln.
  2. Starta Portalen för Mixad verklighet och se till att du har slutfört den första körningen.
  3. Från Unity kan du nu trycka på uppspelningsknappen.

Du kommer nu att kunna se kubåtergivningen i ditt headset för mixad verklighet och i redigeraren.

Kapitel 6 – Skapa och distribuera till enhet från Visual Studio

Nu är vi redo att kompilera projektet för Visual Studio distribuera till målenheten.

Exportera till Visual Studio lösningen

  1. Öppna fönstret > Skapa Inställningar fil.
  2. Klicka på Lägg till öppna scener för att lägga till scenen.
  3. Ändra Plattform till Universal Windows Platform och klicka på Växla plattform.
  4. I inställningarna för Universal Windows Platform ser du till att SDK är Universal 10.
  5. För Målenhet lämnar du till Valfri enhet för ockluderade skärmar eller växlar till HoloLens.
  6. UWP-byggtyp ska vara D3D.
  7. UWP SDK kan vara kvar på Senaste installerade.
  8. Klicka på Skapa.
  9. I Utforskaren klickar du på Ny mapp och ger mappen namnet "App".
  10. När mappen App är markerad klickar du på knappen Välj mapp.
  11. När Unity har byggts klart visas Windows Utforskaren fönster.
  12. Öppna mappen App i Utforskaren.
  13. Öppna den genererade Visual Studio (MixedRealityIntroduction.sln i det här exemplet)

Kompilera Visual Studio lösningen

Slutligen kompilerar vi den exporterade Visual Studio, distribuerar den och provar den på enheten.

  1. Använd det översta verktygsfältet i Visual Studio ändra målet från Felsök till Version och från ARM till X86.

Anvisningarna skiljer sig åt för att distribuera till en enhet jämfört med emulatorn. Följ anvisningarna som matchar din konfiguration.

Distribuera till en enhet med mixad verklighet via Wi-Fi

  1. Klicka på pilen bredvid knappen Lokal dator och ändra distributionsmålet till Fjärrdator.
  2. Ange IP-adressen för din enhet med mixad verklighet och ändra Autentiseringsläge till Universal (Okrypterat protokoll) för HoloLens och Windows för andra enheter.
  3. Klicka på > starta utan att felsöka.

Om HoloLens det här är första gången du distribuerar till din enhet måste du parkoppla med hjälp av Visual Studio.

Distribuera till enhet med mixad verklighet via USB

Kontrollera att enheten är ansluten via USB-kabeln.

  1. För HoloLens klickar du på pilen bredvid knappen Lokal dator och ändrar distributionsmålet till Enhet.
  2. Om du vill rikta in ockluderade enheter som är anslutna till datorn behåller du inställningen till Lokal dator. Kontrollera att du har Portalen för Mixad verklighet igång.
  3. Klicka på > starta utan att felsöka.

Distribuera till Emulator

  1. Klicka på pilen bredvid knappen Enhet och välj i listrutan HoloLens Emulator.
  2. Klicka på > starta utan att felsöka.

Testa din app

Nu när appen har distribuerats kan du prova att flytta runt kuben och se att den finns kvar i världen framför dig.

Se även