Windows stop error - 0x0000007E system thread exception not handled

This article provides steps to resolve issues in which the guest operating system (guest OS) encounters a problem and tries to restart your Azure virtual machine (VM). Additionally, you receive the following error message:

A system thread exception wasn't handled.

Symptoms

When you use boot diagnostics to view a screenshot of the VM output, you notice that Windows has to restart after it returns either a "SYSTEM THREAD EXCEPTION NOT HANDLED" stop code or a "0x0000007E" error code.

Screenshot shows the (Your PC ran into a problem and needs to restart. We'll restart for you) message and a SYSTEM THREAD EXCEPTION NOT HANDLED stop code.

Cause

The cause of this issue can't be determined until a memory dump file is analyzed. Continue to collect the memory dump file.

Solution

Tip

If you have a recent backup of the VM, you can try to restore the VM from the backup to fix the restart problem.

To resolve this problem, gather a memory dump file for the incident and send the file to Microsoft Support. To collect the dump file, follow the instructions in the next sections.

Part 1: Attach the OS disk to a recovery VM
  1. Take a snapshot of the OS disk of the affected VM to create a backup. For more information, see Create a snapshot of a virtual hard disk.

  2. Attach the OS disk to a recovery VM.

  3. Use remote desktop protocol (RDP) to connect remotely to the recovery VM.

  4. If the OS disk of the affected VM is encrypted, turn off encryption before you go to the next step. For more information, see Decrypt the encrypted OS disk.

Part 2: Locate the dump file and submit a support ticket
  1. On the recovery VM, go to the Windows folder on the attached OS disk. For example, if the drive letter that's assigned to the attached OS disk is F, go to F:\Windows.

  2. Locate the Memory.dmp file, and then submit a support ticket and attach the dump file.

Note

If you're having trouble locating the Memory.dmp file, you can try to use non-maskable interrupt (NMI) calls in the serial console instead. You can use this guidance to generate a crash dump file by using NMI calls.

Next steps

Contact us for help

If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.