Microsoft Dynamics CRM电子邮件路由器不会在Microsoft Dynamics CRM队列中创建电子邮件

本文解决了Microsoft Dynamics CRM电子邮件路由器未在Microsoft Dynamics CRM队列中创建电子邮件的问题。

适用于:Microsoft Dynamics CRM 2011、Exchange Server 2010 Enterprise、Exchange Server 2010 Standard、Microsoft Exchange Server 2003 Enterprise Edition、Microsoft Exchange Server 2003 Standard Edition
原始 KB 编号: 921193

症状

收到Microsoft Dynamics CRM的电子邮件时,Microsoft Dynamics CRM电子邮件路由器不会在Microsoft Dynamics CRM队列中创建电子邮件。

此外,在运行Microsoft Dynamics CRM电子邮件路由器的服务器的事件日志中记录了警告事件。

原因

当队列的电子邮件地址与邮箱的 SMTP 主地址不匹配时,会出现此问题。

解决方案

若要解决此问题,请更改队列的电子邮件地址以匹配邮箱的 SMTP 主地址。 为此,请按照下列步骤操作:

  1. 确定邮箱的 SMTP 主地址。

    若要在 Microsoft Exchange Server 2007 或 Microsoft Exchange Server 2010 中执行此操作,请执行以下步骤:

    1. 以域管理员身份登录到运行 Exchange Server 的服务器。
    2. 依次选择“开始”、“所有程序”、“Microsoft Exchange 2007 或 Microsoft Exchange Server 2010”,然后选择“Exchange 管理控制台”。
    3. 展开 “收件人配置”,然后选择“ 邮箱”。
    4. 找到用作队列邮箱的邮箱。
    5. 右键单击邮箱,然后选择“ 属性”。
    6. 在“ 电子邮件地址 ”选项卡上,记下 SMTP 地址 (粗体) 。

    若要在 Microsoft Exchange Server 2003 中执行此操作,请执行以下步骤:

    1. 以域管理员身份登录到运行 Exchange Server 的服务器。
    2. 选择“开始”,指向“所有程序”,指向“Microsoft Exchange”,然后选择“Active Directory 用户和计算机”。
    3. 找到用作队列邮箱的邮箱。
    4. 右键单击邮箱,然后选择“ 属性”。
    5. 在“ 电子邮件地址 ”选项卡上,记下 SMTP 地址 (粗体) 。
  2. 在 2011 Microsoft Dynamics CRM 更改队列的电子邮件地址。

    1. 以系统管理员身份登录 Microsoft Dynamics CRM。
    2. 依次选择“设置”、“业务管理”、“队列”。
    3. 打开Microsoft Dynamics CRM队列。
    4. “电子邮件 ”框中,将电子邮件地址更改为步骤 1 中确定的电子邮件地址。
    5. 选择工具栏上的“ 批准电子邮件 ”按钮。 仅当“系统设置”设置为“仅处理已批准队列的电子邮件”时,才需要执行此步骤。