尝试安装 Microsoft Dynamics 365 App for Outlook 时的 GeneralIncomingEmailServerError

本文提供了在尝试安装 Microsoft Dynamics 365 App for Outlook 时可能会收到 GeneralIncomingEmailServerError 错误的问题的解决方法。

适用范围:Microsoft Dynamics CRM
原始 KB 编号: 4019040

症状

尝试安装 Microsoft Dynamics 365 App for Outlook 时,遇到以下错误:

尝试将应用添加到 Outlook 时出现问题。

SoapException:GeneralIncomingEmailServerError

如果选择“ 详细信息” 链接,将显示以下其他详细信息:

错误:System.Web.Services.Protocols.SoapException:指定的服务器版本无效。 at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse (SoapClientMessage 消息,WebResponse 响应, System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke (IAsyncResult 上的 Stream responseStream、Boolean asyncCall) asyncResult) microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndInstallApp (IAsyncResult asyncResult) at Microsoft.Crm.Asynchronous.EmailConnector.OfficeAppsDeploymentStep.EndCall () Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation ()

原因

如果使用本地 Exchange,并且版本不符合要求,则可能会出现此错误。

解决方案

验证你正在使用的本地 Exchange 版本是否满足 Microsoft Exchange 支持的配置中所述的要求。

注意

如果用户的邮箱位于受支持的 Microsoft Exchange 版本上,但组织已从早期版本的 Exchange(如 Exchange Server 2010)迁移,则如果未迁移系统邮箱,则可能会出现此错误。 有关移动系统邮箱的详细信息,请参阅 将 Exchange 2010 系统邮箱移动到 Exchange 2013