Smtp 服务器返回 530 MustIssueStartTlsFirst 在使用 Server-Side 同步时发生异常

本文可帮助你修复在 Microsoft Dynamics 365中使用与 POP3/SMTP 配置文件 Server-Side 同步时出现“Smtp 服务器返回 530 MustIssueStartTlsFirst 异常”错误的问题。

适用于:2016 Microsoft Dynamics CRM
原始 KB 编号: 3214706

症状

在以前称为 Dynamics CRM Online) 的 Dynamics 365 (中测试和启用邮箱时,在“警报”区域中遇到以下错误之一:

无法发送电子邮件“测试邮件”,因为在与电子邮件服务器建立安全连接时出错。 邮箱 <邮箱名称> 未同步。 已通知电子邮件服务器配置文件<的所有者Email服务器配置文件名称>。

Email服务器错误代码:Smtp 服务器返回 530 MustIssueStartTlsFirst 异常。

ActivityId: <GUID>
>错误:System.Net.Mail.SmtpException:SMTP 服务器需要安全连接或客户端未进行身份验证。 服务器响应为:5.5.1 需要身份验证。 了解详细信息,请参阅
at System.Net.Mail.SendMailAsyncResult.End (IAsyncResult 结果)
at System.Net.Mail.SmtpTransport.EndSendMail (IAsyncResult 结果)
at System.Net.Mail.SmtpClient.SendMailCallback (IAsyncResult 结果)

无法接收邮箱<的Email邮箱名称>。 请确保邮箱中指定的凭据正确无误,并且有足够的权限来接收电子邮件。 然后,启用邮箱以处理电子邮件。

无法接收邮箱<的Email邮箱名称>。 请确保邮箱中指定的凭据正确无误,并且有足够的权限来接收电子邮件。 然后,启用邮箱以处理电子邮件。

原因

如果使用 POP3/SMTP 电子邮件服务器配置文件,并且存在以下问题之一,则可能会出现此错误:

  1. 用户名或密码不正确。
  2. 如果使用 Gmail,则会禁用允许安全性较低的应用的选项。

解决方案

  1. 验证Dynamics 365邮箱记录上的“用户名”和“密码”值是否正确。 此错误包括指向 Dynamics 365 中的邮箱记录的链接。

  2. 如果使用 Gmail,请验证是否已启用 “允许安全性较低的应用” 选项:

    & Google 帐户安全度较低的应用

更改上述任何设置后,再次单击邮箱记录上的“测试和启用”。

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