选择“在 Microsoft Dynamics CRM中跟踪”时,你无权访问这些记录错误

本文为在 Outlook 的 Microsoft Dynamics CRM 内选择“在Microsoft Dynamics CRM中跟踪”时出现的“你无权访问这些记录”错误提供了解决方法。

适用于:2015 Microsoft Dynamics CRM、Microsoft Dynamics CRM 2016
原始 KB 编号: 3140750

症状

在 Outlook Microsoft Dynamics CRM 内选择“跟踪Microsoft Dynamics CRM”时,失败并出现以下错误:

您无权访问这些记录。 请与Microsoft Dynamics CRM管理员联系。

原因

Microsoft Dynamics CRM中的用户记录缺少对记录创建和更新规则实体的读取访问权限。 Microsoft 已意识到此问题,并计划提供修补程序,因此无需此权限即可跟踪电子邮件。 在此期间,可以使用“解决方法”部分中提供的解决方法。

解决方案

以具有系统管理员角色的用户身份登录Microsoft Dynamics CRM。 找到分配给用户的安全角色。 在安全角色的“ 服务管理 ”选项卡上,授予“记录创建和更新规则”实体的读取访问权限。

更多信息

如果捕获客户端 CRM 跟踪,则会记录以下信息:

主体用户 (Id={GUID},type=8) 缺少 prvReadConvertRule 特权 (Id=<GUID>) 2015-08-21T15:27:32.0596285Z