尝试80040203 (Microsoft Dynamics 365 时) 参数无效"错误发生
本文提供了一个解决方案,用于解决尝试将解决方案导入 Microsoft Dynamics 365 时发生的错误。
适用于: Microsoft Dynamics 365 Customer Engagement Online
原始 KB 编号: 4514229
症状
尝试在 Dynamics 365 中导入解决方案时,会收到以下错误消息:
"解决方案导入: <Solution Name> 失败。
错误代码80040203。"
原因
导致此错误的原因有多种。 如果错误对话框引用了以下类型的对象,请查看本文的其余部分,寻找可能的解决方案:
类型: 关系
名称:bpf_<entity>_<publisher>_<BPF Name>
下载打开到"组件"页时将显示的日志文件:
ItemType:实体关系
名称:bpf_<entity>_<publisher>_<BPF Name>
ErrorCode: 0x80040203
ErrorText:id 的属性显示名称 <GUID> :、objectcolumn:DisplayName 和 labelTypeCode:未指定属性
实体关系的名称将是实体的串联和 BPF Flow (业务流程) 。 该实体之前已从 BPF 阶段中删除,并替换为其他 Entity,然后 BPF 已更新,同时仍被激活。 实体已从 BPF 中删除,但关系仍存在于架构中。 因此,它将随解决方案一起从源导出。 此关系导致显示错误。
解决方案
Microsoft 已注意到此问题,正在进行更改,以在删除然后更新后删除此关系。
此问题有两种解决方法:
选项 1 - 更新解决方案文件
如果需要导入解决方案,但无法重新创建解决方案包,请从解决方案中删除关系。
解压缩解决方案。
编辑customization.xml。
搜索错误中提到的关系:bpf_<entity>_<publisher>_<BPF Name>
删除 EntityRelationship 的所有 XML:
<EntityRelationship Name="bpf_<entity>_<publisher>_<BPF Name>"> ... </EntityRelationship>
保存此文件。
压缩整个目录。
再次导入解决方案。
选项 2 - 从源中删除关系并重新创建解决方案
这是一个长期解决方案,将修复下一次导出解决方案时的问题。
打开源组织。
选择 设置 / / 自定义系统
选择关系中的实体:
bpf_<entity>_<publisher>_<BPF Name>
展开 "1:N 关系"。
找到关系:
bpf_<entity>_<publisher>_<BPF Name>
选择并删除关系。
发布 所有自定义。
导出解决方案,将其导入目标。