重新启动计算机时,计算机停止响应,或"应用计算机设置"屏幕显示的时间超过预期

本文提供了一种解决方案,可解决计算机停止响应或"应用计算机设置"屏幕出现的时间超过预期时间的问题。

适用于:  WindowsServer 2003
原始 KB 编号:   905716

症状

重新启动基于 Windows Server 2003 的计算机或基于 Windows 2000 Server 的计算机时,您遇到以下症状之一:

  • 在启动期间,将显示"应用计算机设置"屏幕,并且计算机停止响应。

  • 在启动期间,将显示"应用计算机设置"屏幕,并保留超过预期时间。

  • 在启动期间,在登录屏幕出现之前,将出现一个闪烁指针的蓝色屏幕,并且计算机停止响应。

  • 网络连接文件夹为空。

  • 无法打开"控制面板 "中的 "添加或删除程序"项。

  • APC 代理在启动时停止响应。

  • 无法启动或停止服务。

  • 服务器对图形用户界面和 GUI 函数 (响应) 缓慢。

  • 尝试打开磁盘管理时,将收到以下消息之一:

    等待连接

    连接到逻辑磁盘管理器服务
    磁盘管理从不打开。

  • 应用安全修补程序时,无论是Windows更新还是手动应用,系统都停止"检查配置"。

原因

出现此问题的原因是版本 6 有问题。aPC PowerChute Business Edition Software 的 x。

APC 已就此问题发布了以下正式声明:

APC 6.x 软件使用 Sun Microsystems Java Cryptography Extension (JCE) 1.2.1 程序包。 用于对 JCE 1.2.1 jar 文件进行签名的数字证书于 2005 年 7 月 27 日过期。 因此,系统会导致上述详细症状。

解决方案

若要解决此问题,请按照以下步骤操作:

  1. 以以下模式保险箱计算机:

    1. 重启计算机。 当出现"Please select the operating system to start"消息时,按 F8。

    2. Windows选项菜单"下,使用箭头键选择"保险箱 模式",然后按 Enter。

      备注

      NUM LOCK 必须关闭,数字键盘上的箭头键才能正常工作。

    3. 如果在计算机上运行其他操作系统,请使用箭头键选择您需要的操作系统,然后按 Enter。

  2. 以本地管理员身份登录到计算机。

  3. 禁用 APCPBEAgent 服务和 APCPBEServer 服务:

    1. 单击 "开始",指向 "程序",指向"管理工具",然后单击"服务 "。
    2. 在右侧窗格中,右键单击 "APCPBEAgent", 然后单击"属性 "。
    3. 在"启动类型" 列表中,单击以选择"已禁用", 然后单击"确定 "。
    4. 在右侧窗格中,右键单击 "APCPBEServer", 然后单击"属性 "。
    5. 在"启动类型" 列表中,单击以选择"已禁用", 然后单击"确定 "。
  4. 重启计算机。

  5. 安装最新版本的 APC PowerChute 软件。 若要详细了解如何获取 PowerChute Business Edition 版本 6 的更新。 x 软件,请访问 APC 网站

解决方法

若要解决此问题,请重新注册Msiexec.exe。 为此,请单击"开始 ", 再单击 "运行",键入 msiexec /regserver ,然后单击"确定 "。

更多信息

本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 对于这些产品的性能或可靠性,Microsoft 不作任何暗示保证或其他形式的保证。

Microsoft 提供了第三方联系信息,以便你寻求技术支持。 该联系信息如有更改,恕不另行通知。 Microsoft 不保证此第三方联系信息的准确性。

APC PowerChute Business Edition v6 使用 Sun Java运行时引擎,该引擎于 2005 年 7 月 27 日从服务过期。 APC 现在使用 PowerChute Business Edition 来通信和管理 UPS (不间断电源和电池) 系统。