重启计算机时,计算机停止响应,或者“应用计算机设置”屏幕显示的时间比预期的时间长

本文提供了计算机停止响应或“应用计算机设置”屏幕显示时间比预期更长的问题的解决方案。

适用于: Windows Server 2003
原始 KB 编号: 905716

症状

重启基于 Windows Server 2003 的计算机或基于 Windows 2000 Server 的计算机时,会遇到以下症状之一:

  • 在启动期间,将显示“正在应用计算机设置”屏幕,并且计算机停止响应。

  • 在启动期间,将显示“应用计算机设置”屏幕,并且其保留时间比预期更长。

  • 在启动期间,在登录屏幕出现之前,将显示具有闪烁指针的蓝屏,并且计算机停止响应。

  • “网络连接”文件夹为空。

  • 无法在 控制面板 中打开“添加或删除程序”项。

  • APC 代理在启动时停止响应。

  • 无法启动或停止服务。

  • 服务器响应图形用户界面 (GUI) 函数。

  • 尝试打开磁盘管理时,会收到以下消息之一:

    正在等待连接

    连接到逻辑磁盘管理器服务
    磁盘管理永远不会打开。

  • 应用安全修补程序时,无论是从Windows 更新还是手动应用,系统在“检查配置”处停止。

原因

出现此问题的原因是版本 6 存在问题。APC PowerChute Business Edition Software 的 x。

APC 已就此问题发表了以下官方声明:

APC 6.x 软件使用 Sun Microsystems Java 加密扩展 (JCE) 1.2.1 包。 用于对 JCE 1.2.1 jar 文件进行签名的数字证书已于 2005 年 7 月 27 日过期。 因此,系统会导致上述详细症状。

解决方案

要解决此问题,请按照下列步骤操作:

  1. 在安全模式下重启计算机:

    1. 重启计算机。 出现“请选择要启动的操作系统”消息时,按 F8。

    2. “Windows 高级选项菜单”下,使用箭头键选择“ 安全模式”,然后按 Enter。

      注意

      NUM LOCK 必须关闭,数字键盘上的箭头键才能起作用。

    3. 如果在计算机上运行其他操作系统,请使用箭头键选择所需的操作系统,然后按 Enter。

  2. 以本地管理员身份登录到计算机。

  3. 禁用 APCPBEAgent 服务和 APCPBEServer 服务:

    1. 单击 “开始”,指向 “程序”,指向 “管理工具”,然后单击“ 服务”。
    2. 在右窗格中,右键单击“ APCPBEAgent”,然后单击“ 属性”。
    3. “启动类型 ”列表中,单击以选择“ 已禁用”,然后单击“ 确定”。
    4. 在右窗格中,右键单击“ APCPBEServer”,然后单击“ 属性”。
    5. “启动类型 ”列表中,单击以选择“ 已禁用”,然后单击“ 确定”。
  4. 重启计算机。

  5. 安装最新版本的 APC PowerChute 软件。 有关如何获取 PowerChute Business Edition 版本 6 更新的详细信息。 x software,请访问 APC 网站

解决方法

若要解决此问题,请重新注册 Msiexec.exe。 为此,请单击“ 开始”,单击“ 运行”,键入 msiexec /regserver,然后单击“ 确定”。

更多信息

本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 对于这些产品的性能或可靠性,Microsoft 不作任何暗示保证或其他形式的保证。

Microsoft 提供了第三方联系信息,以便你寻求技术支持。 该联系信息如有更改,恕不另行通知。 Microsoft 不保证此第三方联系信息的准确性。

APC PowerChute Business Edition v6 使用 2005 年 7 月 27 日从服务过期的 Sun Java 运行时引擎。 APC 现在使用 PowerChute Business Edition 来通信和管理 UPS (不间断电源和电池备份) 系统。