无法使用 Outlook 在 Exchange Server 2010 服务器上打开邮箱
原始 KB 编号: 982678
症状
尝试使用 Outlook 在 Microsoft Exchange Server 2010 服务器上打开邮箱时,会收到以下错误消息之一:
错误消息 1:
无法打开默认电子邮件文件夹。 尝试登录到 Microsoft Exchange 失败。
错误消息 2:
Outlook 无法登录。 验证是否已连接到网络,并使用正确的服务器和邮箱名称。
错误消息 3:
无法打开默认电子邮件文件夹。 path_to_OST的文件不是脱机文件夹文件。
原因
如果满足以下条件之一,则会出现此问题:
Exchange Server 2010 邮箱角色和 Exchange Server 2010 客户端访问服务器 (CAS) 角色安装在同一台服务器上。 因此,RpcClientAccessServer 邮箱数据库属性引用此服务器的地址。 从此服务器卸载 Exchange Server 2010 CAS 角色时,RpcClientAccessServer 属性不会更改。 邮箱数据库属性仍引用原始 Exchange Server 2010 服务器地址,即使该服务器上未安装 Exchange Server 2010 CAS。
从服务器中卸载 Exchange 2010 CAS 角色。 但是,卸载过程不会完全删除所有设置。 RpcClientAccessServer 邮箱数据库属性仍引用此服务器地址。
数据库中
LegacyExchangeDN
的属性已更改为不正确的值。
解决方案
若要解决此问题并将邮箱数据库属性更改为 RpcClientAccessServer
正确的值,请执行以下步骤:
注意
在此过程中,属性LegacyExchangDN
将更新为 Exchange Server 服务器的正确值。
单击“开始”,指向“所有程序”,指向“Exchange Server 2010”,然后单击“Exchange 命令行管理程序”。
在命令提示符下,键入
Get-MailboxDatabase <database_name> | fl Name, RpcClientAccessServer
cmdlet,然后按 Enter。返回的值可能不是 Exchange Server 2010 CAS 服务器或 Exchange Server 2010 CAS 数组) FQDN (完全限定的域名。 如果出现此行为,请
Set-MailboxDatabase <database_name> -RpcClientAccessServer <FQDN_of_CAS>
键入 cmdlet,然后按 Enter。注意
FQDN_of_CAS<>占位符是 Exchange Server 2010 CAS 服务器或 Exchange Server 2010 CAS 数组的 FQDN。