Excel JavaScript API 要求集Excel JavaScript API requirement sets

要求集是指各组已命名的 API 成员。Office 加载项使用清单中指定的要求集或执行运行时检查,以确定 Office 主机是否支持加载项所需的 API。有关详细信息,请参阅 Office 版本和要求集Requirement sets are named groups of API members. Office Add-ins use requirement sets specified in the manifest or use a runtime check to determine whether an Office host supports APIs that an add-in needs. For more information, see Office versions and requirement sets.

要求集可用性Requirement set availability

Excel 加载项可在多个 Office 版本中运行,包括 Windows 版 Office 2016 或更高版本、Office 网页版、Mac 版 Office 和 iPad 版 Office。Excel add-ins run across multiple versions of Office, including Office 2016 or later on Windows, and Office on the web, Mac, and iPad. 下表列出了 Excel 要求集、支持各要求集的 Office 主机应用程序,以及这些应用程序的内部版本或版本号。The following table lists the Excel requirement sets, the Office host applications that support that requirement set, and the build versions or number for those applications.

备注

若要在任何编号的要求集中使用 API,你应该引用 CDN 上的生产库:https://appsforoffice.microsoft.com/lib/1/hosted/office.js。To use APIs in any of the numbered requirement sets, you should reference the production library on the CDN: https://appsforoffice.microsoft.com/lib/1/hosted/office.js.

有关使用预览 API 的信息,请参阅 Excel JavaScript 预览 API 一文。For information about using preview APIs, see the Excel JavaScript preview APIs section within this article.

要求集Requirement set Windows 版 OfficeOffice on Windows
(已连接到 Office 365 订阅)(connected to Office 365 subscription)
iPad 版 OfficeDebug Office Add-ins on iPad and Mac
(已连接到 Office 365 订阅)(connected to Office 365 subscription)
Mac 版 OfficeOffice apps on Mac
(已连接到 Office 365 订阅)(connected to Office 365 subscription)
Office 网页版Office on the web
预览Preview 请使用最新的 Office 版本来试用预览 API(你可能需要加入 Office 预览体验成员计划Please use the latest Office version to try preview APIs (you may need to join the Office Insider program)
ExcelApi 1.9ExcelApi 1.9 版本 1903 (内部版本 11425.20204) 或更高版本Version 1903 (Build 11425.20204) or later 2.24 或更高版本2.24 or later 16.24 或更高版本16.24 or later 2019 年 5 月May 2019
ExcelApi 1.8ExcelApi 1.8 版本 1808(内部版本 10730.20102)或更高版本Version 1808 (Build 10730.20102) or later 2.17 或更高版本2.17 or later 16.17 或更高版本16.17 or later 2018 年 9 月September 2018
ExcelApi 1.7ExcelApi 1.7 版本 1801(内部版本 9001.2171)或更高版本Version 1801 (Build 9001.2171) or later 2.9 或更高版本2.9 or later 16.9 或更高版本16.9 or later 2018 年 4 月April 2018
ExcelApi 1.6ExcelApi 1.6 版本 1704(生成号 8201.2001)或更高版本Version 1704 (Build 8201.2001) or later 2.2 或更高版本2.2 or later 15.36 或更高版本15.36 or later 2017 年 4 月April 2017
ExcelApi 1.5ExcelApi 1.5 版本 1703(内部版本 8067.2070)或更高版本Version 1703 (Build 8067.2070) or later 2.2 或更高版本2.2 or later 15.36 或更高版本15.36 or later 2017 年 3 月March 2017
ExcelApi 1.4ExcelApi 1.4 版本 1701(内部版本 7870.2024)或更高版本Version 1701 (Build 7870.2024) or later 2.2 或更高版本2.2 or later 15.36 或更高版本15.36 or later 2017 年 1 月January 2017
ExcelApi 1.3ExcelApi 1.3 版本 1608(内部版本 7369.2055)或更高版本Version 1608 (Build 7369.2055) or later 1.27 或更高版本1.27 or later 15.27 或更高版本15.27 or later 2016 年 9 月September 2016
ExcelApi 1.2ExcelApi 1.2 版本 1601(内部版本 6741.2088)或更高版本Version 1601 (Build 6741.2088) or later 1.21 或更高版本1.21 or later 15.22 或更高版本15.22 or later 2016 年 1 月January 2016
ExcelApi 1.1ExcelApi 1.1 版本 1509(内部版本 4266.1001)或更高版本Version 1509 (Build 4266.1001) or later 1.19 或更高版本1.19 or later 15.20 或更高版本15.20 or later 2016 年 1 月January 2016

备注

通过 MSI 安装的 Office 2016 的内部版本号为 16.0.4266.1001。The build number for Office 2016 installed via MSI is 16.0.4266.1001. 此版本只包含 ExcelApi 1.1 要求集。This version only contains the ExcelApi 1.1 requirement set.

Office 版本和内部版本号Office versions and build numbers

有关 Office 版本和内部版本号的详细信息,请参阅:For more information about versions, build numbers, and Office Online Server, see:

另请参阅See also