使用代理自动配置文件时,Outlook 2016 for Mac崩溃

症状

请考虑以下情况:

  • 在配置为使用代理自动配置 (PAC) 文件的 Mac 计算机上使用 Microsoft Outlook 2016 for Mac。
  • 尝试使用 HTTP 协议访问远程资源。

在这种情况下,Outlook 2016 for Mac崩溃。

原因

在 Mac 操作系统的 自动代理配置 设置中使用基于文件的 PAC 文件时,会出现此问题。

注意

基于文件的 PAC 文件是其 URL 以 file:// 开头的文件。

解决方案

若要解决此问题,请在可以使用 HTTP 协议访问的 Web 服务器上托管 PAC 文件,然后在 Mac 操作系统中高级网络首选项的自动代理配置设置中指定文件的 URL。

若要在 Mac 操作系统中编辑自动代理配置设置,请执行以下步骤:

  1. 打开“系统首选项”。
  2. 选择“网络”
  3. 选择“高级”
  4. 选择“ 代理 ”选项卡。
  5. “选择要配置的协议”下,选择“ 自动代理配置”。
  6. 输入托管的 PAC 文件的 URL。

更多信息

  • 与支持人员交谈

    若要报告问题或提供反馈,请转到帮助>联系Outlook for Mac中的支持人员

  • 询问社区

    获取 Microsoft 365 和 Office 专家的帮助。

第三方信息免责声明

本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。

Microsoft 提供了第三方联系信息,以便你寻求技术支持。 该联系信息如有更改,恕不另行通知。 Microsoft 不保证此第三方联系信息的准确性。

本文档中的信息和解决方案代表在本文发布之时 Microsoft 公司对这些问题的最新观点。 此解决方案通过 Microsoft 或第三方供应商提供。 Microsoft 并不明确建议使用本文中述及的任何第三方供应商产品或第三方解决方案。 可能还存在其他一些本文未提及的第三方提供商或第三方解决方案。 因为 Microsoft 必须响应不断变化的市场形势,所以此信息不应解释为 Microsoft 一方的承诺。 Microsoft 不担保或认可由 Microsoft 或提到的任何第三方供应商提供的任何信息或任何解决方案的准确性。

Microsoft 不作任何担保,并拒绝所有明示、暗示或法定的表述、担保和条件。 这些内容包括但不限于有关任何服务、解决方案、产品或任何其他材料或信息的所有权、非侵权、令人满意的条件、适销性和针对特定用途的适用性的陈述、保证或条件。 在任何情况下,对于本文中提到的任何第三方解决方案,Microsoft 概不负责。