在 Outlook 2016 for Mac 中使用新式验证时,会反复提示您输入凭据

原始 KB 编号:   3156719

症状

You're using Outlook 2016 for Mac version 15.20 or later versions to connect to an Exchange Online mailbox through a federated account, and modern authentication is enabled.

尝试连接到 Exchange Online 邮箱时,将显示提供程序的 Active Directory 联合身份验证服务 (AD FS) 身份验证对话框,然后输入凭据。 但是,在输入凭据后,会反复提示您输入凭据。

原因

如果满足下列条件,则会出现此问题:

  • 您的电子邮件地址不同于用户主体名称 (UPN) 。
  • You entered your email address in the User name field of the Accounts dialog box in Outlook 2016 for Mac.

在这种情况下,您必须手动在提供商的"AD FS"对话框的"用户名"字段中输入 UPN。

解决方案

在"帐户"对话框的"用户名"字段中输入UPN,然后退出并重新启动 Outlook 2016 for Mac。

"Outlook 2016 for Mac 帐户"对话框的屏幕截图

更多信息

如果您不知道 UPN,请与管理员联系。

有关 UPN 的信息,请参阅 用户名格式