在 Outlook 2016 for Mac 中使用新式身份验证时,系统反复提示输入凭据

原始 KB 编号: 3156719

症状

你正在使用 Outlook 2016 for Mac 版本 15.20 或更高版本通过联合帐户连接到Exchange Online邮箱,并且已启用新式身份验证。

尝试连接到 Exchange Online 邮箱时,会显示提供商的“Active Directory 联合身份验证服务 (AD FS) 身份验证”对话框,并输入凭据。 但是,在输入凭据后,系统会反复提示你输入凭据。

原因

如果满足以下条件,则会出现此问题:

  • 电子邮件地址与 UPN) (用户主体名称不同。
  • 您在 Outlook 2016 for Mac 的“帐户”对话框的“用户名”字段中输入了电子邮件地址。

在这种情况下,必须在提供程序的“AD FS”对话框的“用户名”字段中手动输入 UPN。

解决方案

在“帐户”对话框的“用户名”字段中输入 UPN,然后退出并重启Outlook 2016 for Mac。

“Outlook 2016 for Mac帐户”对话框的屏幕截图。

更多信息

如果不知道 UPN,请与管理员联系。

有关 UPN 的详细信息,请参阅 用户名格式