创建新的 Microsoft 365 组后,组所有者不会显示搜索结果

症状

当 Microsoft 365 组的所有者通过以下搜索引擎之一执行 SharePoint Online 搜索时:

  • Microsoft 365 搜索框
  • 企业级搜索中心
  • 设计自定义搜索 Web 部件
  • 通过 CSOM/REST 搜索 API 进行查询

所有者在搜索结果中找不到内容。

原因

此问题是由于查询的安全修整 (基于用户的访问权限和成员身份进行筛选) 仅与安全组成员身份无关,而与组所有权无关。 Microsoft 365 组可以有一个不是成员的所有者。

解决方案

若要解决此问题,请确保所有者也是该组的成员。 然后,组所有者将显示所有搜索结果。

如果从管理门户创建组,你将看到该对话框:

Microsoft 365 管理中心中“新建组”窗体的屏幕截图。

可在此处定义组的所有者。 所有者不会自动添加为成员。

要使所有者成为组的第一类成员,并且能够搜索所有内容,必须通过配置对话框将所有者显式添加为组的成员:

可以在组的配置对话框中添加所有者的“所有者”和“成员”字段的屏幕截图。

更多信息

当管理员创建新的 Microsoft 365 组时,管理员并不总是添加为该组的成员。 成员身份设置取决于用于创建组的实际管理员对话。 如果所有者不是成员,则所有者无法从 Microsoft 365 搜索界面和 API 搜索组中的内容。 在 Microsoft 365 中的管理门户中创建新组时,通常会发生这种情况。

在某些情况下,这可能是预期行为。 如果管理员代表用户创建组,则可能不希望该管理员成为该组的成员。 管理员仍可以通过添加和删除组成员来管理组。

在其他情况下,这可能是无意的,并且会导致问题,因为组管理员也是组的参与者,但未能将自己添加为组成员。 如果从 Outlook 或 SharePoint 中的用户界面创建组,则这不是问题。 组创建者会自动成为成员。

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