OneDrive 或 SharePoint 上的“403 禁止访问”错误

症状

当你尝试从另一个用户与你共享的 OneDrive 或 SharePoint 网站访问文件时,你会收到以下错误消息:

错误:403 已禁止

原因

出现“403 禁止访问”错误的原因可能是以下条件之一:

  • 必须清除浏览器缓存。

  • 你对文件的权限未在服务器上正确复制。

  • OneDrive 网站已锁定。

  • 问题会影响组织的 SharePoint Online 服务。

解决方案

登录 Microsoft 365 时,请使用 Web 浏览器的可用隐私模式。 例如,在 Microsoft Edge 中使用 InPrivate 模式,或在 Google Chrome 中使用 Incognito 模式。 然后,尝试访问该文件。 若要了解如何浏览 InPrivate 窗口,请参阅 Microsoft Edge。 若要了解如何浏览 Incognito 窗口,请参阅 Google Chrome

如果在隐私模式下浏览时可以访问该文件,请清除浏览器缓存。 若要了解如何清除浏览器缓存,请参阅 EdgeChrome

如果这不能解决问题,请与组织的 SharePoint 或 OneDrive 管理员联系。 如果不知道是谁,请参阅如何实现查找我的 Microsoft 365 管理员?

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管理员的操作

如果清除缓存无法解决问题,请尝试以下方法。

重新共享文件

文件的权限可能未正确或完全复制。 要求用户等待 30 分钟,然后再尝试再次访问该文件。 如果错误在 30 分钟后仍出现,请尝试 SharePoint Online 中的“访问拒绝”、“需要访问此网站的权限”或“在目录中找不到用户”错误中列出的步骤,并OneDrive for Business。

检查 OneDrive 站点是否已锁定

用户的 OneDrive 网站可能处于锁定的“NoAccess”状态。 作为 Microsoft 365 中的全局管理员或 SharePoint 管理员,可以使用 PowerShell 或运行 Microsoft 365 诊断来解锁站点。 有关详细信息,请参阅 SharePoint 或 OneDrive 只读错误消息

检查服务运行状况

以管理员身份转到Microsoft 365 管理中心的“服务运行状况”页 (“运行状况>服务运行状况) ”。 检查可能发生的任何公告或事件。 如果 SharePoint Online 没有发生公告或事件,可以选择“ 报告问题 ”(如果可用),或者向 Microsoft 365 技术支持部门提出新的服务请求。

预配 OneDrive 网站

如果用户尝试访问未预配的 OneDrive 网站,则可能会出现错误 403。 让用户尝试从 Microsoft 365 门户导航到 OneDrive 磁贴。

如果这不起作用,请使用 Request-SPOPersonalSite cmdlet 预配网站。

访问其他用户的 OneDrive 数据

如果用户尝试访问其他用户(例如前员工)的 OneDrive 数据,则可以按照 步骤 4 - 授予其他员工对 OneDrive 和 Outlook 数据的访问权限中的步骤向用户授予权限。