安装产品时Visual C++ 可再发行程序包 2017 Visual Studio程序包"错误SharePoint Server 2019

症状

Microsoft SharePoint 2019 产品准备工具通过安装或启用所有必备组件成功运行并完成。 但在运行 Microsoft SharePoint Server 2019 安装程序时,会收到以下错误消息:

由于以下错误,安装程序无法继续进行 () :

  • 该产品需要 Visual C++ 可再发行程序包 2017 Visual Studio程序包。

原因

SharePoint 2019 产品准备工具将 Microsoft Visual C++ 2017 可再发行组件 (x64) 安装所需的最低版本SharePoint Server 2019错误。 在这种情况下,如果安装了 Visual C++ 2017 可再发行组件 (x64) ,但版本大于或等于 14.10.25017.0 且小于 14.13.26020.0,该工具将不会安装 SharePoint Server 2019 安装程序所需的最低版本。

解决方案

若要解决此问题,请使用下列方法之一。

方法 1

  1. 通过Microsoft Visual C++控制面板卸载 (2017) x64 Windows可再发行组件。
  2. 重新运行 Microsoft SharePoint 2019 产品准备工具。 该工具现在将安装 Visual C++2017 可再发行 (x64) 。
  3. 运行SharePoint Server 2019安装程序。

方法 2

  1. 从 下载并安装 Microsoft Visual C++ 2017 可再发行组件 (x64) 版本 14.13.26020.0 (或更高版本 https://go.microsoft.com/fwlink/?LinkId=848299) 。
  2. 运行SharePoint Server 2019安装程序。

更多信息

仍然需要帮助? 请转到 SharePoint 社区