OneDrive for Business同步返回错误“我们无法连接到指定的 SharePoint 网站”

症状

单击 Microsoft SharePoint 或 OneDrive for Business 中的“立即同步”时,将返回以下错误:

无法连接到指定的 SharePoint 网站

“OneDrive for Business同步错误消息”对话框的屏幕截图。

原因

如果按如下所示配置以下注册表值之一,则会出现此问题:

  • HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Common\SignIn

    名称:SignInOptions

    类型:DWORD

    数值:3

  • HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Common\SignIn

    名称:SignInOptions

    类型:DWORD

    数值:3

SignInOptions=3 限制您使用 Microsoft 或组织 ID 登录到 SharePoint 或 SharePoint Online。

注意

x.0 占位符表示 Office 版本 (16.0 = Office 2016、Office 2019、Office LTSC 2021 或 Microsoft 365 应用版,15.0 = Office 2013) 。

解决方案

重要

请仔细遵循本部分中的步骤进行操作。 对注册表修改不当可能会导致严重问题。 修改之前,备份注册表以便在发生问题时进行还原

若要解决此问题,请按照下列步骤操作:

  1. 单击“ 确定” 关闭同步窗口。

  2. 启动注册表编辑器。

  3. 找到并选择以下子项:

    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Common\SignIn

  4. 双击 “SignInOptions ”值。

  5. 在“ 值数据 ”框中,键入 0,然后单击“确定”。

  6. 退出注册表编辑器。

注意

如果 SignInOptions 值位于策略配置单元下,则它可能是由 组策略 创建的。 在这种情况下,管理员必须修改策略才能更改此设置。

更多信息

SignInOptions 值控制用户是否可以使用其 Microsoft 帐户 ID 或组织分配的用户 ID (组织 ID) 为 Microsoft 365 提供凭据。 可以使用以下值配置此设置:

  • 0 = 允许这两种 ID 类型
  • 1 = 仅允许使用 Microsoft 帐户 ID
  • 2 = 仅允许组织 ID
  • 3 = 用户无法使用任一类型的 ID 登录