尝试删除 Microsoft Entra ID 中的 B2C 目录时出错:无法删除“<contoso>”

本文介绍尝试删除 Microsoft Entra ID 中的 B2C 目录时出错的问题。

原始产品版本:Microsoft Entra ID
原始 KB 编号: 3112170

症状

在Microsoft Entra环境中,设置 B2C 目录,然后尝试将其删除。 但是,你会收到以下错误消息:

无法删除“<contoso>”
以下问题 () 阻止删除目录:
目录包含由用户或管理员添加的一个或多个应用程序

原因

如果现有的 B2C 应用程序服务主体 (例如 CPIM、Ibiza Portal 和 SSPR) 阻止删除,则会出现此问题。

解决方案

若要解决此问题,请使用 Azure 门户。

步骤 1:删除 Azure AD B2C 仪表板上列出的所有应用

为此,请按照下列步骤操作:

  1. 以有权访问 Azure AD B2C 目录的管理员身份登录Azure 门户

  2. 选择右上角的显示名称,然后选择 B2C 目录的目录。

    注意

    如果只有一个目录,则已选择 Azure AD B2C 目录。

  3. 若要查找“Azure AD B2C”边栏选项卡,请选择左下角的“更多服务 (>) ”按钮,然后在“B2C”上搜索。

  4. 选择“ Azure AD B2C”。

  5. 选择“ 所有设置”,然后选择“ 应用程序”。

    应用程序设置的屏幕截图。

  6. 删除所有应用程序。 为此,请选择应用程序,选择 “属性”,然后选择“ 删除 ”按钮。

    屏幕截图显示如何删除应用。

步骤 2:删除 Azure AD B2C 租户

为此,请按照下列步骤操作:

  1. 在 Azure AD B2C 目录中,找到并选择Azure 门户中的“Microsoft Entra ID”边栏选项卡。

  2. 在“ 概述 ”菜单上,选择“ 删除目录”。

  3. 按照门户中的说明进行操作。

联系我们寻求帮助

如果你有任何疑问或需要帮助,请创建支持请求联系 Azure 社区支持。 还可以向 Azure 反馈社区提交产品反馈。