Windows 10设备设置同步失败时出错:此用户无法登录,因为此帐户当前已禁用
本文介绍了当Windows 10设置无法同步时,会记录错误“事件 ID 6065:80070533此用户无法登录,因为此帐户当前已禁用”。
原始产品版本:Windows 10、版本 1803、版本 1709、版本 1703、版本 1511、版本 1607、所有版本
原始 KB 编号: 3193791
症状
已在Microsoft Entra 管理中心和某些Windows 10客户端上启用了企业状态漫游。 任何受支持的同步设置(例如桌面背景或任务栏位置)都不会在同一用户的设备之间同步。
此外,事件 ID 6065 记录在 Microsoft-Windows-SettingSync/Debug 事件日志中:
日志名称:Microsoft-Windows-SettingSync/Debug
源:Microsoft-Windows-SettingSync
日期: <日期和时间>
事件 ID:6065
任务类别:无
级别:错误
关键字:用户: <用户 SID>
计算机:WIN10DESKTOP
说明:shell\roaming\cloudsync\cloudsyncengine\cloudsyncengine.cpp (990) \SettingSyncHost.exe!00007FF701A2A8C2: (调用方: 00007FF70 1A2A3D9) ReturnHr[PreRelease] (17) tid (1060) 80070533 此用户无法登录,因为此帐户当前已禁用。 CallContext:[\AttemptSyncActivity]
原因
租户尚未使用 RMSBASIC 订阅进行预配。 在Microsoft Entra 管理中心中启用企业状态漫游并用于加密同步数据时,会自动发生这种情况。 如果在 AllowAdHocSubscriptions
租户上设置为 False ,则此配置可以防止使用 RMSBASIC 订阅预配租户。
注意
自 2024 年 3 月 30 日起,Azure AD 和 MSOnline PowerShell 模块已弃用。 若要了解详细信息,请阅读 弃用更新。 在此日期之后,对这些模块的支持仅限于 Microsoft Graph PowerShell SDK 和安全修补程序的迁移帮助。 弃用的模块将继续运行到 2025 年 3 月 30 日。
建议迁移到 Microsoft Graph PowerShell,以便与以前为 Azure AD) Microsoft Entra ID (交互。 有关常见的迁移问题,请参阅 迁移常见问题解答。 注意: MSOnline 1.0.x 版可能会在 2024 年 6 月 30 日之后遇到中断。
解决方案
验证是否在租户上启用了 RMSBASIC 订阅
打开 PowerShell 并使用Microsoft Entra凭据登录到Microsoft Entra ID。 第一行将提示输入凭据。 第二行连接到Microsoft Entra ID。
$msolcred = get-credential connect-msolservice -credential $msolcred
运行以下 cmdlet 以查看公司拥有的所有 SKU。
Get-MsolAccountSku
如果列出了 RMSBASIC(如下面的示例输出中所示),则无需继续执行本文中的其余步骤。
AccountSkuId ActiveUnits WarningUnits ConsumedUnits --------------- ------------ --------------- ----------------- tenantname:ENTERPRISEPACK 25 0 14 tenantname:INTUNE_A 25 0 23 tenantname:AAD_PREMIUM 100 0 21 tenantname:RIGHTSMANAGEMENT_ADHOC 1000 0 18 tenantname:RMSBASIC 1000 0 18 如果不存在 RMSBASIC(如下面的示例输出中所示),请继续执行下一部分中的步骤。
AccountSkuId ActiveUnits WarningUnits ConsumedUnits --------------- ------------ --------------- ----------------- tenantname:ENTERPRISEPACK 25 0 14 tenantname:INTUNE_A 25 0 23 tenantname:AAD_PREMIUM 100 0 21 tenantname:RIGHTSMANAGEMENT_ADHOC 1000 0 18
验证租户上的 AllowAdHocSubscriptions 是否设置为“True”
如果在 AllowAdHocSubscriptions
租户上设置为 False ,则无法使用 RMSBASIC 订阅预配租户。 使用这些步骤验证 的配置 AllowAdHocSubscriptions
,并暂时将其设置为 True 以获取 RMSBASIC 订阅。
打开 PowerShell 并使用Microsoft Entra凭据登录到Microsoft Entra ID。 第一行将提示输入凭据。 第二行连接到Microsoft Entra ID。
$msolcred = get-credential connect-msolservice -credential $msolcred
运行以下 cmdlet 以确定租户已
AllowAdHocSubscriptions
设置为 True 还是 False。Get-MsolCompanyInformation | fl AllowAdHocSubscriptions
如果
AllowAdHocSubscriptions
设置为 True,则无需继续执行其余步骤。 如果为 False,则可以运行以下命令来启用AllowAdHocSubscriptions
。 可以在后面的步骤中将其设置回 False 。Set-MsolCompanySettings -AllowAdHocSubscriptions $true
在Microsoft Entra 管理中心中,禁用并重新启用企业状态漫游。 请参阅 在租户上验证用户是否可以同步设置和企业应用数据 部分。
Get-MsolAccountSku
运行 cmdlet,查看是否已添加 RMSBASIC 订阅:Get-MsolAccountSku
验证租户上是否启用了“用户可以同步设置”和“企业应用数据”
获取高级Microsoft Entra订阅后,请按照以下步骤启用企业状态漫游:
- 登录到 Azure 经典门户。
- 在左侧,选择“ ACTIVE DIRECTORY”,然后选择要为其启用 企业状态漫游的目录。
- 转到“ 配置 ”选项卡。
- 向下滚动页面,查找“用户可能同步设置和企业应用数据”,并验证是否已选中“全部”或“已选择”。
- 如果已选择 “全部 ”或“ 选定 ”,请选择“无”,保存,然后使用原始 SG 选项返回到以前选择的 “全部 ”或“ 选定 ”,然后再次保存。 有关屏幕截图的参考,请参阅在 Microsoft Entra ID 中启用企业状态漫游。
(可选) 在租户上将 AllowAdHocSubscriptions 设置为“False”
如果要将 AllowAdHocSubscriptions 重新设置为 False,请在租户上预配 RMSBASIC 订阅后使用此 cmdlet:
Set-MsolCompanySettings -AllowAdHocSubscriptions $false
更多信息
- Azure Active Directory PowerShell 模块
- Get-MsolAccountsku
- Set-MsolCompanySettings
- 管理员如何控制为个人 RMS 创建的帐户
- 50,000 个席位分配给Office 365组织中的RIGHTSMANAGEMENT_ADHOC SKU
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