尝试连接到 Microsoft Entra ID 时出现“无法对凭据进行身份验证”错误

原始产品版本:Microsoft Entra ID、云服务 (Web 角色/辅助角色) 、Microsoft Intune、Azure 备份、Office 365用户和域管理、Office 365标识管理
原始 KB 编号: 2929554

症状

尝试使用用于Windows PowerShell的 Azure Active Directory 模块连接到 Microsoft Entra ID 时,会收到以下错误消息:

Connect-MsolService : Unable to authenticate your credentials. Make sure that
your user name is in the format: <username>@<domain>. If this issue persists,
contact Support.

At line:1 char:1
+ Connect-MsolService
+ ~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : OperationStopped: (:) [Connect-MsolService], Mic
rosoftOnlineException
+ FullyQualifiedErrorId : 0x80048862,Microsoft.Online.Administration.Autom
ation.ConnectMsolService

注意

自 2024 年 3 月 30 日起,Azure AD 和 MSOnline PowerShell 模块已弃用。 若要了解详细信息,请阅读 弃用更新。 在此日期之后,对这些模块的支持仅限于 Microsoft Graph PowerShell SDK 和安全修补程序的迁移帮助。 弃用的模块将继续运行到 2025 年 3 月 30 日。

建议迁移到 Microsoft Graph PowerShell,以便与以前为 Azure AD) Microsoft Entra ID (交互。 有关常见的迁移问题,请参阅 迁移常见问题解答注意: MSOnline 1.0.x 版可能会在 2024 年 6 月 30 日之后遇到中断。

原因

如果满足以下条件之一,则会出现此问题:

  • 输入用户名时使用了不正确的格式。
  • 用户帐户已启用Microsoft Entra多重身份验证。

解决方案

请根据自己的情况执行以下操作之一。

方案 1:输入用户名时使用了不正确的格式

输入用户名时使用以下格式:

<user_name >@<domain>

例如, john@contoso.com 采用正确的格式。 输入 johncontoso\john 不起作用。

方案 2:用户帐户已启用Microsoft Entra多重身份验证

如果用户帐户启用了Microsoft Entra多重身份验证,则 Microsoft 目前不支持使用 Azure Active Directory 模块来Windows PowerShell连接到Microsoft Entra ID。

若要使用用于Windows PowerShell的 Azure Active Directory 模块执行管理任务,请使用以下方法之一:

  • 禁用用户帐户Microsoft Entra多重身份验证。
  • 使用未启用Microsoft Entra多重身份验证的其他管理员帐户。

联系我们寻求帮助

如果你有任何疑问或需要帮助,请创建支持请求联系 Azure 社区支持。 还可以向 Azure 反馈社区提交产品反馈。