Windows 停止错误 - 未处理0x0000007E系统线程异常
本文提供的步骤可解决来宾操作系统 (来宾 OS) 遇到问题并尝试重启 Azure 虚拟机 (VM) 。 显示的错误消息显示“未处理系统线程异常”。
症状
使用启动诊断查看 VM 输出的屏幕截图时,会看到 Windows 需要重启并显示“系统线程异常未处理”停止代码或“0x0000007E”错误代码。
原因
在分析内存转储文件之前,无法确定原因。 继续收集内存转储文件。
解决方案
提示
如果最近备份了 VM,可以尝试 从备份还原 VM 以修复启动问题。
若要解决此问题,首先需要收集崩溃的内存转储文件,然后将该文件发送给 Microsoft 支持部门。 若要收集转储文件,请按照接下来两节中的说明进行操作。
第 1 部分:将 OS 磁盘附加到恢复 VM
获取受影响 VM 的 OS 磁盘快照以创建备份。 有关详细信息,请参阅Create虚拟硬盘的快照。
使用远程桌面协议 (RDP) 远程连接到恢复 VM。
如果受影响 VM 的 OS 磁盘已加密,请在转到下一步之前关闭加密。 有关详细信息,请参阅 解密加密的 OS 磁盘。
第 2 部分:找到转储文件并提交支持票证
在恢复 VM 上,转到附加 OS 磁盘上的 Windows 文件夹。 例如,如果分配给附加 OS 磁盘的驱动器号为 F,请转到 F:\Windows。
找到 Memory.dmp 文件,然后 提交支持票证 并附加转储文件。
注意
如果在查找 Memory.dmp 文件时遇到问题,可以尝试改用 串行控制台中的非屏蔽中断 (NMI) 调用 。 可以按照指南使用 NMI 调用生成故障转储文件。
后续步骤
联系我们寻求帮助
如果你有任何疑问或需要帮助,请创建支持请求或联系 Azure 社区支持。 还可以向 Azure 反馈社区提交产品反馈。
反馈
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即将发布:在整个 2024 年,我们将逐步淘汰作为内容反馈机制的“GitHub 问题”,并将其取代为新的反馈系统。 有关详细信息,请参阅:提交和查看相关反馈