以其他用户身份发送电子邮件时出现“无法以所选用户身份发送电子邮件”错误

本文可帮助你修复以下问题:在Microsoft Dynamics CRM中以其他用户身份发送电子邮件时,收到“无法以所选用户身份发送电子邮件”错误。

适用于:Microsoft Dynamics CRM Online、Microsoft Dynamics CRM 2016、Microsoft Dynamics CRM 2015、Microsoft Dynamics CRM 2013、2011 Microsoft Dynamics CRM
原始 KB 编号: 3184980

症状

尝试通过在 Microsoft Dynamics CRM 中将“发件人”字段设置为其他用户来发送电子邮件时,会收到以下错误消息:

“不能以所选用户身份发送电子邮件。 所选用户不允许这样做,或者您没有足够的权限执行此操作。 请与系统管理员联系以获取帮助。”

原因

如果存在以下条件之一,则会出现此问题:

  • Microsoft Dynamics CRM 中的安全角色缺少“以其他用户身份发送Email”权限。

    注意

    如果使用工作流规则发送电子邮件,则工作流规则的所有者需要此权限。

  • 你尝试以 身份发送的用户尚未启用允许其他用户像他们一样发送电子邮件的选项。

解决方案

若要解决此问题,请执行以下步骤,验证安全角色是否包括“以其他用户身份发送Email”权限。

  1. 使用具有系统管理员角色的用户登录到Microsoft Dynamics CRM。

  2. 导航到 “设置”,然后选择“ 安全>角色”。

  3. 打开分配给收到错误消息的用户的安全角色。

  4. 选择“ 业务管理 ”选项卡。

  5. 验证用户是否具有“以其他用户身份发送Email”权限。

    注意

    以其他用户身份发送Email”权限具有不同的深度级别。 用户需要具有此权限的足够深度,以匹配他们尝试发送的用户身份。 例如,如果尝试以 Dynamics CRM 内不同业务部门中的用户身份发送,则拥有此权限的业务部门级别访问权限是不够的,因为它只允许你以同一业务部门中的其他用户身份发送。

  6. 选择“保存”。

你还需要执行以下步骤来验证你尝试发送的用户是否启用了允许其他用户像他们一样发送电子邮件的选项。

  1. 以尝试发送电子邮件的用户身份登录Microsoft Dynamics CRM。
  2. 选择右上角的齿轮图标,然后选择“ 选项”。
  3. 选择“Email”选项卡。
  4. 验证是否选择了“允许其他Microsoft Dynamics CRM用户代表你发送电子邮件”选项。
  5. 选择“确定”。

更多信息

选择“ 下载日志 ”按钮时, “消息 ”部分将显示以下信息:

<消息>用户没有“发送”权限。</消息>