Microsoft Dynamics CRM预览/窗体区域在 Outlook 中不显示任何数据
本文解决了窗口底部Microsoft Dynamics CRM预览/窗体区域未显示任何信息的问题。
适用范围:Microsoft Dynamics CRM
原始 KB 编号: 2617456
症状
使用 Microsoft Office Outlook 并且安装了 Outlook 客户端Microsoft Dynamics CRM时,窗口底部的Microsoft Dynamics CRM预览/窗体区域不显示任何信息。
原因
此问题可能是由以下条件之一引起的。
原因 1
早期版本的 Microsoft Office 留下了对旧对象库 (OLB) 文件的引用。 这通常包括早期版本的主互操作程序集。
原因 2
用户配置文件临时目录包含超过 65,535 个文件。 Outlook 使用临时文件进行窗体区域存储。 但是,如果用户的临时目录包含超过 65,535 个文件,则 Outlook 无法初始化窗体区域。
原因 1 的解决方法
重要
此部分(或称方法或任务)介绍了修改注册表的步骤。 但是,注册表修改不当可能会出现严重问题。 因此,请务必严格按照这些步骤操作。 为了加强保护,应先备份注册表,再进行修改。 如果出现问题,可以还原注册表。 有关如何备份和还原注册表的详细信息,请参阅: 如何在 Windows 中备份和还原注册表。
依次选择“ 开始”、“ 所有程序”、“ 附件”和“ 运行”。
在“ 运行 ”对话框中,输入 regedit,然后选择“ 确定”。
在注册表编辑器中,找到以下配置单元:
HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}\9.3
找到 PrimaryInteropAssemblyName 字符串值,然后确定版本,如以下示例中的粗体元素所示:
PrimaryInteropAssemblyName“=”Microsoft.Office.Interop.Outlook,Version =12.0.0.0,Culture=neutral,PublicKeyToken=71E9BCE111E9429C
如果版本为 12.0.0.0,则必须删除 9.3 文件夹配置单元,因为它对应于 2007 Microsoft Office 系统。
原因 2 的解决方案
- 依次选择“ 开始”、“ 所有程序”、“ 附件”和“ 运行”。
- 在“ 运行 ”对话框中,输入 %localappdata%,然后选择“ 确定”。
- 打开 Temp 文件夹。
- 删除以
Olk
开头的任何.tmp文件。