无法加载此应用,因为 Microsoft Dynamics 365 App for Outlook 中未配置约会、联系人和任务的Dynamics 365服务器端同步错误

本文提供了在尝试打开 Dynamics 365 App for Outlook 时发生的错误的解决方案。

适用于:Microsoft Dynamics 365
原始 KB 编号: 4469522

症状

尝试打开 Dynamics 365 App for Outlook 时,收到以下错误:

“很抱歉
我们无法加载此应用,因为你的电子邮件帐户未配置约会、联系人和任务的Dynamics 365服务器端同步。 请系统管理员为约会、联系人和任务设置服务器端同步。”

如果选择“ 显示详细信息”,则会看到更多详细信息,如以下消息:

“错误:Email帐户未配置约会、联系人和任务的服务器端同步跟踪:错误:Email帐户未配置约会、联系人和任务的服务器端同步”

原因

Dynamics 365 Outlook 应用要求为邮箱启用 Server-Side 同步。 当 Dynamics 365 中的邮箱未启用使用服务器端同步的约会、联系人和任务的同步时,会发生此错误

注意

邮箱之前可能已正确配置 Server-Side 同步。 但是,如果Dynamics 365邮箱的状态后来更改为失败状态,则会收到此错误,直到邮箱配置正确并再次启用。

解决方案

使用 Server-Side 同步验证邮箱是否为传入电子邮件启用。

  1. 以具有系统管理员角色的用户身份访问Dynamics 365。
  2. 导航到“设置”,然后选择“Email配置”。
  3. 选择“ 邮箱 ”,然后将视图更改为 “活动邮箱”。
  4. 找到并打开遇到错误的用户的邮箱记录。
  5. 验证“约会”、“联系人”和“任务”选项是否设置为“服务器端同步”或“Email路由器”。
  6. 如果 “约会”、“联系人”和“任务状态 ”尚未显示为 “成功”,请选择“ 测试 & 启用邮箱 ”,并确保选中对话框中显示的复选框。
  7. 如果邮箱测试不成功,请查看 “警报 ”部分中的邮件。 如果警报包含“了解详细信息”链接,请选择此链接以获取更多详细信息。 如果在选择“测试 & 启用邮箱”后仍然看到失败,请参阅在Dynamics 365中单击“测试 & 启用邮箱”后失败,以获取更多指导。
  8. 邮箱显示“约会成功”、“联系人”和“任务状态”后,关闭并重新打开 Outlook。 然后再次尝试打开Dynamics 365 Outlook 应用。
  9. 如果在邮箱成功测试 & 已启用后继续显示此邮件,并且关闭并重新打开 Outlook,则如果用户是多个Dynamics 365实例的成员,并且应用是从邮箱未经过测试 & 启用的其他实例部署的,则可能会出现此消息。

更多信息

如果在邮箱成功测试 & 已启用后继续显示此邮件,并且关闭并重新打开 Outlook,则如果用户是多个Dynamics 365实例的成员,并且应用是从邮箱未经过测试 & 启用的其他实例部署的,则可能会出现此消息。

示例:组织有多个Dynamics 365实例,例如生产实例 (实例 A) ,另一个实例用于测试实例 B () 。 如果在实例 A 中为 Server-Side 同步启用了邮箱,但仍看到此消息,则可能是因为该应用上次从实例 B 部署到此用户的 Exchange 邮箱。

如果这可能是原因,请执行以下步骤:

  1. 打开用户将用于连接到Dynamics 365的 Web 应用程序。
  2. 导航到“设置”区域,然后选择“Dynamics 365 Outlook 应用”。
  3. 从“所有符合条件的用户”列表中选择 该用户
  4. 选择“ 将应用添加到 Outlook ”按钮。
  5. “状态”应切换到 “挂起”。 在大约 15 分钟内,应用应重新部署到此用户的邮箱并连接到此实例。