尝试在 Microsoft Dynamics CRM 中跟踪电子邮件时 Outlook 崩溃

本文提供了一种解决方法和解决方法,可解决尝试在 Microsoft Dynamics CRM 中跟踪电子邮件时 Microsoft Outlook 崩溃的问题。

适用于:Microsoft Dynamics CRM 2016、Microsoft Dynamics CRM 2015、Microsoft Dynamics CRM 2013、Outlook 2016、Outlook 2013、Microsoft Outlook 2010
原始 KB 编号: 3142993

症状

在带有附件的电子邮件中选择“ 在 CRM 中跟踪 ”或“ 设置” 时,Microsoft Outlook 崩溃。

此外,在应用程序事件日志中,你可能会发现事件 ID 为 1000 的以下一个或多个崩溃签名:

应用程序名称 应用程序版本 模块名称 模块版本 Offset
Outlook 2010
Outlook.exe 14.0.7165.5000 exsec32.dll 14.0.7159.5000 0x00007D06
Outlook.exe 14.0.7160.5000 exsec32.dll 14.0.7159.5000 0x00000000000023C5
Outlook.exe 14.0.6109.5005 exsec32.dll 14.0.6019.1000 0x00007C50
Outlook 2013
Outlook.exe 15.0.4763.1000 exsec32.dll 15.0.4759.1000 0x000076BD
Outlook.exe 15.0.4551.1004 exsec32.dll 15.0.4551.1001 0x000076a7
Outlook 2016
Outlook.exe 16.0.6366.2036 exsec32.dll 16.0.6366.1439 0x00003F99
Outlook.exe 16.0.4266.1001 exsec32.dll 16.0.4266.1001 0x00003F82
Outlook.exe 16.0.4266.1001 exsec32.dll 16.0.4266.1001 0x000000000000251F

原因

如果未将 Outlook 配置为使用缓存 Exchange 模式,则可能会出现此问题。 仅当使用缓存 Exchange 模式时,才支持 outlook Microsoft Dynamics CRM。

解决方案

若要解决此问题,请按照 Office 版本和安装类型的步骤进行操作。 请参阅更多信息部分,确定 Office 安装是基于即点即用还是基于 MSI。

Office 2016

Office 2016 的基于即点即用安装

若要解决此问题,请确保 Office 2016 即点即用安装版本为 16.0.6629.1000 或更高版本。 如果不是此版本或更高版本,请更新 Office 2013 安装。 为此,请按照下列步骤操作。

  1. 打开任意 Office 应用程序,例如 Outlook 或 Word。
  2. 选择“文件”,然后选择“Office 帐户”或“帐户”
  3. 查看 Office 汇报 下列出的版本
  4. 如果版本不是 16.0.6629.1000 或更高版本,请选择“ 更新选项”,然后选择“ 立即更新”。

注意

如果以前禁用了更新,请在选择“更新选项”后选择“启用更新”,然后选择“立即更新”。

有关Office 365客户端的更新通道的详细信息,请参阅按日期) 列出的Microsoft 365 应用版 (的更新历史记录

基于 MSI 的 Office 2016 安装

若要解决此问题,请安装 2017 年 2 月 7 日更新Outlook 2016。 有关此更新的信息,请参阅 2017 年 2 月 7 日更新Outlook 2016 (KB3141511)

Office 2013

基于即点即用的 Office 2013 安装

若要解决此问题,请确保 Office 2013 即点即用安装版本为 15.0.4833.1001 或更高版本。 如果不是此版本或更高版本,请更新 Office 2013 安装。 为此,请按照下列步骤操作。

  1. 打开任意 Office 应用程序,例如 Outlook 或 Word。
  2. 选择“文件”,然后选择“Office 帐户”或“帐户”
  3. 查看“Office 更新”下列出的版本。
  4. 如果版本不是 15.0.4833.1001 或更高版本,请选择“ 更新选项”,然后选择“ 立即更新”。

注意

如果以前禁用了更新,请在选择“更新选项”后选择“启用更新”,然后选择“立即更新”。

有关 Office 2013 的即点即用的详细信息,请参阅 Office 2013 的更新历史记录

基于 MSI 的 Office 2013 安装

若要解决此问题,请安装 Outlook 2013 的 2016 年 6 月 7 日更新。 有关此更新的信息,请参阅 2016 年 6 月 7 日 Outlook 2013 更新 (KB3115158)

解决方法

如果无法安装“解决方法”部分中提到的更新来解决此问题,则可以使用以下选项之一来解决此问题:

选项 1 - 启用缓存 Exchange 模式

使用以下文章中的步骤在 Outlook 中启用缓存 Exchange 模式:

打开或关闭缓存 Exchange 模式

选项 2 - 启用 Server-Side 同步

将用户Microsoft Dynamics CRM中的邮箱记录切换到服务器端同步或Email路由器,而不是 outlook Microsoft Dynamics CRM。 有关如何配置同步 Server-Side 的其他详细信息,请参阅以下文章。

设置电子邮件、约会、联系人和任务的服务器端同步

更多信息

若要确定 Office 安装是基于即点即用还是基于 MSI,请执行以下步骤:

  1. 打开 Office 应用,如 Outlook 或 Word。
  2. 在“ 文件 ”菜单上,选择“ 帐户 ”或“ Office 帐户”。
  3. 对于 Office 即点即用安装,将显示 “更新选项” 项。 对于基于 MSI 的安装,不显示 “更新选项” 项。