排查表视图问题

本文可帮助你排查和解决与表视图相关的问题。

问题 1 - 在表视图中看不到某些列中的数据

原因

出现此问题的原因是视图 ODATA 文件中的 和 fetchxml 列名layoutxml不匹配, (OrgUrl/api/data/Dynamics 365 version/savedqueries (ViewId) ) 。

解决方案

若要解决此问题,必须删除并添加回导致此问题的列。 这将确保 和 fetchxml 中的layoutxml列名称匹配。

注意

在开始解决问题之前,请记下发生此问题的视图。

  1. 转到 “设置>自定义>”“自定义系统”。

  2. 选择 “实体>视图 ”,然后选择存在此问题的视图。 在此示例中,我们将选择表 “帐户 ”,并查看为 “正在关注的帐户”。

    从表中选择视图。

  3. 选择“ 更多操作>编辑”。

    视图编辑页面随即打开。

    打开视图编辑页以编辑视图。

  4. 选择导致问题的列,然后选择“ 删除”。 在此示例中,我们选择要删除的主要联系人) Email (列。

    从视图中删除列。

    列将从视图中删除。

  5. 添加回已删除的列。 选择“ 添加列” 并读取已删除的列。 在此示例中,我们将添加已删除的主联系人) Email (列。

    添加回已删除的列。

    列中的数据正确显示。

问题 2 - 在表视图中看不到某些记录

原因

出现此问题的原因是对视图的数据进行筛选。

解决方案

若要解决此问题,必须编辑或删除视图的筛选器。 这将确保为视图正确应用筛选器。

注意

在开始解决问题之前,请记下发生此问题的视图。

  1. 转到 “设置>自定义>”“自定义系统”。

  2. 选择 “实体>视图 ”,然后选择存在此问题的视图。 在此示例中,我们将选择表 “帐户” ,并查看为 “我关注的帐户”。

    从表中选择视图。

  3. 选择“ 更多操作>编辑”。

    视图编辑页面随即打开。

    打开视图编辑页以编辑或删除筛选器。

  4. 选择 “编辑筛选条件 ”,并通过更新或删除来重新检查筛选条件。

    更新或清除筛选条件。

    视图中的记录正确显示。

问题 3 - 在商机、报价单、订单或发票子网格中看不到某些记录

处理商机、报价单、订单或发票记录时,可能会发现缺少一些记录。

原因

你可能看不到某些记录,因为对子网格进行了自定义而发生了错误。

解决方案

若要解决错误自定义的问题,请执行以下步骤,确保正确配置子网格:

  1. 在应用中的导航栏中,选择 “设置” 图标,然后选择“ 高级设置”。

    “设置”菜单中的“高级设置”链接。

    业务管理 设置”页将在新的浏览器选项卡中打开。

  2. 在导航栏上,选择“设置”,然后在“自定义”下,选择“自定义”。

  3. 选择 “自定义系统”。

  4. 在解决方案资源管理器的 “组件” 下,展开 “实体”,展开“ 机会”,然后选择“ 窗体”。

  5. 打开 Main 类型的“商机”窗体。

  6. 双击以选择“产品明细项”部分中的“Connections”部分。

    产品明细项子网格。

    设置属性 ”对话框随即打开。

    设置“机会产品”网格的属性。

  7. 在“ 控件 ”选项卡上,双击选择“ 可编辑网格”。

    双击“可编辑网格”选项。

  8. 请确保正确设置所有值:

    • 网格视图:商机产品内联编辑视图

    • 嵌套网格视图:选择铅笔图标并填写以下详细信息:

      “配置属性”对话框中的详细信息。

      • 表:商机产品
      • 查看:商机产品内联编辑视图:捆绑产品
    • 嵌套网格父 ID:parentbundleidref

    • 按列分组:已启用 (枚举)

    • 允许筛选:已启用 (枚举)

    • 隐藏嵌套网格列标题:隐藏列

      注意

      如果使用产品捆绑包并在产品网格中编辑这些捆绑的行项,请选择“ 隐藏嵌套网格列标题 ”作为 “显示列”。

问题 4 - 无法在“添加产品”对话框中将自定义视图设置为“现有产品”字段的默认视图

若要将产品添加到商机、报价单、订单或发票,请从“添加产品”对话框中的“ 现有产品 查找”字段中选择 产品 。 如果将查阅字段的默认视图更改为自定义视图,该字段不会显示自定义视图中的产品。

原因

为了能够显示所选价目表中的产品,查找始终默认为 父价目表中名为“产品”的系统视图。 因此,即使更改了默认值,查阅字段也会将默认设置为 “父价目表”视图中的“产品 ”。

解决方案

此行为按设计工作。 虽然无法设置默认视图,但可以手动切换到 “现有产品 查找”字段中的视图。

“添加产品”对话框中的“更改视图”选项。

问题 5 - 无法更新“产品”选项卡上的嵌套捆绑包项

原因

在“ 产品 ”选项卡上更新嵌套捆绑包项时,将禁用保存图标。 出现此问题的原因是嵌套网格列的标题隐藏在自定义 项中的“机会产品内联编辑视图 ”下。

解决方案

若要解决此问题,请按照以下步骤在商机表单上显示产品的嵌套网格列的标题。

  1. 在应用中的导航栏中,选择 “设置” 图标,然后选择“ 高级设置”。

    “设置”菜单上的“高级设置”。

    业务管理 设置”页将在新的浏览器选项卡中打开。

  2. 在导航栏上,选择“设置”,然后在“自定义”下,选择“自定义”。

  3. 选择 “自定义系统”。

  4. 在解决方案资源管理器的 “组件” 下,展开 “实体”,展开“ 机会”,然后选择“ 窗体”。

  5. 打开窗体类型 Main“商机”窗体。

  6. 在“ 产品明细项 ”部分中,双击以选择 “商机产品 ”部分。

    选择“商机产品”。

    设置属性 ”对话框随即打开。

    设置“机会产品”网格的属性。

  7. 在“ 控件 ”选项卡上,双击选择“ 可编辑网格”。

    在“控件”选项卡上选择“可编辑网格”。

  8. “可编辑网格 ”部分中,选择 “隐藏嵌套网格列标题”旁边的铅笔图标。

    选择“隐藏嵌套网格列标题”。

  9. 在“ 配置属性 ”对话框中的“ 绑定到静态选项”下,选择“ 显示列标题”。

    在“配置属性”对话框中选择“显示列标题”。

  10. 保存并发布配置。

问题 6 - 从站点地图中选择“机会”时,无法在旧 Web 客户端中查看机会记录,但可以在统一接口中看到它们

原因

记录基于表视图显示在列表中。 当没有将公共视图标记为表的默认视图时,可能会出现此问题。

解决方案

选择表的其中一个公共视图作为默认视图。 这可确保视图按预期显示。 若要了解如何将视图设置为默认视图,请参阅 指定模型驱动应用默认视图

注意

如果仍然看不到记录,请清除浏览器缓存,然后重试。